aboutsummaryrefslogtreecommitdiff
path: root/databases/pg_activity
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /databases/pg_activity
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'databases/pg_activity')
-rw-r--r--databases/pg_activity/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/pg_activity/Makefile b/databases/pg_activity/Makefile
index cbfe506de07a..7c1aa6b8f437 100644
--- a/databases/pg_activity/Makefile
+++ b/databases/pg_activity/Makefile
@@ -11,8 +11,8 @@ COMMENT= Htop like application for PostgreSQL server activity monitoring
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=0:databases/py-psycopg2 \
- ${PYTHON_PKGNAMEPREFIX}psutil>=0:sysutils/py-psutil
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=0:databases/py-psycopg2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=0:sysutils/py-psutil@${FLAVOR}
OPTIONS_DEFINE= DOCS
@@ -20,7 +20,7 @@ USE_GITHUB= yes
GH_ACCOUNT= julmon
USES= python:2.6+
-USE_PYTHON= autoplist distutils noegginfo
+USE_PYTHON= autoplist distutils noegginfo concurrent optsuffix
PYDISTUTILS_INSTALLARGS= --with-man
post-patch: