aboutsummaryrefslogtreecommitdiff
path: root/databases/pgaccess
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-11-15 10:32:42 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-11-15 10:32:42 +0000
commit08fa6d82d0662158909ff488fdecfc4371a0f153 (patch)
tree9bc6a44cff5ccb2b46ecb45b644df8c859c51146 /databases/pgaccess
parent59000e5ca41430bf4b9bed2f985e0e1e07e54f9e (diff)
downloadports-08fa6d82d0662158909ff488fdecfc4371a0f153.tar.gz
ports-08fa6d82d0662158909ff488fdecfc4371a0f153.zip
Maintainer update: downgrade to TCL 8.3 because the dependent port
requires that version. PR: ports/56884.
Notes
Notes: svn path=/head/; revision=94004
Diffstat (limited to 'databases/pgaccess')
-rw-r--r--databases/pgaccess/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/pgaccess/Makefile b/databases/pgaccess/Makefile
index 029cd470b21c..4f1d0a431187 100644
--- a/databases/pgaccess/Makefile
+++ b/databases/pgaccess/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= pgtcl:${PORTSDIR}/databases/postgresql-tcltk
USE_REINPLACE= yes
-TCL_VERSION?= 8.4
+TCL_VERSION?= 8.3
PGACCESSDOCDIR= ${PREFIX}/share/doc/postgresql/pgaccess
PGACCESSDIR= ${PREFIX}/share/postgresql/pgaccess
@@ -27,12 +27,12 @@ post-patch:
@${RM} ${WRKSRC}/lib/mainlib.tcl.bak
do-build:
-.for file in pgaccess.tcl pgmonitor
+.for targetfile in pgaccess.tcl pgmonitor
@ ${SED} -e "s,%%LOCALBASE%%,${LOCALBASE},g; \
s,%%TCL_VERSION%%,${TCL_VERSION},g; \
s,%%PREFIX%%,${PREFIX},g; \
- s,%%PROGRAM%%,${file},g" \
- < ${FILESDIR}/run-tcl-file > ${WRKDIR}/${file:R}.sh
+ s,%%PROGRAM%%,${targetfile},g" \
+ < ${FILESDIR}/run-tcl-file > ${WRKDIR}/${targetfile:R}.sh
.endfor
do-install:
@@ -41,8 +41,8 @@ do-install:
${TAR} cf - `${FIND} * ! \( -path win32\* -o -path doc\* \)` | \
( cd ${PGACCESSDIR}; ${TAR} xf - ) ; \
${CHOWN} -R 0:0 ${PGACCESSDIR}
-.for file in pgaccess pgmonitor
- ${INSTALL_SCRIPT} ${WRKDIR}/${file}.sh ${PREFIX}/bin/${file}
+.for targetfile in pgaccess pgmonitor
+ ${INSTALL_SCRIPT} ${WRKDIR}/${targetfile}.sh ${PREFIX}/bin/${targetfile}
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${PGACCESSDOCDIR} ; \