aboutsummaryrefslogtreecommitdiff
path: root/databases/pgbash/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 05:20:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 05:20:14 +0000
commit59f5611bc4d2b39af85996dcc438f2ae892c7571 (patch)
treedeff8ce281b8fddbdbf973c371c34cb56514c42d /databases/pgbash/Makefile
parent25e587e6b7adf7b75b4da9bd62ef9cba1c9d8a7f (diff)
downloadports-59f5611bc4d2b39af85996dcc438f2ae892c7571.tar.gz
ports-59f5611bc4d2b39af85996dcc438f2ae892c7571.zip
New port: databases/pgbash
pgBash is a bash shell with the ability to directly connect to a PostgreSQL Database and use it while still being at a shell prompt with all its features. PR: ports/54271 Submitted by: Sascha Holzleiter <sascha@root-login.org>
Notes
Notes: svn path=/head/; revision=96833
Diffstat (limited to 'databases/pgbash/Makefile')
-rw-r--r--databases/pgbash/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/databases/pgbash/Makefile b/databases/pgbash/Makefile
new file mode 100644
index 000000000000..a1fe546b9857
--- /dev/null
+++ b/databases/pgbash/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: pgbash
+# Date created: 6 July 2003
+# Whom: Sascha Holzleiter <sascha@root-login.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgbash
+PORTVERSION= 7.3
+CATEGORIES= databases
+MASTER_SITES= http://www.psn.co.jp/PostgreSQL/pgbash/:pgsource \
+ ${MASTER_SITE_GNU:S/$/:bashsrc/}
+MASTER_SITE_SUBDIR= bash/:bashsrc
+DISTFILES= pgbash-7.3.tar.gz:pgsource \
+ bash-2.05a.tar.gz:bashsrc
+EXTRACT_ONLY= pgbash-7.3.tar.gz
+
+MAINTAINER= sascha@root-login.org
+COMMENT= SQL Bash Shell for PostgreSQL
+
+LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql-client
+
+WRKSRC= ${WRKDIR}/pgbash-7.3/src/bash-2.05a
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-extract:
+ ${ECHO_MSG} ">>> extracting bash"
+ ${TAR} -C ${WRKDIR}/pgbash-7.3/src -xzf ${DISTDIR}/bash-2.05a.tar.gz
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|/etc/pgbashrc|${PREFIX}/etc/pgbashrc|g' \
+ ${WRKDIR}/pgbash-7.3/src/bash-2.05a-patch/shell.c.patch
+.for i in Makefile.in.patch builtins-Makefile.in.patch \
+ builtins-declare.def.patch builtins-mkbuilrins.c.patch \
+ builtins-set.def.patch builtins-setattr.def.patch configure.in.patch \
+ configure.patch parse.y.patch shell.c.patch variables.c.patch
+ ${PATCH} -d ${WRKSRC} -p1 < ${WRKDIR}/pgbash-7.3/src/bash-2.05a-patch/${i}
+.endfor
+
+do-configure:
+ cd ${WRKSRC}; ./configure --pginc-prefix=${LOCALBASE}/include --pglib-prefix=${LOCALBASE}/lib
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pgbash ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/pgbash-7.3/rc/pgbashrc ${PREFIX}/etc/pgbashrc-dist
+
+.include <bsd.port.mk>