aboutsummaryrefslogtreecommitdiff
path: root/databases/pgtune
diff options
context:
space:
mode:
authorGlen Barber <gjb@FreeBSD.org>2014-05-08 17:06:35 +0000
committerGlen Barber <gjb@FreeBSD.org>2014-05-08 17:06:35 +0000
commitdef3ec08f6cd4bc677e7eb9875677d6d9accbd87 (patch)
tree24f6e1e9120ad27791c56ceace6c02de5e7019e4 /databases/pgtune
parentb9034d8ac26bdb47068874b8d274b60e5d067bd9 (diff)
downloadports-def3ec08f6cd4bc677e7eb9875677d6d9accbd87.tar.gz
ports-def3ec08f6cd4bc677e7eb9875677d6d9accbd87.zip
Fix a few nits with databases/pgtune that cause runtime
problems: - Add USES=shebangfix - Replace USE_PYTHON=yes with USE_PYTHON=2+ - Fix shebang line to use python2.N - Bump PORTREVISION Reported by: pathiaki2@yahoo.com (via ports@) Redports ID: https://redports.org/buildarchive/20140508164000-29103/ Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=353334
Diffstat (limited to 'databases/pgtune')
-rw-r--r--databases/pgtune/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/databases/pgtune/Makefile b/databases/pgtune/Makefile
index 7de91cdaf89b..10f7b3ff7059 100644
--- a/databases/pgtune/Makefile
+++ b/databases/pgtune/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pgtune
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://pgfoundry.org/frs/download.php/2449/ \
https://www.glenbarber.us/ports/${CATEGORIES}/${PORTNAME}/
@@ -10,9 +11,17 @@ MASTER_SITES= http://pgfoundry.org/frs/download.php/2449/ \
MAINTAINER= gjb@FreeBSD.org
COMMENT= Postgresql.conf tuning tips based on hardware and load type
-USE_PYTHON= yes
+USES= shebangfix
+USE_PYTHON= 2+
NO_BUILD= yes
+SHEBANG_FILES= ${PORTNAME}
+python_OLD_CMD= ${PREFIX}/bin/python
+
+pre-install:
+ @${REINPLACE_CMD} -e 's|${python_OLD_CMD}|${PYTHON_CMD}|' \
+ ${WRKSRC}/${PORTNAME}
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/pgtune ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/share/pgtune/settings