aboutsummaryrefslogtreecommitdiff
path: root/databases/phpmyadmin/Makefile
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-08-17 13:10:27 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-08-17 13:10:27 +0000
commit4c75a7d5b46e64d9800ff1a2cb9335619f5d3e21 (patch)
treeadf68cf48c26ef27944c20779331c620e0142189 /databases/phpmyadmin/Makefile
parent5a998b6cece6ba82c81bc7c9ee1b8ef5d3811e0f (diff)
downloadports-4c75a7d5b46e64d9800ff1a2cb9335619f5d3e21.tar.gz
ports-4c75a7d5b46e64d9800ff1a2cb9335619f5d3e21.zip
Fix build -- the shebang files have been removed[1].
Placate portlint Reported by: Walter Schwarzenfeld [1]
Notes
Notes: svn path=/head/; revision=420343
Diffstat (limited to 'databases/phpmyadmin/Makefile')
-rw-r--r--databases/phpmyadmin/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 521573983008..68e7eb7d80fb 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= phpMyAdmin
DISTVERSION= 4.6.4
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= https://files.phpmyadmin.net/${PORTNAME}/${DISTVERSION}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
@@ -10,14 +11,14 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
MAINTAINER= matthew@FreeBSD.org
COMMENT= Set of PHP-scripts to manage MySQL over the web
-NO_ARCH= yes
LICENSE= GPLv2
BROKEN_powerpc64= Does not build
-USES= cpe shebangfix tar:xz
+USES= cpe php:web tar:xz
CPE_PRODUCT= ${PORTNAME:tl}
+NO_ARCH= yes
NO_BUILD= yes
.if !defined(WITHOUT_PHP_DEPENDS)
IGNORE_WITH_PHP=5 54
@@ -42,8 +43,6 @@ ZLIB_DESC= PHP ZLIB support
.include <bsd.port.options.mk>
-WANT_PHP_WEB= yes
-
GROUPS?= ${WWWGRP}
CFG_FILE= config.inc.php
@@ -54,9 +53,6 @@ SUB_LIST+= PKGNAME=${PKGNAME} \
CFG_FILE=${WWWDIR}/${CFG_FILE}
SUB_FILES+= pkg-message
-SHEBANG_FILES= libraries/plugins/transformations/generator_main_class.sh \
- libraries/plugins/transformations/generator_plugin.sh
-
.if !defined(WITHOUT_PHP_DEPENDS)
.for opt in ${OPTIONS_DEFINE} ${OPTIONS_MULTI_DB_connect}