aboutsummaryrefslogtreecommitdiff
path: root/databases/phpmyadmin/Makefile
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-05-04 06:24:53 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-05-04 06:24:53 +0000
commit7ceab773004c50f8d7dd36b80315ab18681e10d0 (patch)
tree5cad0c0729eb488d52fa9ce0cf3b3d20dae15cbe /databases/phpmyadmin/Makefile
parent3fcf6ba40cd5cd07621f3371d7c01fdce99b5dab (diff)
downloadports-7ceab773004c50f8d7dd36b80315ab18681e10d0.tar.gz
ports-7ceab773004c50f8d7dd36b80315ab18681e10d0.zip
- Copy databases/phpmyadmin to databases/phpmyadmin35
- Update databases/phpmyadmin to 4.0.0 Version 4.0.0 is the first release of a new major version, and involves some significant changes in functionality. In particular it now requires Javascript in order to operate. Provide a new phpmyadmin35 port to track the 3.5.x branch for those not wishing to upgrade yet. Note that you will have to adjust your httpd.conf if you switch to this port, as it installs the application to ${LOCALBASE}/www/phpMyAdmin35
Notes
Notes: svn path=/head/; revision=317295
Diffstat (limited to 'databases/phpmyadmin/Makefile')
-rw-r--r--databases/phpmyadmin/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 668c08de93af..684d4e41ffd8 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= phpMyAdmin
-DISTVERSION= 3.5.8.1
+DISTVERSION= 4.0.0
CATEGORIES= databases www
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}/${DISTVERSION}
DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
@@ -23,9 +23,9 @@ USE_PHP= ctype session filter mbstring json spl
# want this, either turn off GD in the config dialog, or else turn off
# FONTCONFIG in the graphics/gd port options.
-PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF ZIP ZLIB
+PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF XML ZIP ZLIB
OPTIONS_DEFINE= SUPHP ${PHP_MODULE_OPTIONS}
-OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF ZIP ZLIB
+OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF XML ZIP ZLIB
OPTIONS_MULTI= DB_connect
OPTIONS_MULTI_DB_connect= MYSQL MYSQLI
@@ -39,6 +39,7 @@ MYSQL_DESC= PHP MySQL support via mysql client
OPENSSL_DESC= PHP OpenSSL support
PDF_DESC= PHP PDFlib support
SUPHP_DESC= suPHP support
+XML_DESC= PHP XML support (Export to OpenDoc)
ZIP_DESC= PHP Zip compression support
ZLIB_DESC= PHP ZLIB support