aboutsummaryrefslogtreecommitdiff
path: root/databases/postgis
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-18 20:04:14 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-18 20:04:14 +0000
commit39565a0f8b355a1e59de8d219f9d2198d74edef4 (patch)
tree9a9544677393b5f228cb5749b8fd63fa45c2bbd2 /databases/postgis
parent67e8f6c61797759fe678cc1001d5aff6173acd1e (diff)
downloadports-39565a0f8b355a1e59de8d219f9d2198d74edef4.tar.gz
ports-39565a0f8b355a1e59de8d219f9d2198d74edef4.zip
Fix package building:
- Use WRKDIRPREFIX; - Replace the pre-extract target by BUILD_DEPENDS:configure + LIB_DEPENDS on postgresql7 (and then remove RUN_DEPENDS). Reported by: Kris / pointyhat.
Notes
Notes: svn path=/head/; revision=111761
Diffstat (limited to 'databases/postgis')
-rw-r--r--databases/postgis/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index e29dd90840c4..65b00a53049a 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -14,9 +14,9 @@ DISTNAME= postgis-${PORTVERSION}
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Adds support for geographic objects to PostgreSQL databases
-LIB_DEPENDS= proj.3:${PORTSDIR}/graphics/proj
-BUILD_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql7
-RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql7
+BUILD_DEPENDS= ${PGSQL_SRC}/src/Makefile.global:${PORTSDIR}/databases/postgresql7:configure
+LIB_DEPENDS= proj.3:${PORTSDIR}/graphics/proj \
+ pq:${PORTSDIR}/databases/postgresql7
USE_GMAKE= yes
USE_PERL5_BUILD= yes
@@ -24,20 +24,13 @@ MAKE_ARGS= PGSQL_SRC=${PGSQL_SRC}
PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/postgis-${PORTVERSION}
-PGSQL_SRC= ${PGSQL_PORTDIR}/work/postgresql-7.4.2
+PGSQL_SRC= ${WRKDIRPREFIX}${PGSQL_PORTDIR}/work/postgresql-7.4.2
INSTALL_TARGET= install
.if defined(WITH_GEOS)
LIB_DEPENDS+= geos.1:${PORTSDIR}/graphics/geos
.endif
-pre-extract:
- @if [ ! -d ${PGSQL_SRC} ] ; then \
- ${ECHO_MSG} "===> Extracting and configuring PostgreSQL source" ; \
- cd ${PGSQL_PORTDIR} ; \
- ${MAKE} configure ; \
- fi
-
post-extract:
.if ! defined(WITH_GEOS)
@ ${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig ; \