aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-jdbc
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-12-04 12:00:49 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-12-04 12:00:49 +0000
commit8a928af72d1ebb839a332158c27129b8a154275e (patch)
treec658c0da17e05366791dbe372c9e966663a70265 /databases/postgresql-jdbc
parent75d6fb12df9343cebb166dc9ac575ae77c24dd4d (diff)
downloadports-8a928af72d1ebb839a332158c27129b8a154275e.tar.gz
ports-8a928af72d1ebb839a332158c27129b8a154275e.zip
Introduce the world to PostgreSQL 7.4! By and large this release is
regarded as a major release with features with interest to those with large databases. The updates are extensive and the best source of info is in the release notes. Enjoy and direct questions to database@! Release notes: http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4 PR: ports/59403, ports/59404, ports/59393, ports/59394, ports/59395, ports/59397, ports/59398, ports/59402, && ports/59401 Submitted by: maintainer Approved by: marcus (portmgr@ hat)
Notes
Notes: svn path=/head/; revision=94977
Diffstat (limited to 'databases/postgresql-jdbc')
-rw-r--r--databases/postgresql-jdbc/Makefile15
-rw-r--r--databases/postgresql-jdbc/files/patch-aa19
2 files changed, 15 insertions, 19 deletions
diff --git a/databases/postgresql-jdbc/Makefile b/databases/postgresql-jdbc/Makefile
index a26e4d01eead..04997e9dcb94 100644
--- a/databases/postgresql-jdbc/Makefile
+++ b/databases/postgresql-jdbc/Makefile
@@ -4,27 +4,20 @@
#
# $FreeBSD$
#
-POSTGRESQL_PORT?= databases/postgresql7
-PORTNAME= postgresql
-PORTVERSION!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V PORTVERSION
-PORTREVISION?= 0
+PORTREVISION= 0
CATEGORIES= databases java
-MASTER_SITES= ${MASTER_SITE_PGSQL}
-MASTER_SITE_SUBDIR!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V MASTER_SITE_SUBDIR
PKGNAMESUFFIX= -jdbc
-DISTFILES!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V DISTFILES
-DIST_SUBDIR= postgresql
MAINTAINER= girgen@pingpong.net
COMMENT= The Java JDBC implementation for PostgreSQL
BUILD_DEPENDS= ${LOCALBASE}/bin/ant:${PORTSDIR}/devel/apache-ant
-MD5_FILE= ${.CURDIR}/../../${POSTGRESQL_PORT}/distinfo
+POSTGRESQL_PORT?= databases/postgresql7
+POSTGRESQL_SUBPORT=YES
+.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
-USE_GMAKE= YES
-GNU_CONFIGURE= YES
CONFIGURE_ARGS= --with-java
USE_JAVA= 1.1+
diff --git a/databases/postgresql-jdbc/files/patch-aa b/databases/postgresql-jdbc/files/patch-aa
index 44a6e7960a2c..5c186c265977 100644
--- a/databases/postgresql-jdbc/files/patch-aa
+++ b/databases/postgresql-jdbc/files/patch-aa
@@ -1,11 +1,14 @@
---- src/interfaces/jdbc/build.xml.orig Fri Mar 28 09:55:21 2003
-+++ src/interfaces/jdbc/build.xml Fri Mar 28 09:57:29 2003
-@@ -101,7 +101,7 @@
+--- src/interfaces/jdbc/build.xml.orig Mon Aug 25 00:10:09 2003
++++ src/interfaces/jdbc/build.xml Tue Nov 18 03:37:21 2003
+@@ -110,10 +110,7 @@
- <!-- This is the core of the driver. It is common for all three versions. -->
<target name="compile" depends="prepare,check_versions,driver">
-- <javac srcdir="${srcdir}" destdir="${builddir}" debug="${debug}">
-+ <javac includeAntRuntime="no" srcdir="${srcdir}" destdir="${builddir}" debug="${debug}">
- <include name="${package}/**" />
- <exclude name="${package}/jdbc1/**" unless="jdbc1"/>
+- <available classname="org.postgresql.Driver" property="old.driver.present" />
+- <fail message="Old driver was detected on classpath or in jre/lib/ext, please remove and try again." if="old.driver.present" />
+-
+- <javac classpath="{$srcdir}" srcdir="${srcdir}" destdir="${builddir}" debug="${debug}">
++ <javac includeAntRuntime="no" classpath="{$srcdir}" srcdir="${srcdir}" destdir="${builddir}" debug="${debug}">
+ <!-- This is the core of the driver. It is common for all three versions. -->
+ <include name="${package}/*.java" />
+ <include name="${package}/core/**" />