aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-06-12 22:07:12 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-06-12 22:07:12 +0000
commit1d8c38f8dfa78e75372b7e0e5509b28db3cfabff (patch)
tree8396706b8f10371ad8f151755405c6eab0e89930 /databases/postgresql-libpqxx/Makefile
parent6650773ab109c15b69e5205f04d8582535fb5bd5 (diff)
downloadports-1d8c38f8dfa78e75372b7e0e5509b28db3cfabff.tar.gz
ports-1d8c38f8dfa78e75372b7e0e5509b28db3cfabff.zip
- Update libpqxx to 4.0. [1]
- Update CONFLICTS in libpqxx30. - Add instructions to UPDATING for people willing to stick with version 3. Submitted by: arrowdodger via IRC [1]
Notes
Notes: svn path=/head/; revision=299158
Diffstat (limited to 'databases/postgresql-libpqxx/Makefile')
-rw-r--r--databases/postgresql-libpqxx/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 7a3f1e74573a..6b7752551a03 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libpqxx
-PORTVERSION= 3.1
+PORTVERSION= 4.0
CATEGORIES= databases
MASTER_SITES= http://pqxx.org/download/software/libpqxx/
PKGNAMEPREFIX= postgresql-
@@ -22,10 +22,16 @@ USE_PGSQL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+SOVERSION= 4
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ SOVERSION=${SOVERSION}
-CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
- --enable-shared \
- --with-postgres-include=${LOCALBASE}/include/postgresql
+CONFIGURE_ARGS= --enable-shared \
+ --disable-dependency-tracking
+
+post-install:
+# This is needed for ldconfig
+ ${LN} -s ${PREFIX}/lib/libpqxx-${PORTVERSION}.so \
+ ${PREFIX}/lib/libpqxx.so.${SOVERSION}
.include <bsd.port.mk>