aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx3
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-23 22:19:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-23 22:19:23 +0000
commit86ed82148813be256c98d954dd47860a0329dbc8 (patch)
treebedcf575891530725981dbfef2636458081f9b22 /databases/postgresql-libpqxx3
parent0de8ad7faf55a55093ee04dc9d558de41a9b47c1 (diff)
downloadports-86ed82148813be256c98d954dd47860a0329dbc8.tar.gz
ports-86ed82148813be256c98d954dd47860a0329dbc8.zip
Upgrade to 2.2.3.
Warning: broken on 4.x. PR: 68217 Submitted by: maintainer.
Notes
Notes: svn path=/head/; revision=112087
Diffstat (limited to 'databases/postgresql-libpqxx3')
-rw-r--r--databases/postgresql-libpqxx3/Makefile16
-rw-r--r--databases/postgresql-libpqxx3/distinfo4
-rw-r--r--databases/postgresql-libpqxx3/files/patch-Makefile.in11
-rw-r--r--databases/postgresql-libpqxx3/pkg-plist10
4 files changed, 32 insertions, 9 deletions
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
index 794265c66f7f..356e3870f217 100644
--- a/databases/postgresql-libpqxx3/Makefile
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libpqxx
-PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTVERSION= 2.2.3
CATEGORIES= databases
MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqxx/stable/
PKGNAMEPREFIX= postgresql-
@@ -16,14 +15,23 @@ DIST_SUBDIR= postgresql
MAINTAINER= girgen@pingpong.net
COMMENT= A new C++ interface for PostgreSQL
-POSTGRESQL_PORT?= databases/postgresql7
LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_LIBTOOL_VER=15
USE_GMAKE= YES
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
+ --enable-shared \
--with-postgres-include=${LOCALBASE}/include/postgresql
-.include <bsd.port.mk>
+POSTGRESQL_PORT?= databases/postgresql7
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "<ios> header missing on this platform"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/postgresql-libpqxx3/distinfo b/databases/postgresql-libpqxx3/distinfo
index c08d77f4499b..9a1f2fae6d50 100644
--- a/databases/postgresql-libpqxx3/distinfo
+++ b/databases/postgresql-libpqxx3/distinfo
@@ -1,2 +1,2 @@
-MD5 (postgresql/libpqxx-2.1.1.tar.gz) = 570a04c4758fead88ac555e7bc90f88b
-SIZE (postgresql/libpqxx-2.1.1.tar.gz) = 948902
+MD5 (postgresql/libpqxx-2.2.3.tar.gz) = 02d34b97dc77c51ef8c54eea6965fc91
+SIZE (postgresql/libpqxx-2.2.3.tar.gz) = 744455
diff --git a/databases/postgresql-libpqxx3/files/patch-Makefile.in b/databases/postgresql-libpqxx3/files/patch-Makefile.in
new file mode 100644
index 000000000000..730a3b577b48
--- /dev/null
+++ b/databases/postgresql-libpqxx3/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon May 10 14:37:09 2004
++++ Makefile.in Wed Jun 23 21:47:42 2004
+@@ -196,7 +196,7 @@
+ MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.log configure \
+ stamp-h.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(libdir)/libdata/pkgconfig
+ pkgconfig_DATA = libpqxx.pc
+ bin_SCRIPTS = pqxx-config
+ all: all-recursive
diff --git a/databases/postgresql-libpqxx3/pkg-plist b/databases/postgresql-libpqxx3/pkg-plist
index 3cf76a7ee609..891965a7093f 100644
--- a/databases/postgresql-libpqxx3/pkg-plist
+++ b/databases/postgresql-libpqxx3/pkg-plist
@@ -1,10 +1,10 @@
+bin/pqxx-config
include/pqxx/pqxx
include/pqxx/all.h
include/pqxx/binarystring
include/pqxx/binarystring.hxx
include/pqxx/cachedresult.h
include/pqxx/compiler.h
-include/pqxx/config.h
include/pqxx/connection
include/pqxx/connection.hxx
include/pqxx/connection.h
@@ -19,6 +19,7 @@ include/pqxx/dbtransaction.h
include/pqxx/except
include/pqxx/except.hxx
include/pqxx/except.h
+include/pqxx/internalconfig.h
include/pqxx/isolation
include/pqxx/isolation.hxx
include/pqxx/isolation.h
@@ -30,6 +31,8 @@ include/pqxx/libconfig.h
include/pqxx/nontransaction
include/pqxx/nontransaction.hxx
include/pqxx/nontransaction.h
+include/pqxx/pipeline
+include/pqxx/pipeline.hxx
include/pqxx/result
include/pqxx/result.hxx
include/pqxx/result.h
@@ -64,6 +67,7 @@ include/pqxx/util.h
lib/libpqxx.a
lib/libpqxx.la
lib/libpqxx.so
-lib/libpqxx.so.0
-lib/pkgconfig/libpqxx.pc
+lib/libpqxx-2.2.3.so
+lib/libdata/pkgconfig/libpqxx.pc
@dirrm include/pqxx
+@unexec rmdir %D/lib/libdata/pkgconfig 2>/dev/null || true