aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx4
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2018-01-12 16:26:29 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2018-01-12 16:26:29 +0000
commit22e94ad6fc2852e22d711429ff72472ca2594b2e (patch)
treec77f306e718be821640a05b75fb303acb8cadd1a /databases/postgresql-libpqxx4
parentfd2a05e4dd66ff909ead5b7f6a249f53752f2ac0 (diff)
downloadports-22e94ad6fc2852e22d711429ff72472ca2594b2e.tar.gz
ports-22e94ad6fc2852e22d711429ff72472ca2594b2e.zip
Update postgresql-libpqxx to latest version 6
Keep version 4 as a separate port Set license for the old version 3 port PR: 225109 Submitted by: Yuri Victorovich
Notes
Notes: svn path=/head/; revision=458857
Diffstat (limited to 'databases/postgresql-libpqxx4')
-rw-r--r--databases/postgresql-libpqxx4/Makefile30
-rw-r--r--databases/postgresql-libpqxx4/distinfo2
-rw-r--r--databases/postgresql-libpqxx4/pkg-descr18
-rw-r--r--databases/postgresql-libpqxx4/pkg-plist97
4 files changed, 147 insertions, 0 deletions
diff --git a/databases/postgresql-libpqxx4/Makefile b/databases/postgresql-libpqxx4/Makefile
new file mode 100644
index 000000000000..2ceeaab626fe
--- /dev/null
+++ b/databases/postgresql-libpqxx4/Makefile
@@ -0,0 +1,30 @@
+# Created by: Palle Girgensohn <girgen@pingpong.net>
+# $FreeBSD$
+
+PORTNAME= libpqxx
+PORTVERSION= 4.0.1
+PORTREVISION= 1
+CATEGORIES= databases
+MASTER_SITES= http://pqxx.org/download/software/libpqxx/
+PKGNAMEPREFIX= postgresql-
+PKGNAMESUFFIX= 4
+DIST_SUBDIR= postgresql
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= New C++ interface for PostgreSQL
+
+LICENSE= BSD3CLAUSE
+
+CONFLICTS= postgresql-libpqxx-3.* postgresql-libpqxx3-3.* postgresql-libpqxx-6.*
+PORTSCOUT= limit:^4\.
+
+USES+= gmake libtool pathfix pgsql python:2.7,build shebangfix
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+PLIST_SUB= PORTVERSION=${PORTVERSION:R}
+SHEBANG_FILES= ${WRKSRC}/tools/splitconfig
+
+CONFIGURE_ARGS= --enable-shared \
+ --disable-dependency-tracking
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-libpqxx4/distinfo b/databases/postgresql-libpqxx4/distinfo
new file mode 100644
index 000000000000..23b32e01115e
--- /dev/null
+++ b/databases/postgresql-libpqxx4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (postgresql/libpqxx-4.0.1.tar.gz) = 097ceda2797761ce517faa5bee186c883df1c407cb2aada613a16773afeedc38
+SIZE (postgresql/libpqxx-4.0.1.tar.gz) = 1582532
diff --git a/databases/postgresql-libpqxx4/pkg-descr b/databases/postgresql-libpqxx4/pkg-descr
new file mode 100644
index 000000000000..5697d09a3e4d
--- /dev/null
+++ b/databases/postgresql-libpqxx4/pkg-descr
@@ -0,0 +1,18 @@
+Welcome to libpqxx, the official C++ API to the PostgreSQL database
+management system.
+
+There are many similar libraries for PostgreSQL and for other
+databases, some of them database-independent. Most of these, however,
+are fairly C-like in their programming style, and fail to take
+advantage of the full power of the C++ language as it has matured
+since the acceptance of the Standard in 1996. What libpqxx brings you
+is effective use of templates to reduce the inconvenience of dealing
+with type conversions; of standard C++ strings to keep you from having
+to worry about buffer allocation and overflow attacks; of exceptions
+to take the tedious and error-prone plumbing around error handling out
+of your hands; of constructors and destructors to bring resource
+management under control; and even basic object-orientation to give
+you some extra reliability features that would be hard to get with
+most other database interfaces.
+
+WWW: http://pqxx.org/
diff --git a/databases/postgresql-libpqxx4/pkg-plist b/databases/postgresql-libpqxx4/pkg-plist
new file mode 100644
index 000000000000..c85e50ce1974
--- /dev/null
+++ b/databases/postgresql-libpqxx4/pkg-plist
@@ -0,0 +1,97 @@
+bin/pqxx-config
+include/pqxx/basic_connection
+include/pqxx/basic_connection.hxx
+include/pqxx/binarystring
+include/pqxx/binarystring.hxx
+include/pqxx/compiler-internal-post.hxx
+include/pqxx/compiler-internal-pre.hxx
+include/pqxx/compiler-public.hxx
+include/pqxx/config-public-compiler.h
+include/pqxx/connection
+include/pqxx/connection.hxx
+include/pqxx/connection_base
+include/pqxx/connection_base.hxx
+include/pqxx/connectionpolicy
+include/pqxx/connectionpolicy.hxx
+include/pqxx/cursor
+include/pqxx/cursor.hxx
+include/pqxx/dbtransaction
+include/pqxx/dbtransaction.hxx
+include/pqxx/errorhandler
+include/pqxx/errorhandler.hxx
+include/pqxx/except
+include/pqxx/except.hxx
+include/pqxx/field
+include/pqxx/field.hxx
+include/pqxx/internal/callgate.hxx
+include/pqxx/internal/gates/connection-dbtransaction.hxx
+include/pqxx/internal/gates/connection-errorhandler.hxx
+include/pqxx/internal/gates/connection-largeobject.hxx
+include/pqxx/internal/gates/connection-notification_receiver.hxx
+include/pqxx/internal/gates/connection-parameterized_invocation.hxx
+include/pqxx/internal/gates/connection-pipeline.hxx
+include/pqxx/internal/gates/connection-prepare-invocation.hxx
+include/pqxx/internal/gates/connection-reactivation_avoidance_exemption.hxx
+include/pqxx/internal/gates/connection-sql_cursor.hxx
+include/pqxx/internal/gates/connection-transaction.hxx
+include/pqxx/internal/gates/errorhandler-connection.hxx
+include/pqxx/internal/gates/icursor_iterator-icursorstream.hxx
+include/pqxx/internal/gates/icursorstream-icursor_iterator.hxx
+include/pqxx/internal/gates/result-connection.hxx
+include/pqxx/internal/gates/result-creation.hxx
+include/pqxx/internal/gates/result-sql_cursor.hxx
+include/pqxx/internal/gates/transaction-subtransaction.hxx
+include/pqxx/internal/gates/transaction-tablereader.hxx
+include/pqxx/internal/gates/transaction-tablewriter.hxx
+include/pqxx/internal/gates/transaction-transactionfocus.hxx
+include/pqxx/internal/libpq-forward.hxx
+include/pqxx/internal/result_data.hxx
+include/pqxx/internal/statement_parameters.hxx
+include/pqxx/isolation
+include/pqxx/isolation.hxx
+include/pqxx/largeobject
+include/pqxx/largeobject.hxx
+include/pqxx/nontransaction
+include/pqxx/nontransaction.hxx
+include/pqxx/notification
+include/pqxx/notification.hxx
+include/pqxx/notify-listen
+include/pqxx/notify-listen.hxx
+include/pqxx/performance.hxx
+include/pqxx/pipeline
+include/pqxx/pipeline.hxx
+include/pqxx/pqxx
+include/pqxx/prepared_statement
+include/pqxx/prepared_statement.hxx
+include/pqxx/result
+include/pqxx/result.hxx
+include/pqxx/robusttransaction
+include/pqxx/robusttransaction.hxx
+include/pqxx/strconv
+include/pqxx/strconv.hxx
+include/pqxx/subtransaction
+include/pqxx/subtransaction.hxx
+include/pqxx/tablereader
+include/pqxx/tablereader.hxx
+include/pqxx/tablestream
+include/pqxx/tablestream.hxx
+include/pqxx/tablewriter
+include/pqxx/tablewriter.hxx
+include/pqxx/transaction
+include/pqxx/transaction.hxx
+include/pqxx/transaction_base
+include/pqxx/transaction_base.hxx
+include/pqxx/transactor
+include/pqxx/transactor.hxx
+include/pqxx/trigger
+include/pqxx/trigger.hxx
+include/pqxx/tuple
+include/pqxx/tuple.hxx
+include/pqxx/util
+include/pqxx/util.hxx
+include/pqxx/version
+include/pqxx/version.hxx
+lib/libpqxx-%%PORTVERSION%%.so
+lib/libpqxx.a
+lib/libpqxx.so
+libdata/pkgconfig/libpqxx.pc