aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql14-plpython
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2021-05-20 08:53:00 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2021-05-20 14:38:55 +0000
commitfccc45e5ff4a8aea150005196c0d4f2cbaeed5db (patch)
treeb308d056494290f6e3b9e2bfa8e6750ec82183e6 /databases/postgresql14-plpython
parent21a4d52359f0e59b4f0dbb97212db803352e067e (diff)
downloadports-fccc45e5ff4a8aea150005196c0d4f2cbaeed5db.tar.gz
ports-fccc45e5ff4a8aea150005196c0d4f2cbaeed5db.zip
databases/postgresql14-*: Add postgresql 14 beta1 the the ports tree.
Release notes: https://www.postgresql.org/docs/devel/release-14.html Also reintroduce parallel builds. Some components, namely plperl, plpython, pltcl and contrib, fail to build properly when using parallel builds. Something with static linking using `ar` that fails. MAKE_JOBS_UNSAFE is set for these ports.
Diffstat (limited to 'databases/postgresql14-plpython')
-rw-r--r--databases/postgresql14-plpython/Makefile28
-rw-r--r--databases/postgresql14-plpython/pkg-descr6
2 files changed, 34 insertions, 0 deletions
diff --git a/databases/postgresql14-plpython/Makefile b/databases/postgresql14-plpython/Makefile
new file mode 100644
index 000000000000..9f7f102c341a
--- /dev/null
+++ b/databases/postgresql14-plpython/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= postgresql
+CATEGORIES= databases python
+# Keep the ?=, it is used as master by the other plpython ports.
+PORTREVISION?= 0
+PKGNAMESUFFIX?= ${WANT_PGSQL_VER:S/.//}${COMPONENT}
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= Module for using Python to write SQL functions
+
+USES+= pgsql:${WANT_PGSQL_VER} ${WANT_PYTHON_USE}
+WANT_PGSQL= server
+
+MASTERDIR= ${.CURDIR}/../postgresql${WANT_PGSQL_VER:S/.//}-server
+
+WANT_PGSQL_VER?= 14
+WANT_PYTHON_USE?= python
+
+CONFIGURE_ARGS= --with-python
+COMPONENT= -plpython
+
+BUILD_DIRS= src/backend ${INSTALL_DIRS}
+INSTALL_DIRS?= src/pl/plpython contrib/hstore_plpython contrib/jsonb_plpython contrib/ltree_plpython
+SLAVE_ONLY= yes
+
+# this port fails to build in parallel
+MAKE_JOBS_UNSAFE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql14-plpython/pkg-descr b/databases/postgresql14-plpython/pkg-descr
new file mode 100644
index 000000000000..416cce467d37
--- /dev/null
+++ b/databases/postgresql14-plpython/pkg-descr
@@ -0,0 +1,6 @@
+PL/Python allows one to write PostgeSQL stored functions and
+procedures in Python (http://www.python.org/).
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: https://www.postgresql.org/