aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql73
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>1998-11-22 21:33:20 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>1998-11-22 21:33:20 +0000
commitcde9cfb4d2664e586e734b36f8135954d026ced0 (patch)
treeafe659beafb1523cba08b3fb5c7d343e14f3775c /databases/postgresql73
parent36ad053ebd2c4759f6f3f07db92a56db817f3ab9 (diff)
downloadports-cde9cfb4d2664e586e734b36f8135954d026ced0.tar.gz
ports-cde9cfb4d2664e586e734b36f8135954d026ced0.zip
Upgrade to PostgreSQL v6.4
From: Cyrus Rahman <cr@jcmax.com>
Notes
Notes: svn path=/head/; revision=14774
Diffstat (limited to 'databases/postgresql73')
-rw-r--r--databases/postgresql73/Makefile34
-rw-r--r--databases/postgresql73/distinfo2
-rw-r--r--databases/postgresql73/pkg-plist173
3 files changed, 165 insertions, 44 deletions
diff --git a/databases/postgresql73/Makefile b/databases/postgresql73/Makefile
index 42e4d1614a0f..0ff914ae7cf2 100644
--- a/databases/postgresql73/Makefile
+++ b/databases/postgresql73/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: PostgreSQL
-# Version required: 6.2.1
-# Date created: April 2, 1997
+# Version required: 6.4
+# Date created: November 13, 1998
# Whom: Marc G. Fournier <scrappy@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.27 1998/10/12 04:12:35 jseger Exp $
+# $Id: Makefile,v 1.28 1998/10/16 02:42:29 jseger Exp $
#
-DISTNAME= postgresql-6.3.2
+DISTNAME= postgresql-v6.4
CATEGORIES= databases
MASTER_SITES= ftp://ftp.postgresql.org/pub/
@@ -15,9 +15,11 @@ MAINTAINER= andreas@FreeBSD.ORG
# if you want to use the tcl/tk frontend pgaccess, then you need to build
# postgresql with tcl support by typing: make USE_TCL=yes
.if defined(USE_TCL)
-MAKE_ENV= USE_TCL=true TCL_INCDIR=${PREFIX}/include/tcl8.0
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
-WITH_TCL= --with-tcl
+TCL_INCDIR= ${PREFIX}/include/tcl8.0
+TK_INCDIR= ${PREFIX}/include/tk8.0
+MAKE_ENV= USE_TCL=true TCL_INCDIR=${TCL_INCDIR}
+LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80 tk80.1:${PORTSDIR}/x11-toolkits/tk80
+WITH_TCL= --with-tcl --with-tclconfig="${PREFIX}/lib/tcl8.0 ${PREFIX}/lib/tk8.0"
.endif
NO_PACKAGE= "Requires pgsql uid"
@@ -29,15 +31,17 @@ HAS_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX}/pgsql \
--enable-locale \
--with-template=`uname -s | ${TR} '[A-Z]' '[a-z]'` \
- --with-includes=/usr/local/include ${WITH_TCL} \
+ --with-includes="/usr/local/include ${TCL_INCDIR} ${TK_INCDIR}" ${WITH_TCL} \
--with-libraries=/usr/local/lib
+INSTALL_TARGET= install install-man
+
MAN1= cleardbdir.1 createdb.1 createuser.1 destroydb.1 \
- destroyuser.1 ecpg.1 initdb.1 ipcclean.1 initlocation.1 \
- pg_dump.1 pg_dumpall.1 pg_passwd.1 pgintro.1 postgres.1 \
- postmaster.1 psql.1
-MAN3= catalogs.3 large_objects.3 libpq.3 oracle_compat.3 pgbuiltin.3
-MAN5= bki.5 page.5 pg_hba.conf.5
+ destroyuser.1 ecpg.1 initdb.1 initlocation.1 \
+ ipcclean.1 pg_dump.1 pg_dumpall.1 pg_passwd.1 \
+ pg_upgrade.1 postgres.1 postmaster.1 psql.1
+MAN3= catalogs.3 libpq.3
+MAN5= pg_hba.conf.5
MANL= abort.l alter_table.l alter_user.l begin.l close.l cluster.l \
commit.l copy.l create_aggregate.l create_database.l \
create_function.l create_index.l create_language.l \
@@ -48,8 +52,8 @@ MANL= abort.l alter_table.l alter_user.l begin.l close.l cluster.l \
drop_language.l drop_operator.l drop_rule.l drop_sequence.l \
drop_table.l drop_trigger.l drop_type.l drop_user.l \
drop_view.l end.l explain.l fetch.l grant.l insert.l listen.l \
- load.l lock.l move.l notify.l reset.l revoke.l \
- rollback.l select.l set.l show.l sql.l update.l vacuum.l
+ load.l lock.l move.l notify.l reset.l revoke.l rollback.l \
+ select.l set.l show.l sql.l update.l vacuum.l
MANPREFIX= ${PREFIX}/pgsql
diff --git a/databases/postgresql73/distinfo b/databases/postgresql73/distinfo
index dc42f89ecf8d..909a64b8dd0a 100644
--- a/databases/postgresql73/distinfo
+++ b/databases/postgresql73/distinfo
@@ -1 +1 @@
-MD5 (postgresql-6.3.2.tar.gz) = 8902842461c9a42854ba9883bee56a4c
+MD5 (postgresql-v6.4.tar.gz) = 8a6e224f90b0201757eb05aa0068bfa9
diff --git a/databases/postgresql73/pkg-plist b/databases/postgresql73/pkg-plist
index 69fcca04897d..dc1f31e49664 100644
--- a/databases/postgresql73/pkg-plist
+++ b/databases/postgresql73/pkg-plist
@@ -13,6 +13,7 @@ pgsql/bin/pg_dump
pgsql/bin/pg_dumpall
pgsql/bin/pg_id
pgsql/bin/pg_passwd
+pgsql/bin/pg_upgrade
pgsql/bin/pg_version
pgsql/bin/postgres
pgsql/bin/postmaster
@@ -35,6 +36,7 @@ pgsql/data/base/template1/pg_class_relname_index
pgsql/data/base/template1/pg_description
pgsql/data/base/template1/pg_description_objoid_index
pgsql/data/base/template1/pg_index
+pgsql/data/base/template1/pg_indexes
pgsql/data/base/template1/pg_inheritproc
pgsql/data/base/template1/pg_inherits
pgsql/data/base/template1/pg_internal.init
@@ -46,19 +48,21 @@ pgsql/data/base/template1/pg_operator
pgsql/data/base/template1/pg_parg
pgsql/data/base/template1/pg_proc
pgsql/data/base/template1/pg_proc_oid_index
-pgsql/data/base/template1/pg_proc_proname_index
+pgsql/data/base/template1/pg_proc_proname_narg_type_index
pgsql/data/base/template1/pg_proc_prosrc_index
pgsql/data/base/template1/pg_relcheck
pgsql/data/base/template1/pg_relcheck_rcrelid_index
pgsql/data/base/template1/pg_rewrite
+pgsql/data/base/template1/pg_rules
pgsql/data/base/template1/pg_statistic
+pgsql/data/base/template1/pg_tables
pgsql/data/base/template1/pg_trigger
pgsql/data/base/template1/pg_trigger_tgrelid_index
pgsql/data/base/template1/pg_type
pgsql/data/base/template1/pg_type_oid_index
pgsql/data/base/template1/pg_type_typname_index
pgsql/data/base/template1/pg_user
-pgsql/data/base/template1/pg_version
+pgsql/data/base/template1/pg_views
pgsql/data/pg_database
pgsql/data/pg_geqo.sample
pgsql/data/pg_group
@@ -71,12 +75,21 @@ pgsql/include/access/attnum.h
pgsql/include/c.h
pgsql/include/commands/trigger.h
pgsql/include/config.h
+pgsql/include/ecpgerrno.h
pgsql/include/ecpglib.h
pgsql/include/ecpgtype.h
pgsql/include/executor/spi.h
pgsql/include/fmgr.h
pgsql/include/lib/dllist.h
+pgsql/include/libpq++.h
+pgsql/include/libpq++/pgconnection.h
+pgsql/include/libpq++/pgcursordb.h
+pgsql/include/libpq++/pgdatabase.h
+pgsql/include/libpq++/pgenv.h
+pgsql/include/libpq++/pglobject.h
+pgsql/include/libpq++/pgtransdb.h
pgsql/include/libpq-fe.h
+pgsql/include/libpq-int.h
pgsql/include/libpq/libpq-fs.h
pgsql/include/libpq/pqcomm.h
pgsql/include/os.h
@@ -89,30 +102,36 @@ pgsql/include/utils/palloc.h
pgsql/lib/global1.bki.source
pgsql/lib/global1.description
pgsql/lib/libecpg.a
+pgsql/lib/libecpg.so.2.6.2
+pgsql/lib/libecpg.so.2.3
pgsql/lib/libecpg.so
-pgsql/lib/libecpg.so.1.1
+pgsql/lib/libpq++.a
+pgsql/lib/libpq++.so
+pgsql/lib/libpq++.so.2.0
+pgsql/lib/libpq++.so.2
pgsql/lib/libpq.a
pgsql/lib/libpq.so
-pgsql/lib/libpq.so.1.1
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+pgsql/lib/libpq.so.2.0
+pgsql/lib/libpq.so.2
pgsql/lib/local1_template1.bki.source
pgsql/lib/local1_template1.description
pgsql/lib/pg_geqo.sample
pgsql/lib/pg_hba.conf.sample
+pgsql/lib/plpgsql.so
pgsql/post-install-notes
share/doc/pgsql/FAQ
+share/doc/pgsql/FAQ_CVS
+share/doc/pgsql/FAQ_DEV
share/doc/pgsql/FAQ_FreeBSD
share/doc/pgsql/FAQ_Irix
share/doc/pgsql/FAQ_Linux
share/doc/pgsql/Makefile
-share/doc/pgsql/README.GEQO
share/doc/pgsql/README.fsync
+share/doc/pgsql/README.inet
+share/doc/pgsql/README.locale
share/doc/pgsql/README.mb
share/doc/pgsql/README.mb.jp
-share/doc/pgsql/README.support
share/doc/pgsql/TODO
-share/doc/pgsql/TODO.GEQO
share/doc/pgsql/admin.ps.gz
share/doc/pgsql/admin.tar.gz
share/doc/pgsql/bug.template
@@ -121,6 +140,7 @@ share/doc/pgsql/programmer.ps.gz
share/doc/pgsql/programmer.tar.gz
share/doc/pgsql/src/Makefile
share/doc/pgsql/src/graphics/catalogs.gif
+share/doc/pgsql/src/graphics/catalogs.ps
share/doc/pgsql/src/graphics/clientserver.ag
share/doc/pgsql/src/graphics/clientserver.gif
share/doc/pgsql/src/graphics/connections.ag
@@ -128,6 +148,7 @@ share/doc/pgsql/src/graphics/connections.gif
share/doc/pgsql/src/graphics/layout.ag
share/doc/pgsql/src/graphics/layout.gif
share/doc/pgsql/src/sgml/Makefile
+share/doc/pgsql/src/sgml/about.sgml
share/doc/pgsql/src/sgml/admin.sgml
share/doc/pgsql/src/sgml/advanced.sgml
share/doc/pgsql/src/sgml/arch-dev.sgml
@@ -135,8 +156,11 @@ share/doc/pgsql/src/sgml/arch-pg.sgml
share/doc/pgsql/src/sgml/arch.sgml
share/doc/pgsql/src/sgml/array.sgml
share/doc/pgsql/src/sgml/biblio.sgml
+share/doc/pgsql/src/sgml/bki.sgml
share/doc/pgsql/src/sgml/compiler.sgml
+share/doc/pgsql/src/sgml/config.sgml
share/doc/pgsql/src/sgml/contacts.sgml
+share/doc/pgsql/src/sgml/current.sgml
share/doc/pgsql/src/sgml/datatype.sgml
share/doc/pgsql/src/sgml/dfunc.sgml
share/doc/pgsql/src/sgml/docguide.sgml
@@ -144,18 +168,31 @@ share/doc/pgsql/src/sgml/ecpg.sgml
share/doc/pgsql/src/sgml/environ.sgml
share/doc/pgsql/src/sgml/extend.sgml
share/doc/pgsql/src/sgml/func-ref.sgml
+share/doc/pgsql/src/sgml/func.sgml
share/doc/pgsql/src/sgml/geqo.sgml
share/doc/pgsql/src/sgml/gist.sgml
+share/doc/pgsql/src/sgml/history.sgml
+share/doc/pgsql/src/sgml/indices.sgml
+share/doc/pgsql/src/sgml/info.sgml
share/doc/pgsql/src/sgml/inherit.sgml
share/doc/pgsql/src/sgml/install.sgml
+share/doc/pgsql/src/sgml/installation.sgml
+share/doc/pgsql/src/sgml/intro-ag.sgml
share/doc/pgsql/src/sgml/intro-pg.sgml
share/doc/pgsql/src/sgml/intro.sgml
share/doc/pgsql/src/sgml/jdbc.sgml
+share/doc/pgsql/src/sgml/keys.sgml
+share/doc/pgsql/src/sgml/legal.sgml
share/doc/pgsql/src/sgml/libpgtcl.sgml
+share/doc/pgsql/src/sgml/libpq++.sgml
share/doc/pgsql/src/sgml/libpq.sgml
share/doc/pgsql/src/sgml/lobj.sgml
share/doc/pgsql/src/sgml/manage.sgml
+share/doc/pgsql/src/sgml/notation.sgml
share/doc/pgsql/src/sgml/odbc.sgml
+share/doc/pgsql/src/sgml/oper.sgml
+share/doc/pgsql/src/sgml/page.sgml
+share/doc/pgsql/src/sgml/pg_options.sgml
share/doc/pgsql/src/sgml/pgaccess.sgml
share/doc/pgsql/src/sgml/ports.sgml
share/doc/pgsql/src/sgml/postgres.sgml
@@ -165,48 +202,128 @@ share/doc/pgsql/src/sgml/psql.sgml
share/doc/pgsql/src/sgml/query-ug.sgml
share/doc/pgsql/src/sgml/query.sgml
share/doc/pgsql/src/sgml/recovery.sgml
+share/doc/pgsql/src/sgml/ref/abort.sgml
+share/doc/pgsql/src/sgml/ref/allfiles.sgml
+share/doc/pgsql/src/sgml/ref/alter_table.sgml
+share/doc/pgsql/src/sgml/ref/alter_user.sgml
+share/doc/pgsql/src/sgml/ref/begin.sgml
+share/doc/pgsql/src/sgml/ref/close.sgml
+share/doc/pgsql/src/sgml/ref/cluster.sgml
+share/doc/pgsql/src/sgml/ref/commands.sgml
+share/doc/pgsql/src/sgml/ref/commit.sgml
+share/doc/pgsql/src/sgml/ref/copy.sgml
+share/doc/pgsql/src/sgml/ref/create_aggregate.sgml
+share/doc/pgsql/src/sgml/ref/create_database.sgml
+share/doc/pgsql/src/sgml/ref/create_function.sgml
+share/doc/pgsql/src/sgml/ref/create_index.sgml
+share/doc/pgsql/src/sgml/ref/create_language.sgml
+share/doc/pgsql/src/sgml/ref/create_operator.sgml
+share/doc/pgsql/src/sgml/ref/create_rule.sgml
+share/doc/pgsql/src/sgml/ref/create_sequence.sgml
+share/doc/pgsql/src/sgml/ref/create_table.sgml
+share/doc/pgsql/src/sgml/ref/create_trigger.sgml
+share/doc/pgsql/src/sgml/ref/create_type.sgml
+share/doc/pgsql/src/sgml/ref/create_user.sgml
+share/doc/pgsql/src/sgml/ref/create_view.sgml
+share/doc/pgsql/src/sgml/ref/createdb.sgml
+share/doc/pgsql/src/sgml/ref/createuser.sgml
+share/doc/pgsql/src/sgml/ref/current_date.sgml
+share/doc/pgsql/src/sgml/ref/current_time.sgml
+share/doc/pgsql/src/sgml/ref/current_timestamp.sgml
+share/doc/pgsql/src/sgml/ref/current_user.sgml
+share/doc/pgsql/src/sgml/ref/declare.sgml
+share/doc/pgsql/src/sgml/ref/delete.sgml
+share/doc/pgsql/src/sgml/ref/destroydb.sgml
+share/doc/pgsql/src/sgml/ref/destroyuser.sgml
+share/doc/pgsql/src/sgml/ref/drop_aggregate.sgml
+share/doc/pgsql/src/sgml/ref/drop_database.sgml
+share/doc/pgsql/src/sgml/ref/drop_function.sgml
+share/doc/pgsql/src/sgml/ref/drop_index.sgml
+share/doc/pgsql/src/sgml/ref/drop_language.sgml
+share/doc/pgsql/src/sgml/ref/drop_operator.sgml
+share/doc/pgsql/src/sgml/ref/drop_rule.sgml
+share/doc/pgsql/src/sgml/ref/drop_sequence.sgml
+share/doc/pgsql/src/sgml/ref/drop_table.sgml
+share/doc/pgsql/src/sgml/ref/drop_trigger.sgml
+share/doc/pgsql/src/sgml/ref/drop_type.sgml
+share/doc/pgsql/src/sgml/ref/drop_user.sgml
+share/doc/pgsql/src/sgml/ref/drop_view.sgml
+share/doc/pgsql/src/sgml/ref/explain.sgml
+share/doc/pgsql/src/sgml/ref/fetch.sgml
+share/doc/pgsql/src/sgml/ref/grant.sgml
+share/doc/pgsql/src/sgml/ref/initdb.sgml
+share/doc/pgsql/src/sgml/ref/initlocation.sgml
+share/doc/pgsql/src/sgml/ref/insert.sgml
+share/doc/pgsql/src/sgml/ref/listen.sgml
+share/doc/pgsql/src/sgml/ref/load.sgml
+share/doc/pgsql/src/sgml/ref/lock.sgml
+share/doc/pgsql/src/sgml/ref/move.sgml
+share/doc/pgsql/src/sgml/ref/notify.sgml
+share/doc/pgsql/src/sgml/ref/pg_dump.sgml
+share/doc/pgsql/src/sgml/ref/pg_dumpall.sgml
+share/doc/pgsql/src/sgml/ref/pg_upgrade.sgml
+share/doc/pgsql/src/sgml/ref/psql-ref.sgml
+share/doc/pgsql/src/sgml/ref/reset.sgml
+share/doc/pgsql/src/sgml/ref/revoke.sgml
+share/doc/pgsql/src/sgml/ref/rollback.sgml
+share/doc/pgsql/src/sgml/ref/select.sgml
+share/doc/pgsql/src/sgml/ref/set.sgml
+share/doc/pgsql/src/sgml/ref/show.sgml
+share/doc/pgsql/src/sgml/ref/unlisten.sgml
+share/doc/pgsql/src/sgml/ref/update.sgml
+share/doc/pgsql/src/sgml/ref/vacuum.sgml
+share/doc/pgsql/src/sgml/reference.sgml
share/doc/pgsql/src/sgml/regress.sgml
share/doc/pgsql/src/sgml/release.sgml
share/doc/pgsql/src/sgml/rules.sgml
+share/doc/pgsql/src/sgml/runtime.sgml
+share/doc/pgsql/src/sgml/security.sgml
+share/doc/pgsql/src/sgml/signals.sgml
share/doc/pgsql/src/sgml/spi.sgml
share/doc/pgsql/src/sgml/start-ag.sgml
share/doc/pgsql/src/sgml/start.sgml
share/doc/pgsql/src/sgml/storage.sgml
+share/doc/pgsql/src/sgml/syntax.sgml
share/doc/pgsql/src/sgml/trigger.sgml
share/doc/pgsql/src/sgml/tutorial.sgml
+share/doc/pgsql/src/sgml/typeconv.sgml
share/doc/pgsql/src/sgml/user.sgml
share/doc/pgsql/src/sgml/xaggr.sgml
share/doc/pgsql/src/sgml/xfunc.sgml
share/doc/pgsql/src/sgml/xindex.sgml
share/doc/pgsql/src/sgml/xoper.sgml
+share/doc/pgsql/src/sgml/xplang.sgml
share/doc/pgsql/src/sgml/xtypes.sgml
+share/doc/pgsql/src/sgml/y2k.sgml
share/doc/pgsql/tutorial.ps.gz
share/doc/pgsql/tutorial.tar.gz
share/doc/pgsql/user.ps.gz
share/doc/pgsql/user.tar.gz
-share/doc/pgsql/userguide.ps
-@dirrm share/doc/pgsql/src/graphics
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+@dirrm share/doc/pgsql/src/sgml/ref
@dirrm share/doc/pgsql/src/sgml
+@dirrm share/doc/pgsql/src/graphics
@dirrm share/doc/pgsql/src
@dirrm share/doc/pgsql
-@dirrm pgsql/bin
+@dirrm pgsql/man/manl
+@dirrm pgsql/man/man5
+@dirrm pgsql/man/man3
+@dirrm pgsql/man/man1
+@dirrm pgsql/man
+@dirrm pgsql/lib
+@dirrm pgsql/include/utils
+@dirrm pgsql/include/port/freebsd
+@dirrm pgsql/include/port
+@dirrm pgsql/include/libpq++
+@dirrm pgsql/include/libpq
+@dirrm pgsql/include/lib
+@dirrm pgsql/include/executor
+@dirrm pgsql/include/commands
+@dirrm pgsql/include/access
+@dirrm pgsql/include
@dirrm pgsql/data/base/template1
@dirrm pgsql/data/base
@dirrm pgsql/data
-@dirrm pgsql/include/access
-@dirrm pgsql/include/commands
-@dirrm pgsql/include/executor
-@dirrm pgsql/include/include
-@dirrm pgsql/include/lib
-@dirrm pgsql/include/libpq
-@dirrm pgsql/include/port/bsd
-@dirrm pgsql/include/port
-@dirrm pgsql/include/utils
-@dirrm pgsql/include
-@dirrm pgsql/lib
-@dirrm pgsql/man/man1
-@dirrm pgsql/man/man3
-@dirrm pgsql/man/man5
-@dirrm pgsql/man/manl
-@dirrm pgsql/man
+@dirrm pgsql/bin
@dirrm pgsql