aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql82-server
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1997-10-03 14:13:36 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1997-10-03 14:13:36 +0000
commit8f5d33e0f1106b4b95155ee6f215edec281f74e6 (patch)
tree08a98fbfe0b7af73add2a91b13c99d6c7a1f9194 /databases/postgresql82-server
parent55b5c070e5c985b9b361a087bc0cdcadf0d59a86 (diff)
downloadports-8f5d33e0f1106b4b95155ee6f215edec281f74e6.tar.gz
ports-8f5d33e0f1106b4b95155ee6f215edec281f74e6.zip
Upgrade from version 6.1.1 to 6.2
Please note: when performing a migration to 6.2 and you have an existing db, then you have to use the *new* pg_dumpall script that comes with this new postgresql release. The INSTALL file points this out explicitely !!! Changes: - startup script resides in FILESDIR - renamed it to be in sync with INSTALL file from sources - always install this startup script over an existing, because of the nature of the rc.d directory I can't install it to pgsql.sh-dist, if a pgsql.sh is already presend ... - portlint detected trailing whitespace, usage of perl with absolute path, usage of echo instead of ECHO and plenty things of this kind - post installation notes updated, mentioned the mailing list - copies the html pages as well to the share/doc directory (new manual dir) - had to update PLIST - shortened DESCR file, to match the 24 lines - added post build target, that reminds the admin how to proceed when already having a database -> INSTALL file describes migration - updated manpages
Notes
Notes: svn path=/head/; revision=8095
Diffstat (limited to 'databases/postgresql82-server')
-rw-r--r--databases/postgresql82-server/Makefile73
-rw-r--r--databases/postgresql82-server/distinfo2
-rw-r--r--databases/postgresql82-server/files/pgsql.sh.tmpl21
-rw-r--r--databases/postgresql82-server/files/post-install-notes4
-rw-r--r--databases/postgresql82-server/pkg-descr9
-rw-r--r--databases/postgresql82-server/pkg-plist60
6 files changed, 121 insertions, 48 deletions
diff --git a/databases/postgresql82-server/Makefile b/databases/postgresql82-server/Makefile
index f11b16deb174..be9e1d8230ac 100644
--- a/databases/postgresql82-server/Makefile
+++ b/databases/postgresql82-server/Makefile
@@ -1,17 +1,16 @@
# New ports collection makefile for: PostgreSQL
-# Version required: 6.1
+# Version required: 6.1
# Date created: April 2, 1997
# Whom: Marc G. Fournier <scrappy@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.13 1997/07/17 15:12:40 max Exp $
+# $Id: Makefile,v 1.14 1997/09/27 21:43:48 andreas Exp $
-DISTNAME= postgresql-v6.1.1
-PKGNAME= postgresql-6.1.1
+DISTNAME= postgresql-6.2
CATEGORIES= databases
MASTER_SITES= ftp://ftp.PostgreSQL.org/pub/ \
ftp://ftp.luga.or.at/pub/postgres95/ \
- ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/
-
+ ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/
+
MAINTAINER= andreas@FreeBSD.ORG
NO_PACKAGE= "Requires pgsql uid"
@@ -20,59 +19,71 @@ USE_GMAKE= YES
HAS_CONFIGURE= YES
CONFIGURE_ARGS+=--prefix=${PREFIX}/pgsql \
--enable-locale \
- --with-template=`uname -s | tr '[A-Z]' '[a-z]'`
+ --with-template=`uname -s | ${TR} '[A-Z]' '[a-z]'`
MAKEFILE= GNUmakefile
MAN1= cleardbdir.1 createdb.1 createuser.1 destroydb.1 \
destroyuser.1 initdb.1 ipcclean.1 monitor.1 pg_dump.1 \
- pg_dumpall.1 postgres.1 postmaster.1 psql.1 unix.1
-MAN3= built-in.3 catalogs.3 large_objects.3 libpq.3 oracle_compat.3
-MAN5= bki.5 page.5 pg_hba.conf.5
+ pg_dumpall.1 pg_passwd.1 pgintro.1 postgres.1 \
+ postmaster.1 psql.1
+MAN3= catalogs.3 large_objects.3 libpq.3 oracle_compat.3 pgbuiltin.3
+MAN5= bki.5 page.5 pg_hba.conf.5
MANL= abort.l alter_table.l begin.l close.l cluster.l \
commit.l copy.l create_aggregate.l create_database.l \
create_function.l create_index.l create_operator.l \
create_rule.l create_sequence.l create_table.l \
- create_type.l create_version.l create_view.l delete.l \
- drop.l drop_aggregate.l drop_database.l drop_function.l \
- drop_index.l drop_operator.l drop_rule.l drop_sequence.l \
+ create_trigger.l create_type.l create_version.l \
+ create_view.l declare.l delete.l drop.l drop_aggregate.l \
+ drop_database.l drop_function.l drop_index.l drop_operator.l \
+ drop_rule.l drop_sequence.l drop_table.l drop_trigger.l \
drop_type.l drop_view.l end.l explain.l fetch.l grant.l \
- insert.l listen.l load.l notify.l purge.l rename.l \
- reset.l revoke.l rollback.l select.l set.l show.l \
- sql.l update.l vacuum.l
+ insert.l listen.l load.l move.l notify.l purge.l rename.l \
+ reset.l revoke.l rollback.l select.l set.l show.l sql.l \
+ update.l vacuum.l
+
MANPREFIX= ${PREFIX}/pgsql
+post-build:
+ @ ${ECHO} "------------------------------------------------------------"
+ @ ${ECHO} "Dump existing databases, before installing new db version !!"
+ @ ${ECHO} "Detailed instructions, see INSTALL file under ${WRKDIR}... "
+ @ ${ECHO} "------------------------------------------------------------"
+
pre-install:
@ ${MKDIR} ${PREFIX}/pgsql
- @ ${SETENV} ${MAKE_ENV} /usr/bin/perl ${SCRIPTDIR}/createuser
+ @ ${SETENV} ${MAKE_ENV} perl ${SCRIPTDIR}/createuser
post-install:
@ if [ ! -f ${PREFIX}/pgsql/.profile ]; then \
- echo "PATH=${PATH}:${PREFIX}/pgsql/bin" \
+ ${ECHO} "PATH=${PATH}:${PREFIX}/pgsql/bin" \
> ${PREFIX}/pgsql/.profile; \
- echo "MANPATH=${MANPATH}:${PREFIX}/pgsql/bin" \
+ ${ECHO} "MANPATH=${MANPATH}:${PREFIX}/pgsql/bin" \
+ >> ${PREFIX}/pgsql/.profile; \
+ ${ECHO} "PGLIB=${PREFIX}/pgsql/lib" \
>> ${PREFIX}/pgsql/.profile; \
- echo "PGLIB=${PREFIX}/pgsql/lib" \
+ ${ECHO} "PGDATA=${PREFIX}/pgsql/data" \
>> ${PREFIX}/pgsql/.profile; \
- echo "PGDATA=${PREFIX}/pgsql/data" \
+ ${ECHO} "export PATH MANPATH PGLIB PGDATA" \
>> ${PREFIX}/pgsql/.profile; \
- echo "export PATH MANPATH PGLIB PGDATA" \
+ ${ECHO} "# if you want to make regression tests use this TZ" \
+ >> ${PREFIX}/pgsql/.profile; \
+ ${ECHO} "#TZ=PST8PDT" \
+ >> ${PREFIX}/pgsql/.profile; \
+ ${ECHO} "#export TZ" \
>> ${PREFIX}/pgsql/.profile; \
fi
@ chown -R pgsql:pgsql ${PREFIX}/pgsql
- @ echo 'Initializing PostgreSQL Databases - this may take a few minutes...'
+ @ ${ECHO} 'Initializing PostgreSQL Databases - this may take a few minutes...'
@ ${LDCONFIG} -m ${PREFIX}/pgsql/lib
@ su -l pgsql -c '${PREFIX}/pgsql/bin/initdb --pglib=${PREFIX}/pgsql/lib --pgdata=${PREFIX}/pgsql/data'
- @ if [ ! -f ${PREFIX}/etc/rc.d/postgresql.sh ]; then \
- echo "Installing ${PREFIX}/etc/rc.d/postgresql.sh startup file."; \
- echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/postgresql.sh; \
- echo "[ -d ${PREFIX}/pgsql/lib ] && /sbin/ldconfig -m ${PREFIX}/pgsql/lib" >> ${PREFIX}/etc/rc.d/postgresql.sh; \
- echo "[ -x ${PREFIX}/pgsql/bin/postmaster ] && su -l pgsql -c '${PREFIX}/pgsql/bin/postmaster -D${PREFIX}/pgsql/data -o -F > ${PREFIX}/pgsql/errlog &' && echo -n ' pgsql'" >> ${PREFIX}/etc/rc.d/postgresql.sh; \
- chmod 751 ${PREFIX}/etc/rc.d/postgresql.sh; \
- fi
+ @ ${SED} -e "s=!!PREFIX!!=${PREFIX}=g" < ${FILESDIR}/pgsql.sh.tmpl \
+ > ${PREFIX}/etc/rc.d/pgsql.sh
+ @ chmod 554 ${PREFIX}/etc/rc.d/pgsql.sh
+ @ chown root.pgsql ${PREFIX}/etc/rc.d/pgsql.sh
@ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/pgsql
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/pgsql
- ${CP} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/pgsql
+ ${CP} -r ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/pgsql
.endif
.if !defined(BATCH)
@ more -e ${FILESDIR}/post-install-notes
diff --git a/databases/postgresql82-server/distinfo b/databases/postgresql82-server/distinfo
index 70b03de859e0..312e4988872e 100644
--- a/databases/postgresql82-server/distinfo
+++ b/databases/postgresql82-server/distinfo
@@ -1 +1 @@
-MD5 (postgresql-v6.1.1.tar.gz) = d80f2b459d00bea269435bb4ca05bd78
+MD5 (postgresql-6.2.tar.gz) = 4c59757f6405a6c3011399e3c502afd7
diff --git a/databases/postgresql82-server/files/pgsql.sh.tmpl b/databases/postgresql82-server/files/pgsql.sh.tmpl
new file mode 100644
index 000000000000..7321cf4f4723
--- /dev/null
+++ b/databases/postgresql82-server/files/pgsql.sh.tmpl
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+# $Id$
+
+# pgsql.sh - postgresql startup file for FreeBSD and possibly *BSD (untested)
+
+# Changes:
+# - renamed startup script to be in sync with INSTALL file
+# - merged ldconfig start sequence from former postgrsql.sh script (andreas)
+# - modified the postmaster startup sequence as suggested in the
+# INSTALL file which was given as example for FreeBSD 2.2 (andreas)
+
+
+[ -d !!PREFIX!!/pgsql/lib ] && /sbin/ldconfig -m !!PREFIX!!/pgsql/lib
+
+[ -x !!PREFIX!!/pgsql/bin/postmaster ] && {
+ su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/postmaster
+ -D!!PREFIX!!/pgsql/data
+ -S -o -F > !!PREFIX!!/pgsql/errlog' &
+ echo -n ' pgsql'
+}
diff --git a/databases/postgresql82-server/files/post-install-notes b/databases/postgresql82-server/files/post-install-notes
index 1956d17766c9..910966e67f1b 100644
--- a/databases/postgresql82-server/files/post-install-notes
+++ b/databases/postgresql82-server/files/post-install-notes
@@ -4,3 +4,7 @@ implementation guides. These can be found at:
http://www.PostgreSQL.org/docs
+You may wish to subscribe to the PostgreSQL user-support mailing list.
+Send an e-mail to pgsql-questions-request@postgresql.org with the
+text "subscribe" in the message body.
+
diff --git a/databases/postgresql82-server/pkg-descr b/databases/postgresql82-server/pkg-descr
index 680bf5c7f2ba..f0283be0cd64 100644
--- a/databases/postgresql82-server/pkg-descr
+++ b/databases/postgresql82-server/pkg-descr
@@ -1,4 +1,3 @@
-
PostgreSQL is a robust, next-generation, Object-Relational DBMS (ORDBMS),
derived from the Berkeley Postgres database management system. While
PostgreSQL retains the powerful object-relational data model, rich data types
@@ -16,12 +15,10 @@ memory, PostgreSQL was born.
PostgreSQL development is presently being performed by a team of Internet
developers who are now responsible for all current and future development. The
-development team coordinator is Marc G. Fournier (scrappy@PostgreSQL.Org).
+development team coordinator is Marc G. Fournier (scrappy@PostgreSQL.ORG).
Support is available from the PostgreSQL developer/user community through the
-support mailing list (questions@PostgreSQL.Org).
+support mailing list (questions@PostgreSQL.ORG).
PostgreSQL is free and the complete source is available.
-More information and documentation can be found on the PostgreSQL website,
-at: http://www.PostgreSQL.Org
-
+More information and documentation, visit: http://www.PostgreSQL.ORG/
diff --git a/databases/postgresql82-server/pkg-plist b/databases/postgresql82-server/pkg-plist
index 6801de7d0d9a..4a28e6851896 100644
--- a/databases/postgresql82-server/pkg-plist
+++ b/databases/postgresql82-server/pkg-plist
@@ -1,4 +1,4 @@
-etc/rc.d/postgresql.sh
+etc/rc.d/pgsql.sh
pgsql/.profile
pgsql/bin/cleardbdir
pgsql/bin/createdb
@@ -9,8 +9,10 @@ pgsql/bin/initdb
pgsql/bin/pg_dump
pgsql/bin/pg_dumpall
pgsql/bin/pg_id
+pgsql/bin/pg_passwd
pgsql/bin/pg_version
pgsql/bin/postgres
+pgsql/bin/postmaster
pgsql/bin/psql
pgsql/data/PG_VERSION
pgsql/data/base/template1/PG_VERSION
@@ -20,6 +22,8 @@ pgsql/data/base/template1/pg_amop
pgsql/data/base/template1/pg_amproc
pgsql/data/base/template1/pg_attnameind
pgsql/data/base/template1/pg_attnumind
+pgsql/data/base/template1/pg_attrdef
+pgsql/data/base/template1/pg_attrdefind
pgsql/data/base/template1/pg_attrelidind
pgsql/data/base/template1/pg_attribute
pgsql/data/base/template1/pg_class
@@ -39,8 +43,12 @@ pgsql/data/base/template1/pg_proc
pgsql/data/base/template1/pg_procidind
pgsql/data/base/template1/pg_procnameind
pgsql/data/base/template1/pg_procsrcind
+pgsql/data/base/template1/pg_relcheck
+pgsql/data/base/template1/pg_relcheckind
pgsql/data/base/template1/pg_rewrite
pgsql/data/base/template1/pg_statistic
+pgsql/data/base/template1/pg_trigger
+pgsql/data/base/template1/pg_trigrelidind
pgsql/data/base/template1/pg_type
pgsql/data/base/template1/pg_typeidind
pgsql/data/base/template1/pg_typenameind
@@ -74,6 +82,7 @@ pgsql/include/utils/geo_decls.h
pgsql/include/utils/palloc.h
pgsql/lib/global1.bki.source
pgsql/lib/libpq.a
+pgsql/lib/libpq.so
pgsql/lib/libpq.so.1.0
pgsql/lib/local1_template1.bki.source
pgsql/lib/pg_geqo.sample
@@ -88,15 +97,16 @@ pgsql/man/man1/ipcclean.1.gz
pgsql/man/man1/monitor.1.gz
pgsql/man/man1/pg_dump.1.gz
pgsql/man/man1/pg_dumpall.1.gz
+pgsql/man/man1/pg_passwd.1.gz
+pgsql/man/man1/pgintro.1.gz
pgsql/man/man1/postgres.1.gz
pgsql/man/man1/postmaster.1.gz
pgsql/man/man1/psql.1.gz
-pgsql/man/man1/unix.1.gz
-pgsql/man/man3/built-in.3.gz
pgsql/man/man3/catalogs.3.gz
pgsql/man/man3/large_objects.3.gz
pgsql/man/man3/libpq.3.gz
pgsql/man/man3/oracle_compat.3.gz
+pgsql/man/man3/pgbuiltin.3.gz
pgsql/man/man5/bki.5.gz
pgsql/man/man5/page.5.gz
pgsql/man/man5/pg_hba.conf.5.gz
@@ -115,9 +125,11 @@ pgsql/man/manl/create_operator.l.gz
pgsql/man/manl/create_rule.l.gz
pgsql/man/manl/create_sequence.l.gz
pgsql/man/manl/create_table.l.gz
+pgsql/man/manl/create_trigger.l.gz
pgsql/man/manl/create_type.l.gz
pgsql/man/manl/create_version.l.gz
pgsql/man/manl/create_view.l.gz
+pgsql/man/manl/declare.l.gz
pgsql/man/manl/delete.l.gz
pgsql/man/manl/drop.l.gz
pgsql/man/manl/drop_aggregate.l.gz
@@ -127,6 +139,8 @@ pgsql/man/manl/drop_index.l.gz
pgsql/man/manl/drop_operator.l.gz
pgsql/man/manl/drop_rule.l.gz
pgsql/man/manl/drop_sequence.l.gz
+pgsql/man/manl/drop_table.l.gz
+pgsql/man/manl/drop_trigger.l.gz
pgsql/man/manl/drop_type.l.gz
pgsql/man/manl/drop_view.l.gz
pgsql/man/manl/end.l.gz
@@ -136,6 +150,7 @@ pgsql/man/manl/grant.l.gz
pgsql/man/manl/insert.l.gz
pgsql/man/manl/listen.l.gz
pgsql/man/manl/load.l.gz
+pgsql/man/manl/move.l.gz
pgsql/man/manl/notify.l.gz
pgsql/man/manl/purge.l.gz
pgsql/man/manl/rename.l.gz
@@ -159,24 +174,49 @@ share/doc/pgsql/TODO
share/doc/pgsql/TODO.GEQO
share/doc/pgsql/bug.template
share/doc/pgsql/libpgtcl.doc
+share/doc/pgsql/manual/admin.html
+share/doc/pgsql/manual/advanced.html
+share/doc/pgsql/manual/appenda.html
+share/doc/pgsql/manual/architec.html
+share/doc/pgsql/manual/copy.html
+share/doc/pgsql/manual/extend.html
+share/doc/pgsql/manual/figure01.gif
+share/doc/pgsql/manual/figure02.gif
+share/doc/pgsql/manual/figure03.gif
+share/doc/pgsql/manual/intro.html
+share/doc/pgsql/manual/libpq.html
+share/doc/pgsql/manual/lobj.html
+share/doc/pgsql/manual/pg95user.html
+share/doc/pgsql/manual/query.html
+share/doc/pgsql/manual/refs.html
+share/doc/pgsql/manual/rules.html
+share/doc/pgsql/manual/start.html
+share/doc/pgsql/manual/xaggr.html
+share/doc/pgsql/manual/xfunc.html
+share/doc/pgsql/manual/xindex.html
+share/doc/pgsql/manual/xoper.html
+share/doc/pgsql/manual/xtypes.html
+share/doc/pgsql/spi.txt
+share/doc/pgsql/trigger.txt
share/doc/pgsql/userguide.ps
+@dirrm share/doc/pgsql/manual
@dirrm share/doc/pgsql
-@dirrm pgsql/lib
@dirrm pgsql/bin
-@dirrm pgsql/include/port/BSD44_derived
-@dirrm pgsql/include/port
+@dirrm pgsql/data/base/template1
+@dirrm pgsql/data/base
+@dirrm pgsql/data
+@dirrm pgsql/include/access
@dirrm pgsql/include/include
@dirrm pgsql/include/lib
@dirrm pgsql/include/libpq
+@dirrm pgsql/include/port/BSD44_derived
+@dirrm pgsql/include/port
@dirrm pgsql/include/utils
-@dirrm pgsql/include/access
@dirrm pgsql/include
+@dirrm pgsql/lib
@dirrm pgsql/man/man1
@dirrm pgsql/man/man3
@dirrm pgsql/man/man5
@dirrm pgsql/man/manl
@dirrm pgsql/man
-@dirrm pgsql/data/base/template1
-@dirrm pgsql/data/base
-@dirrm pgsql/data
@dirrm pgsql