aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql94-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2014-10-09 15:20:52 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2014-10-09 15:20:52 +0000
commit13759079991ec09be412b3cb308b89b5234ffb26 (patch)
tree31d6eb2d7418897724039f9c7eb177604f34274c /databases/postgresql94-server
parent259fe123b6503e8f2eb168556ac6799eade5b29b (diff)
downloadports-13759079991ec09be412b3cb308b89b5234ffb26.tar.gz
ports-13759079991ec09be412b3cb308b89b5234ffb26.zip
Update to PostgreSQL 9.4 beta3
Notes
Notes: svn path=/head/; revision=370540
Diffstat (limited to 'databases/postgresql94-server')
-rw-r--r--databases/postgresql94-server/Makefile5
-rw-r--r--databases/postgresql94-server/distinfo4
-rw-r--r--databases/postgresql94-server/files/patch-contrib-uuid409
-rw-r--r--databases/postgresql94-server/pkg-plist-client94
-rw-r--r--databases/postgresql94-server/pkg-plist-contrib12
-rw-r--r--databases/postgresql94-server/pkg-plist-plperl8
-rw-r--r--databases/postgresql94-server/pkg-plist-plpython6
-rw-r--r--databases/postgresql94-server/pkg-plist-pltcl8
-rw-r--r--databases/postgresql94-server/pkg-plist-server63
9 files changed, 101 insertions, 508 deletions
diff --git a/databases/postgresql94-server/Makefile b/databases/postgresql94-server/Makefile
index da44e217991b..475069586d5d 100644
--- a/databases/postgresql94-server/Makefile
+++ b/databases/postgresql94-server/Makefile
@@ -1,9 +1,8 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
# $FreeBSD$
-DISTVERSION?= 9.4beta1
-PORTREVISION?= 1
-PKGNAMESUFFIX?= ${DISTVERSION:R:S/.//}${COMPONENT}
+DISTVERSION?= 9.4beta3
+PKGNAMESUFFIX?= ${DISTVERSION:S/.//:S/beta/./:R}${COMPONENT}
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql94-server/distinfo b/databases/postgresql94-server/distinfo
index 4c10b60e81c5..2e5321aebf8c 100644
--- a/databases/postgresql94-server/distinfo
+++ b/databases/postgresql94-server/distinfo
@@ -1,4 +1,4 @@
-SHA256 (postgresql/postgresql-9.4beta1.tar.bz2) = 0e088eff79bb5171b2233222a25d7a2906eaf62aa86266daf6ec5217b1797f47
-SIZE (postgresql/postgresql-9.4beta1.tar.bz2) = 17216572
+SHA256 (postgresql/postgresql-9.4beta3.tar.bz2) = 5ad1d86a5b9a70d5c153dd862b306a930c6cf67fb4a3f00813eef19fabe6aa5d
+SIZE (postgresql/postgresql-9.4beta1.tar.bz2) = 17355677
SHA256 (postgresql/pg-940-icu-2014-06-09.diff.gz) = 83de4b99c37aec1ad741c686cb2ea7f4bccff516c357ae71032b2d1f8da0d1c1
SIZE (postgresql/pg-940-icu-2014-06-09.diff.gz) = 4259
diff --git a/databases/postgresql94-server/files/patch-contrib-uuid b/databases/postgresql94-server/files/patch-contrib-uuid
deleted file mode 100644
index 2c957f1c7243..000000000000
--- a/databases/postgresql94-server/files/patch-contrib-uuid
+++ /dev/null
@@ -1,409 +0,0 @@
---- contrib/uuid-ossp/Makefile.orig 2014-03-17 20:35:47.000000000 +0100
-+++ contrib/uuid-ossp/Makefile 2014-03-19 20:51:44.000000000 +0100
-@@ -1,12 +1,14 @@
- # contrib/uuid-ossp/Makefile
-+# modified using http://pgfoundry.org/projects/uuid-freebsd/
-+# to actually not use ossp, since uuid methods are all
-+# built in into libc in FreeBSD /girgen@
-
- MODULE_big = uuid-ossp
- OBJS = uuid-ossp.o
-
- EXTENSION = uuid-ossp
- DATA = uuid-ossp--1.0.sql uuid-ossp--unpackaged--1.0.sql
--
--SHLIB_LINK += $(OSSP_UUID_LIBS)
-+SHLIB_LINK = -lmd
-
- ifdef USE_PGXS
- PG_CONFIG = pg_config
---- contrib/uuid-ossp/uuid-ossp--1.0.sql.orig 2014-03-17 20:35:47.000000000 +0100
-+++ contrib/uuid-ossp/uuid-ossp--1.0.sql 2014-03-19 20:51:44.000000000 +0100
-@@ -1,5 +1,12 @@
- /* contrib/uuid-ossp/uuid-ossp--1.0.sql */
-
-+-- this module is modified by girgen@ for FreeBSD using
-+-- http://pgfoundry.org/projects/uuid-freebsd/
-+-- based on the work of Andrew Gierth.
-+-- The name is still uuid-ossp to maintain verbatim compatibility
-+-- with the original ossp based module, although the built-in libc
-+-- routines are actually used instead, not ossp.
-+
- -- complain if script is sourced in psql, rather than via CREATE EXTENSION
- \echo Use '''CREATE EXTENSION "uuid-ossp"''' to load this file. \quit
-
---- contrib/uuid-ossp/uuid-ossp.c.orig 2014-03-17 20:35:47.000000000 +0100
-+++ contrib/uuid-ossp/uuid-ossp.c 2014-03-19 21:12:11.000000000 +0100
-@@ -1,11 +1,15 @@
- /*-------------------------------------------------------------------------
- *
-- * UUID generation functions using the OSSP UUID library
-+ * UUID generation functions for FreeBSD
- *
- * Copyright (c) 2007-2014, PostgreSQL Global Development Group
- *
- * contrib/uuid-ossp/uuid-ossp.c
- *
-+ * Modified to use FreeBSD's built in uuid instead of ossp:
-+ * Copyright (c) 2009 Andrew Gierth
-+ *
-+ * URL: http://pgfoundry.org/projects/uuid-freebsd
- *-------------------------------------------------------------------------
- */
-
-@@ -14,27 +18,14 @@
- #include "utils/builtins.h"
- #include "utils/uuid.h"
-
--/*
-- * There's some confusion over the location of the uuid.h header file.
-- * On Debian, it's installed as ossp/uuid.h, while on Fedora, or if you
-- * install ossp-uuid from a tarball, it's installed as uuid.h. Don't know
-- * what other systems do.
-- */
--#ifdef HAVE_OSSP_UUID_H
--#include <ossp/uuid.h>
--#else
--#ifdef HAVE_UUID_H
--#include <uuid.h>
--#else
--#error OSSP uuid.h not found
--#endif
--#endif
--
--/* better both be 16 */
--#if (UUID_LEN != UUID_LEN_BIN)
--#error UUID length mismatch
--#endif
-+/* OS has a uuid_hash that conflicts with ours; kill it*/
-+/* explicit path since we do _not_ want to get any other version */
-+#define uuid_hash freebsd_uuid_hash
-+#include "/usr/include/uuid.h"
-+#undef uuid_hash
-
-+#include <md5.h>
-+#include <sha.h>
-
- PG_MODULE_MAGIC;
-
-@@ -64,163 +55,175 @@
- PG_FUNCTION_INFO_V1(uuid_generate_v4);
- PG_FUNCTION_INFO_V1(uuid_generate_v5);
-
--static void
--pguuid_complain(uuid_rc_t rc)
--{
-- char *err = uuid_error(rc);
--
-- if (err != NULL)
-- ereport(ERROR,
-- (errcode(ERRCODE_EXTERNAL_ROUTINE_EXCEPTION),
-- errmsg("OSSP uuid library failure: %s", err)));
-- else
-- ereport(ERROR,
-- (errcode(ERRCODE_EXTERNAL_ROUTINE_EXCEPTION),
-- errmsg("OSSP uuid library failure: error code %d", rc)));
--}
-+/* we assume that the string representation is portable and that the
-+ * native binary representation might not be. But for *ns, we assume
-+ * that pg's internal storage of uuids is the simple byte-oriented
-+ * binary format. */
-
--static char *
--uuid_to_string(const uuid_t *uuid)
--{
-- char *buf = palloc(UUID_LEN_STR + 1);
-- void *ptr = buf;
-- size_t len = UUID_LEN_STR + 1;
-- uuid_rc_t rc;
--
-- rc = uuid_export(uuid, UUID_FMT_STR, &ptr, &len);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
--
-- return buf;
--}
--
--
--static void
--string_to_uuid(const char *str, uuid_t *uuid)
-+static Datum
-+internal_uuid_create(int v, unsigned char *ns, char *ptr, int len)
- {
-- uuid_rc_t rc;
--
-- rc = uuid_import(uuid, UUID_FMT_STR, str, UUID_LEN_STR + 1);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
--}
-+ char strbuf[40];
-
-+ switch (v)
-+ {
-+ case 0: /* constant-value uuids: nil, or namespace uuids */
-+ strlcpy(strbuf, ptr, 37);
-+ break;
-+
-+ case 4: default: /* random uuid */
-+ {
-+ sprintf(strbuf, "%08lx-%04x-%04x-%04x-%04x%08lx",
-+ (unsigned long) arc4random(),
-+ (unsigned) (arc4random() & 0xffff),
-+ (unsigned) ((arc4random() & 0xfff) | 0x4000),
-+ (unsigned) ((arc4random() & 0x3fff) | 0x8000),
-+ (unsigned) (arc4random() & 0xffff),
-+ (unsigned long) arc4random());
-+ break;
-+ }
-+
-+ case 1: /* time/node-based uuids */
-+ {
-+ uuid_t uu;
-+ uint32_t status = uuid_s_ok;
-+ char *str = NULL;
-+
-+ uuid_create(&uu, &status);
-+
-+ if (status == uuid_s_ok)
-+ {
-+ uuid_to_string(&uu, &str, &status);
-+ if (status == uuid_s_ok)
-+ {
-+ strlcpy(strbuf, str, 37);
-+
-+ /* PTR, if set, replaces the trailing characters of the uuid;
-+ * this is to support v1mc, where a random multicast MAC is
-+ * used instead of the physical one
-+ */
-+
-+ if (ptr && len <= 36)
-+ strcpy(strbuf + (36 - len), ptr);
-+ }
-+ if (str)
-+ free(str);
-+ }
-
--static Datum
--special_uuid_value(const char *name)
--{
-- uuid_t *uuid;
-- char *str;
-- uuid_rc_t rc;
--
-- rc = uuid_create(&uuid);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-- rc = uuid_load(uuid, name);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-- str = uuid_to_string(uuid);
-- rc = uuid_destroy(uuid);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-+ if (status != uuid_s_ok)
-+ {
-+ ereport(ERROR,
-+ (errcode(ERRCODE_EXTERNAL_ROUTINE_EXCEPTION),
-+ errmsg("FreeBSD uuid library failure: %d", (int) status)));
-+ }
-+
-+ break;
-+ }
-+
-+ case 3: /* namespace-based MD5 uuids */
-+ {
-+ /* we could use pg's md5(), but we're already pulling in libmd */
-+ MD5_CTX ctx;
-+ unsigned char buf[16];
-+
-+ MD5Init(&ctx);
-+ MD5Update(&ctx, ns, 16);
-+ MD5Update(&ctx, (unsigned char *)ptr, len);
-+ MD5Final(buf, &ctx);
-+
-+ sprintf(strbuf,
-+ "%02x%02x%02x%02x-"
-+ "%02x%02x-%02x%02x-%02x%02x-"
-+ "%02x%02x%02x%02x%02x%02x",
-+ buf[0], buf[1], buf[2], buf[3],
-+ buf[4], buf[5], ((buf[6] & 0xf) | 0x30), buf[7],
-+ ((buf[8] & 0x3F) | 0x80), buf[9], buf[10], buf[11],
-+ buf[12], buf[13], buf[14], buf[15]);
-+
-+ break;
-+ }
-+
-+ case 5: /* namespace-based SHA1 uuids */
-+ {
-+ SHA_CTX ctx;
-+ unsigned char buf[20];
-+
-+ SHA1_Init(&ctx);
-+ SHA1_Update(&ctx, ns, 16);
-+ SHA1_Update(&ctx, (unsigned char *)ptr, len);
-+ SHA1_Final(buf, &ctx);
-+
-+ sprintf(strbuf,
-+ "%02x%02x%02x%02x-"
-+ "%02x%02x-%02x%02x-%02x%02x-"
-+ "%02x%02x%02x%02x%02x%02x",
-+ buf[0], buf[1], buf[2], buf[3],
-+ buf[4], buf[5], ((buf[6] & 0xf) | 0x30), buf[7],
-+ ((buf[8] & 0x3F) | 0x80), buf[9], buf[10], buf[11],
-+ buf[12], buf[13], buf[14], buf[15]);
-+
-+ break;
-+ }
-+ }
-
-- return DirectFunctionCall1(uuid_in, CStringGetDatum(str));
-+ return DirectFunctionCall1(uuid_in, CStringGetDatum(strbuf));
- }
-
-
- Datum
- uuid_nil(PG_FUNCTION_ARGS)
- {
-- return special_uuid_value("nil");
-+ return internal_uuid_create(0, NULL, "00000000-0000-0000-0000-000000000000", 36);
- }
-
-
- Datum
- uuid_ns_dns(PG_FUNCTION_ARGS)
- {
-- return special_uuid_value("ns:DNS");
-+ return internal_uuid_create(0, NULL, "6ba7b810-9dad-11d1-80b4-00c04fd430c8", 36);
- }
-
-
- Datum
- uuid_ns_url(PG_FUNCTION_ARGS)
- {
-- return special_uuid_value("ns:URL");
-+ return internal_uuid_create(0, NULL, "6ba7b811-9dad-11d1-80b4-00c04fd430c8", 36);
- }
-
-
- Datum
- uuid_ns_oid(PG_FUNCTION_ARGS)
- {
-- return special_uuid_value("ns:OID");
-+ return internal_uuid_create(0, NULL, "6ba7b812-9dad-11d1-80b4-00c04fd430c8", 36);
- }
-
-
- Datum
- uuid_ns_x500(PG_FUNCTION_ARGS)
- {
-- return special_uuid_value("ns:X500");
--}
--
--
--static Datum
--uuid_generate_internal(int mode, const uuid_t *ns, const char *name)
--{
-- uuid_t *uuid;
-- char *str;
-- uuid_rc_t rc;
--
-- rc = uuid_create(&uuid);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-- rc = uuid_make(uuid, mode, ns, name);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-- str = uuid_to_string(uuid);
-- rc = uuid_destroy(uuid);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
--
-- return DirectFunctionCall1(uuid_in, CStringGetDatum(str));
-+ return internal_uuid_create(0, NULL, "6ba7b814-9dad-11d1-80b4-00c04fd430c8", 36);
- }
-
-
- Datum
- uuid_generate_v1(PG_FUNCTION_ARGS)
- {
-- return uuid_generate_internal(UUID_MAKE_V1, NULL, NULL);
-+ return internal_uuid_create(1, NULL, NULL, 0);
- }
-
-
- Datum
- uuid_generate_v1mc(PG_FUNCTION_ARGS)
- {
-- return uuid_generate_internal(UUID_MAKE_V1 | UUID_MAKE_MC, NULL, NULL);
--}
--
--
--static Datum
--uuid_generate_v35_internal(int mode, pg_uuid_t *ns, text *name)
--{
-- uuid_t *ns_uuid;
-- Datum result;
-- uuid_rc_t rc;
--
-- rc = uuid_create(&ns_uuid);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-- string_to_uuid(DatumGetCString(DirectFunctionCall1(uuid_out, UUIDPGetDatum(ns))),
-- ns_uuid);
--
-- result = uuid_generate_internal(mode,
-- ns_uuid,
-- text_to_cstring(name));
--
-- rc = uuid_destroy(ns_uuid);
-- if (rc != UUID_RC_OK)
-- pguuid_complain(rc);
-+ char buf[20];
-
-- return result;
-+ sprintf(buf, "-%04x-%04x%08lx",
-+ (unsigned)((arc4random() & 0x3FFF) | 0x8000),
-+ /* set IEEE802 multicast and local-admin bits */
-+ (unsigned)((arc4random() & 0xffff) | 0x0300),
-+ (unsigned long) arc4random());
-+
-+ return internal_uuid_create(1, NULL, buf, 18);
- }
-
-
-@@ -230,14 +233,15 @@
- pg_uuid_t *ns = PG_GETARG_UUID_P(0);
- text *name = PG_GETARG_TEXT_P(1);
-
-- return uuid_generate_v35_internal(UUID_MAKE_V3, ns, name);
-+ return internal_uuid_create(3, (unsigned char *)ns,
-+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
- }
-
-
- Datum
- uuid_generate_v4(PG_FUNCTION_ARGS)
- {
-- return uuid_generate_internal(UUID_MAKE_V4, NULL, NULL);
-+ return internal_uuid_create(4, NULL, NULL, 0);
- }
-
-
-@@ -247,5 +251,6 @@
- pg_uuid_t *ns = PG_GETARG_UUID_P(0);
- text *name = PG_GETARG_TEXT_P(1);
-
-- return uuid_generate_v35_internal(UUID_MAKE_V5, ns, name);
-+ return internal_uuid_create(5, (unsigned char *)ns,
-+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
- }
---- contrib/Makefile.orig 2014-03-21 08:58:32.000000000 +0100
-+++ contrib/Makefile 2014-03-21 08:59:13.000000000 +0100
-@@ -52,6 +52,7 @@
- test_parser \
- tsearch2 \
- unaccent \
-+ uuid-ossp \
- vacuumlo \
- worker_spi
-
diff --git a/databases/postgresql94-server/pkg-plist-client b/databases/postgresql94-server/pkg-plist-client
index a49f48ba4d84..ebce0373cf85 100644
--- a/databases/postgresql94-server/pkg-plist-client
+++ b/databases/postgresql94-server/pkg-plist-client
@@ -944,50 +944,50 @@ man/man7/WITH.7.gz
%%GETTEXT%%share/locale/zh_TW/LC_MESSAGES/psql-9.4.mo
%%DATADIR%%/pg_service.conf.sample
%%DATADIR%%/psqlrc.sample
-@dirrm include/libpq
-@dirrm include/postgresql/informix/esql
-@dirrm include/postgresql/informix
-@dirrm include/postgresql/internal/libpq
-@dirrm include/postgresql/internal
-@dirrm include/postgresql/server/access
-@dirrm include/postgresql/server/bootstrap
-@dirrm include/postgresql/server/catalog
-@dirrm include/postgresql/server/commands
-@dirrm include/postgresql/server/common
-@dirrm include/postgresql/server/datatype
-@dirrm include/postgresql/server/executor
-@dirrm include/postgresql/server/foreign
-@dirrm include/postgresql/server/lib
-@dirrm include/postgresql/server/libpq
-@dirrm include/postgresql/server/mb
-@dirrm include/postgresql/server/nodes
-@dirrm include/postgresql/server/optimizer
-@dirrm include/postgresql/server/parser
-@dirrm include/postgresql/server/port/win32/arpa
-@dirrm include/postgresql/server/port/win32/netinet
-@dirrm include/postgresql/server/port/win32/sys
-@dirrm include/postgresql/server/port/win32
-@dirrm include/postgresql/server/port/win32_msvc/sys
-@dirrm include/postgresql/server/port/win32_msvc
-@dirrm include/postgresql/server/port
-@dirrm include/postgresql/server/portability
-@dirrm include/postgresql/server/postmaster
-@dirrm include/postgresql/server/regex
-@dirrm include/postgresql/server/replication
-@dirrm include/postgresql/server/rewrite
-@dirrm include/postgresql/server/snowball/libstemmer
-@dirrm include/postgresql/server/snowball
-@dirrm include/postgresql/server/storage
-@dirrm include/postgresql/server/tcop
-@dirrm include/postgresql/server/tsearch/dicts
-@dirrm include/postgresql/server/tsearch
-@dirrm include/postgresql/server/utils
-@dirrm include/postgresql/server
-@dirrm include/postgresql
-@dirrm lib/postgresql/pgxs/config
-@dirrm lib/postgresql/pgxs/src/makefiles
-@dirrm lib/postgresql/pgxs/src
-@dirrm lib/postgresql/pgxs
-@dirrm lib/postgresql
-%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrmtry %%DATADIR%%
+@dir include/libpq
+@dir include/postgresql/informix/esql
+@dir include/postgresql/informix
+@dir include/postgresql/internal/libpq
+@dir include/postgresql/internal
+@dir include/postgresql/server/access
+@dir include/postgresql/server/bootstrap
+@dir include/postgresql/server/catalog
+@dir include/postgresql/server/commands
+@dir include/postgresql/server/common
+@dir include/postgresql/server/datatype
+@dir include/postgresql/server/executor
+@dir include/postgresql/server/foreign
+@dir include/postgresql/server/lib
+@dir include/postgresql/server/libpq
+@dir include/postgresql/server/mb
+@dir include/postgresql/server/nodes
+@dir include/postgresql/server/optimizer
+@dir include/postgresql/server/parser
+@dir include/postgresql/server/port/win32/arpa
+@dir include/postgresql/server/port/win32/netinet
+@dir include/postgresql/server/port/win32/sys
+@dir include/postgresql/server/port/win32
+@dir include/postgresql/server/port/win32_msvc/sys
+@dir include/postgresql/server/port/win32_msvc
+@dir include/postgresql/server/port
+@dir include/postgresql/server/portability
+@dir include/postgresql/server/postmaster
+@dir include/postgresql/server/regex
+@dir include/postgresql/server/replication
+@dir include/postgresql/server/rewrite
+@dir include/postgresql/server/snowball/libstemmer
+@dir include/postgresql/server/snowball
+@dir include/postgresql/server/storage
+@dir include/postgresql/server/tcop
+@dir include/postgresql/server/tsearch/dicts
+@dir include/postgresql/server/tsearch
+@dir include/postgresql/server/utils
+@dir include/postgresql/server
+@dir include/postgresql
+@dir lib/postgresql/pgxs/config
+@dir lib/postgresql/pgxs/src/makefiles
+@dir lib/postgresql/pgxs/src
+@dir lib/postgresql/pgxs
+@dir lib/postgresql
+%%PORTDOCS%%@dir %%DOCSDIR%%
+@dir %%DATADIR%%
diff --git a/databases/postgresql94-server/pkg-plist-contrib b/databases/postgresql94-server/pkg-plist-contrib
index 5b8dee18f1b4..a0dfaa409dd2 100644
--- a/databases/postgresql94-server/pkg-plist-contrib
+++ b/databases/postgresql94-server/pkg-plist-contrib
@@ -203,9 +203,9 @@ share/doc/postgresql/extension/timetravel.example
%%DATADIR%%/extension/xml2.control
%%DATADIR%%/tsearch_data/unaccent.rules
%%DATADIR%%/tsearch_data/xsyn_sample.rules
-@dirrmtry %%DATADIR%%/tsearch_data
-@dirrmtry %%DATADIR%%/extension
-@dirrmtry %%DATADIR%%
-@dirrmtry %%DOCSDIR%%/extension
-@dirrmtry %%DOCSDIR%%
-@dirrmtry lib/postgresql
+@dir %%DATADIR%%/tsearch_data
+@dir %%DATADIR%%/extension
+@dir %%DATADIR%%
+@dir %%DOCSDIR%%/extension
+@dir %%DOCSDIR%%
+@dir lib/postgresql
diff --git a/databases/postgresql94-server/pkg-plist-plperl b/databases/postgresql94-server/pkg-plist-plperl
index e272701ecc42..feaadbf119d2 100644
--- a/databases/postgresql94-server/pkg-plist-plperl
+++ b/databases/postgresql94-server/pkg-plist-plperl
@@ -6,7 +6,7 @@
%%DATADIR%%/extension/plperl--unpackaged--1.0.sql
%%DOCSDIR%%/README-plperl
lib/postgresql/plperl.so
-@dirrmtry lib/postgresql
-@dirrmtry %%DOCSDIR%%
-@dirrmtry %%DATADIR%%/extension
-@dirrmtry %%DATADIR%%
+@dir lib/postgresql
+@dir %%DOCSDIR%%
+@dir %%DATADIR%%/extension
+@dir %%DATADIR%%
diff --git a/databases/postgresql94-server/pkg-plist-plpython b/databases/postgresql94-server/pkg-plist-plpython
index 1f74e5ec1da4..c7ffa81d313c 100644
--- a/databases/postgresql94-server/pkg-plist-plpython
+++ b/databases/postgresql94-server/pkg-plist-plpython
@@ -10,6 +10,6 @@
%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
%%PYTHON3%%%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
-@dirrmtry %%DATADIR%%/extension
-@dirrmtry lib/postgresql
-@dirrmtry %%DOCSDIR%%
+@dir %%DATADIR%%/extension
+@dir lib/postgresql
+@dir %%DOCSDIR%%
diff --git a/databases/postgresql94-server/pkg-plist-pltcl b/databases/postgresql94-server/pkg-plist-pltcl
index 66cc153320be..2a72dece5e15 100644
--- a/databases/postgresql94-server/pkg-plist-pltcl
+++ b/databases/postgresql94-server/pkg-plist-pltcl
@@ -6,11 +6,11 @@
%%DATADIR%%/extension/pltclu--unpackaged--1.0.sql
%%DOCSDIR%%/README-pltcl
lib/postgresql/pltcl.so
-@dirrmtry lib/postgresql
+@dir lib/postgresql
bin/pltcl_loadmod
bin/pltcl_delmod
bin/pltcl_listmod
share/postgresql/unknown.pltcl
-@dirrmtry %%DATADIR%%/extension
-@dirrmtry %%DATADIR%%
-@dirrmtry %%DOCSDIR%%
+@dir %%DATADIR%%/extension
+@dir %%DATADIR%%
+@dir %%DOCSDIR%%
diff --git a/databases/postgresql94-server/pkg-plist-server b/databases/postgresql94-server/pkg-plist-server
index 5d302007cc09..be1cce594514 100644
--- a/databases/postgresql94-server/pkg-plist-server
+++ b/databases/postgresql94-server/pkg-plist-server
@@ -40,7 +40,7 @@ lib/postgresql/utf8_and_uhc.so
lib/postgresql/utf8_and_win.so
lib/libpgcommon.a
%%PORTDOCS%%%%DOCSDIR%%/README-server
-%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+%%PORTDOCS%%@dir %%DOCSDIR%%
%%DATADIR%%/conversion_create.sql
%%DATADIR%%/information_schema.sql
%%DATADIR%%/pg_hba.conf.sample
@@ -358,6 +358,7 @@ lib/libpgcommon.a
%%TZDATA%%%%DATADIR%%/timezone/Antarctica/Rothera
%%TZDATA%%%%DATADIR%%/timezone/Antarctica/South_Pole
%%TZDATA%%%%DATADIR%%/timezone/Antarctica/Syowa
+%%TZDATA%%%%DATADIR%%/timezone/Antarctica/Troll
%%TZDATA%%%%DATADIR%%/timezone/Antarctica/Vostok
%%TZDATA%%%%DATADIR%%/timezone/Arctic/Longyearbyen
%%TZDATA%%%%DATADIR%%/timezone/Asia/Aden
@@ -376,6 +377,7 @@ lib/libpgcommon.a
%%TZDATA%%%%DATADIR%%/timezone/Asia/Bishkek
%%TZDATA%%%%DATADIR%%/timezone/Asia/Brunei
%%TZDATA%%%%DATADIR%%/timezone/Asia/Calcutta
+%%TZDATA%%%%DATADIR%%/timezone/Asia/Chita
%%TZDATA%%%%DATADIR%%/timezone/Asia/Choibalsan
%%TZDATA%%%%DATADIR%%/timezone/Asia/Chongqing
%%TZDATA%%%%DATADIR%%/timezone/Asia/Chungking
@@ -433,6 +435,7 @@ lib/libpgcommon.a
%%TZDATA%%%%DATADIR%%/timezone/Asia/Seoul
%%TZDATA%%%%DATADIR%%/timezone/Asia/Shanghai
%%TZDATA%%%%DATADIR%%/timezone/Asia/Singapore
+%%TZDATA%%%%DATADIR%%/timezone/Asia/Srednekolymsk
%%TZDATA%%%%DATADIR%%/timezone/Asia/Taipei
%%TZDATA%%%%DATADIR%%/timezone/Asia/Tashkent
%%TZDATA%%%%DATADIR%%/timezone/Asia/Tbilisi
@@ -723,27 +726,27 @@ lib/libpgcommon.a
%%DATADIR%%/timezonesets/India
%%DATADIR%%/timezonesets/Indian.txt
%%DATADIR%%/timezonesets/Pacific.txt
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Africa
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/America/Argentina
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/America/Indiana
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/America/Kentucky
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/America/North_Dakota
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/America
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Antarctica
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Arctic
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Asia
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Atlantic
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Australia
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Brazil
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Canada
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Chile
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Etc
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Europe
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Indian
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Mexico
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/Pacific
-%%TZDATA%%@dirrm %%DATADIR%%/timezone/US
-%%TZDATA%%@dirrm %%DATADIR%%/timezone
+%%TZDATA%%@dir %%DATADIR%%/timezone/Africa
+%%TZDATA%%@dir %%DATADIR%%/timezone/America/Argentina
+%%TZDATA%%@dir %%DATADIR%%/timezone/America/Indiana
+%%TZDATA%%@dir %%DATADIR%%/timezone/America/Kentucky
+%%TZDATA%%@dir %%DATADIR%%/timezone/America/North_Dakota
+%%TZDATA%%@dir %%DATADIR%%/timezone/America
+%%TZDATA%%@dir %%DATADIR%%/timezone/Antarctica
+%%TZDATA%%@dir %%DATADIR%%/timezone/Arctic
+%%TZDATA%%@dir %%DATADIR%%/timezone/Asia
+%%TZDATA%%@dir %%DATADIR%%/timezone/Atlantic
+%%TZDATA%%@dir %%DATADIR%%/timezone/Australia
+%%TZDATA%%@dir %%DATADIR%%/timezone/Brazil
+%%TZDATA%%@dir %%DATADIR%%/timezone/Canada
+%%TZDATA%%@dir %%DATADIR%%/timezone/Chile
+%%TZDATA%%@dir %%DATADIR%%/timezone/Etc
+%%TZDATA%%@dir %%DATADIR%%/timezone/Europe
+%%TZDATA%%@dir %%DATADIR%%/timezone/Indian
+%%TZDATA%%@dir %%DATADIR%%/timezone/Mexico
+%%TZDATA%%@dir %%DATADIR%%/timezone/Pacific
+%%TZDATA%%@dir %%DATADIR%%/timezone/US
+%%TZDATA%%@dir %%DATADIR%%/timezone
%%DATADIR%%/tsearch_data/danish.stop
%%DATADIR%%/tsearch_data/dutch.stop
%%DATADIR%%/tsearch_data/english.stop
@@ -763,13 +766,13 @@ lib/libpgcommon.a
%%DATADIR%%/tsearch_data/ispell_sample.dict
%%DATADIR%%/tsearch_data/synonym_sample.syn
%%DATADIR%%/tsearch_data/thesaurus_sample.ths
-@dirrmtry %%DATADIR%%/extension
-@dirrm %%DATADIR%%/timezonesets
+@dir %%DATADIR%%/extension
+@dir %%DATADIR%%/timezonesets
@exec /bin/mkdir -p %%PREFIX%%/%%PG_USER%% || /usr/bin/true
@exec /usr/sbin/chown %%PG_USER%%:%%PG_GROUP%% %%PREFIX%%/%%PG_USER%% || /usr/bin/true
-@dirrmtry %%DATADIR%%/tsearch_data
-@dirrmtry %%DATADIR%%
-@dirrmtry etc/periodic/daily
-@dirrmtry etc/periodic
-@dirrmtry lib/postgresql
-@dirrmtry %%PG_USER%%
+@dir %%DATADIR%%/tsearch_data
+@dir %%DATADIR%%
+@dir etc/periodic/daily
+@dir etc/periodic
+@dir lib/postgresql
+@dir %%PG_USER%%