aboutsummaryrefslogtreecommitdiff
path: root/databases/py-MySQLdb
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-03-18 15:10:46 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-03-18 15:10:46 +0000
commit1dde51176b70e83c9ea85a26340dcc5ec87f2de3 (patch)
tree9cb32ae4b3ee893aab023276e0f89176b15a0bf2 /databases/py-MySQLdb
parent84c94c7326e3043d33a9942bb7b7d9c139157c82 (diff)
downloadports-1dde51176b70e83c9ea85a26340dcc5ec87f2de3.tar.gz
ports-1dde51176b70e83c9ea85a26340dcc5ec87f2de3.zip
Fix SSL support.
PR: 187666 Submitted by: Michael Gmelin <freebsd@grem.de>
Notes
Notes: svn path=/head/; revision=348573
Diffstat (limited to 'databases/py-MySQLdb')
-rw-r--r--databases/py-MySQLdb/Makefile2
-rw-r--r--databases/py-MySQLdb/files/patch-_mysql.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/databases/py-MySQLdb/Makefile b/databases/py-MySQLdb/Makefile
index 53bcb97b18c5..348c5099d31b 100644
--- a/databases/py-MySQLdb/Makefile
+++ b/databases/py-MySQLdb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= MySQLdb
DISTVERSION= 1.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases python
MASTER_SITES= SF/mysql-python/mysql-python/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/py-MySQLdb/files/patch-_mysql.c b/databases/py-MySQLdb/files/patch-_mysql.c
new file mode 100644
index 000000000000..2f28da8facf4
--- /dev/null
+++ b/databases/py-MySQLdb/files/patch-_mysql.c
@@ -0,0 +1,13 @@
+--- _mysql.c.orig 2014-03-18 19:07:07.000000000 +0400
++++ _mysql.c 2014-03-18 19:07:40.000000000 +0400
+@@ -102,6 +102,10 @@ static int _mysql_server_init_done = 0;
+ #define check_server_init(x) if (!_mysql_server_init_done) _mysql_server_init_done = 1
+ #endif
+
++#if MYSQL_VERSION_ID >= 50500
++#define HAVE_OPENSSL 1
++#endif
++
+ PyObject *
+ _mysql_Exception(_mysql_ConnectionObject *c)
+ {