aboutsummaryrefslogtreecommitdiff
path: root/databases/py-apsw/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-08 10:33:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-08 10:33:39 +0000
commit1d2b0860f956a866efbb85da7a966fbd15052814 (patch)
treef274e8a4cdfaf3888c9f13e7e357bff0c7ce92dd /databases/py-apsw/Makefile
parenta6d5a3bdbcec5c5c1189ff4cd284d315a852d58f (diff)
downloadports-1d2b0860f956a866efbb85da7a966fbd15052814.tar.gz
ports-1d2b0860f956a866efbb85da7a966fbd15052814.zip
Update to 3.17.0
- Allow concurrent installation (USE_PYTHON=concurrent) - Do not silence installation and test messages - Cosmetic change - Update pkg-descr Changes: https://github.com/rogerbinns/apsw/releases https://rogerbinns.github.io/apsw/changes.html
Notes
Notes: svn path=/head/; revision=437999
Diffstat (limited to 'databases/py-apsw/Makefile')
-rw-r--r--databases/py-apsw/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/databases/py-apsw/Makefile b/databases/py-apsw/Makefile
index 230d17be51f7..08fd92c95562 100644
--- a/databases/py-apsw/Makefile
+++ b/databases/py-apsw/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= apsw
-PORTVERSION= 3.14.1
+PORTVERSION= 3.17.0
DISTVERSIONSUFFIX= -r1
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,16 +13,16 @@ COMMENT= Another Python SQLite Wrapper
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GITHUB= yes
-GH_ACCOUNT= rogerbinns
-
+USE_PYTHON= autoplist concurrent distutils
USES= localbase python sqlite:3
-USE_PYTHON= distutils autoplist
+
+GH_ACCOUNT= rogerbinns
+USE_GITHUB= yes
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/apsw.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/apsw.so
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ cd ${WRKSRC}/ && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>