aboutsummaryrefslogtreecommitdiff
path: root/databases/py-apsw/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-19 20:09:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-19 20:09:01 +0000
commit8aa8a13b5857038e2292f16ed5977bfceb1cd704 (patch)
tree57296dcc1f1466f8972f0043b0ae8593217ffb44 /databases/py-apsw/Makefile
parent0d6bd45401340eb61aafd2729c5135b756dd8600 (diff)
downloadports-8aa8a13b5857038e2292f16ed5977bfceb1cd704.tar.gz
ports-8aa8a13b5857038e2292f16ed5977bfceb1cd704.zip
Use upstream asset instead of source tarball
- Bump PORTREVISION for package change
Notes
Notes: svn path=/head/; revision=558519
Diffstat (limited to 'databases/py-apsw/Makefile')
-rw-r--r--databases/py-apsw/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/databases/py-apsw/Makefile b/databases/py-apsw/Makefile
index abbf7db652ba..e141d1f131d4 100644
--- a/databases/py-apsw/Makefile
+++ b/databases/py-apsw/Makefile
@@ -5,26 +5,23 @@ PORTNAME= apsw
PORTVERSION= 3.33.0
DISTVERSIONSUFFIX= -r1
CATEGORIES= databases python
+MASTER_SITES= https://github.com/rogerbinns/apsw/releases/download/${PORTVERSION}${DISTVERSIONSUFFIX}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Another Python SQLite Wrapper
LICENSE= ZLIB
-LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= sqlite3>=${PORTVERSION:R},1:databases/sqlite3
-USES= localbase python sqlite:3
+USES= localbase python sqlite:3 zip
USE_PYTHON= autoplist concurrent distutils
-GH_ACCOUNT= rogerbinns
-USE_GITHUB= yes
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/apsw.so
do-test:
- cd ${WRKSRC}/ && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ cd ${WRKSRC}/ && ${PYTHON_CMD} setup.py test
.include <bsd.port.mk>