aboutsummaryrefslogtreecommitdiff
path: root/databases/py-carbon/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-16 14:22:12 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-16 14:22:12 +0000
commit624d76338342d42dab244f91fdda22b977cbe186 (patch)
treeee549098468d9773dcc7298436bfb56cf61b3680 /databases/py-carbon/Makefile
parent16aee7d8de334264ad58f504dcff0e79fc403d31 (diff)
downloadports-624d76338342d42dab244f91fdda22b977cbe186.tar.gz
ports-624d76338342d42dab244f91fdda22b977cbe186.zip
- update dependency version on databases/py-whisper
- fix comments in carbon's rc-script - checksum change, that was in original PR is rejected, because it fetches fine with old checksums and fails to fetch with new ones. while here: - change etc/carbon to %%ETCDIR%% in pkg-plist - remove unneeded newlines in files/pkg_message.in - add license (AL2) - remove BUILD_DEPENDS (setup.py didn't cheking for it on build phase) - limit python version to 2.x - tab -> space in pkg-descr:WWW - this port depends on twisted both directly and via USE_TWISTED. Since I wasn't able to find which twisted components it actually needed, I just dropped USE_TWISTED and let the port to depend on it via devel/py-twisted meta-port PR: 170920 Submitted by: Chris McCoy <bsdports at wayfair dot com> (maintainer)
Notes
Notes: svn path=/head/; revision=304351
Diffstat (limited to 'databases/py-carbon/Makefile')
-rw-r--r--databases/py-carbon/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/databases/py-carbon/Makefile b/databases/py-carbon/Makefile
index 434d986f84d8..bb225e6eab28 100644
--- a/databases/py-carbon/Makefile
+++ b/databases/py-carbon/Makefile
@@ -14,14 +14,14 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= bsdports@wayfair.com
COMMENT= Backend storage application for graphite
+LICENSE= AL2
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}txamqp>=0.3:${PORTSDIR}/net/py-txamqp \
- ${PYTHON_PKGNAMEPREFIX}whisper>=0.9.9:${PORTSDIR}/databases/py-whisper \
- ${PYTHON_PKGNAMEPREFIX}twisted>=11.0.0:${PORTSDIR}/devel/py-twisted
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+ ${PYTHON_PKGNAMEPREFIX}whisper>=0.9.10:${PORTSDIR}/databases/py-whisper \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=11.0.0:${PORTSDIR}/devel/py-twisted
-USE_PYTHON= 2.6+
+USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
-USE_TWISTED= yes
FETCH_ARGS= -pRr
USE_RC_SUBR= carbon