aboutsummaryrefslogtreecommitdiff
path: root/databases/py-dbt-snowflake
diff options
context:
space:
mode:
authorPat Maddox <pat@patmaddox.com>2023-10-22 08:43:24 +0000
committerKurt Jaeger <pi@FreeBSD.org>2023-10-22 08:43:24 +0000
commit3601989e86ec783801f9ffca5b8374e1757f107b (patch)
tree3690a6feff970b4487b70dc9674027083087ce40 /databases/py-dbt-snowflake
parentda38902830d326a2b5f2fb45f4d6f2e91ef57614 (diff)
downloadports-3601989e86ec783801f9ffca5b8374e1757f107b.tar.gz
ports-3601989e86ec783801f9ffca5b8374e1757f107b.zip
databases/py-dbt-snowflake: new port
The dbt-snowflake package contains all of the code enabling dbt to work with Snowflake. PR: 274583 Author: Pat Maddox <pat@patmaddox.com>
Diffstat (limited to 'databases/py-dbt-snowflake')
-rw-r--r--databases/py-dbt-snowflake/Makefile38
-rw-r--r--databases/py-dbt-snowflake/distinfo3
-rw-r--r--databases/py-dbt-snowflake/pkg-descr2
3 files changed, 43 insertions, 0 deletions
diff --git a/databases/py-dbt-snowflake/Makefile b/databases/py-dbt-snowflake/Makefile
new file mode 100644
index 000000000000..d09504defe8c
--- /dev/null
+++ b/databases/py-dbt-snowflake/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= dbt-snowflake
+PORTVERSION= 1.6.0
+CATEGORIES= databases python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= pat@patmaddox.com
+COMMENT= Snowflake adapter plugin for dbt
+WWW= https://github.com/dbt-labs/dbt-snowflake
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}agate>0:textproc/py-agate@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbt-core>=1.6,<2:databases/py-dbt-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}snowflake-connector-python>=3.0,<4:databases/py-snowflake-connector-python@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+# py-dbt-snowflake attempts to install __init__.py and the generated bytecode into
+# these directories which conflicts with those installed by py-dbt-core. We need to
+# delete these files and their entries in the generated plist post-install.
+COMMON_DIRS= dbt \
+ dbt/adapters \
+ dbt/include
+
+post-stage:
+.for dir in ${COMMON_DIRS:S|/|\/|g}
+ @${REINPLACE_CMD} -e '/.*\/${dir}\/__init__.py/d' \
+ -e '/.*\/${dir}\/__pycache__.*/d' \
+ ${WRKDIR}/.PLIST.pymodtmp
+.endfor
+.for dir in ${COMMON_DIRS}
+ @(cd ${STAGEDIR}${PYTHON_SITELIBDIR}/${dir} && ${RM} -r __pycache__ __init__.py)
+.endfor
+
+.include <bsd.port.mk>
diff --git a/databases/py-dbt-snowflake/distinfo b/databases/py-dbt-snowflake/distinfo
new file mode 100644
index 000000000000..76bf8dc3209c
--- /dev/null
+++ b/databases/py-dbt-snowflake/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691563233
+SHA256 (dbt-snowflake-1.6.0.tar.gz) = 1e710aeafceaa57318dce58789595c813cc1c551f43a0e1ec03d34c6659f504c
+SIZE (dbt-snowflake-1.6.0.tar.gz) = 31680
diff --git a/databases/py-dbt-snowflake/pkg-descr b/databases/py-dbt-snowflake/pkg-descr
new file mode 100644
index 000000000000..0c0b89753a9a
--- /dev/null
+++ b/databases/py-dbt-snowflake/pkg-descr
@@ -0,0 +1,2 @@
+The dbt-snowflake package contains all of the code enabling dbt to work with
+Snowflake.