aboutsummaryrefslogtreecommitdiff
path: root/databases/py-mongoengine
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
commit74174b26616baa21c285c0515b591e7d738c5c0f (patch)
tree1c10419849a595f8ebfa59836f2e676bb7ec3469 /databases/py-mongoengine
parent45b08b671d6459dc7e71950a89cac654920ec089 (diff)
downloadports-74174b26616baa21c285c0515b591e7d738c5c0f.tar.gz
ports-74174b26616baa21c285c0515b591e7d738c5c0f.zip
graphics/py-pillow: Update to 7.0.0
* Repo-Copy the Pillow 6.2.2 release to graphics/py-pillow6 to retain backwards compatibility for Python 2 consumers as the Pillow 7.0.0 release dropped the support for Python 2. * Apply conditional statements to use either Pillow 7.x or Pillow 6.x for consumers that can be built for Python 2 or newer. * Exceptions are ports that can be built only for either Python 2 or Python 3. For the first case, consumers are just assigned to the repo-copied graphics/py-pillow6. * Also remove Pillow from BUILD_DEPENDS of math/py-PyWavelets as it is not listed in setup.py as a build dependency [1] and relax the version requirements of Pillow for www/py-wagtail. Release Notes: * https://pillow.readthedocs.io/en/latest/releasenotes/index.html Backward Incompatible Changes (7.0.0): * https://pillow.readthedocs.io/en/latest/releasenotes/7.0.0.html#backwards-incompatible-changes Detailed Changelog: * https://github.com/python-pillow/Pillow/blob/7.0.0/CHANGES.rst PR: 243665 Submitted by: sunpoet (patch for 7.0.0 and repo-copied version) Reviewed by: koobs [1], sunpoet Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D23713
Notes
Notes: svn path=/head/; revision=526962
Diffstat (limited to 'databases/py-mongoengine')
-rw-r--r--databases/py-mongoengine/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/databases/py-mongoengine/Makefile b/databases/py-mongoengine/Makefile
index d6fb87c18e92..4d34704c6528 100644
--- a/databases/py-mongoengine/Makefile
+++ b/databases/py-mongoengine/Makefile
@@ -16,8 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymongo>=3.4:databases/pymongo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=2.0.0:graphics/py-pillow@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR}
py27_TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR}
USES= python
@@ -25,6 +24,14 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=2.0.0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=2.0.0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
# bson is provided by pymongo
post-patch:
@${RM} -r ${WRKSRC}/bson
@@ -32,4 +39,4 @@ post-patch:
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>