aboutsummaryrefslogtreecommitdiff
path: root/databases/py-python-binary-memcached
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-08-30 07:12:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-08-30 07:12:37 +0000
commit359ea5d1be9dc49afa44dbde0c588be524b2d499 (patch)
tree9857b4f307ccfa3c6932b4146bcfcc1cb08e2a88 /databases/py-python-binary-memcached
parentafe72edb94c11ab720d18e06d9f7de43bbea5ff1 (diff)
downloadports-359ea5d1be9dc49afa44dbde0c588be524b2d499.tar.gz
ports-359ea5d1be9dc49afa44dbde0c588be524b2d499.zip
Add py-python-binary-memcached 0.30.0
bmemcached is a pure python module (thread safe) to access memcached via it's binary with SASL auth support. The main purpose of this module it to be able to communicate with memcached using binary protocol and support authentication, so it can work with Heroku for example. WWW: https://github.com/jaysonsantos/python-binary-memcached
Notes
Notes: svn path=/head/; revision=546973
Diffstat (limited to 'databases/py-python-binary-memcached')
-rw-r--r--databases/py-python-binary-memcached/Makefile27
-rw-r--r--databases/py-python-binary-memcached/distinfo3
-rw-r--r--databases/py-python-binary-memcached/pkg-descr8
3 files changed, 38 insertions, 0 deletions
diff --git a/databases/py-python-binary-memcached/Makefile b/databases/py-python-binary-memcached/Makefile
new file mode 100644
index 000000000000..6a597b540c0e
--- /dev/null
+++ b/databases/py-python-binary-memcached/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-binary-memcached
+PORTVERSION= 0.30.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pure python module to access memcached via its binary protocol
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uhashring>=0:security/py-uhashring@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/databases/py-python-binary-memcached/distinfo b/databases/py-python-binary-memcached/distinfo
new file mode 100644
index 000000000000..c2676340624e
--- /dev/null
+++ b/databases/py-python-binary-memcached/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1598605156
+SHA256 (python-binary-memcached-0.30.0.tar.gz) = 93669e5620b9fa9ab55d475191a2c3853132b693c5de719ed10eda2c8829391c
+SIZE (python-binary-memcached-0.30.0.tar.gz) = 93280
diff --git a/databases/py-python-binary-memcached/pkg-descr b/databases/py-python-binary-memcached/pkg-descr
new file mode 100644
index 000000000000..2a84fced4383
--- /dev/null
+++ b/databases/py-python-binary-memcached/pkg-descr
@@ -0,0 +1,8 @@
+bmemcached is a pure python module (thread safe) to access memcached via it's
+binary with SASL auth support.
+
+The main purpose of this module it to be able to communicate with memcached
+using binary protocol and support authentication, so it can work with Heroku for
+example.
+
+WWW: https://github.com/jaysonsantos/python-binary-memcached