aboutsummaryrefslogtreecommitdiff
path: root/databases/py-swift/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-09-17 03:13:32 +0000
committerWen Heping <wen@FreeBSD.org>2010-09-17 03:13:32 +0000
commit78fe1f23f9d2d0db13efbcc9d6263430d75cb423 (patch)
tree777363eb56a0f2c52fa8fbed790748f8ffed1900 /databases/py-swift/Makefile
parentca980848d744413da579ca6763c99962441e3d60 (diff)
downloadports-78fe1f23f9d2d0db13efbcc9d6263430d75cb423.tar.gz
ports-78fe1f23f9d2d0db13efbcc9d6263430d75cb423.zip
Swift is a highly available, distributed, eventually consistent
object/blob store. WWW: http://launchpad.net/swift PR: ports/150063 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Notes
Notes: svn path=/head/; revision=261311
Diffstat (limited to 'databases/py-swift/Makefile')
-rw-r--r--databases/py-swift/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/databases/py-swift/Makefile b/databases/py-swift/Makefile
new file mode 100644
index 000000000000..385e3374a6be
--- /dev/null
+++ b/databases/py-swift/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-swift
+# Date created: 2010-07-22
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= swift
+PORTVERSION= 1.0.2
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Highly available, distributed, eventually consistent object/blob store
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9.8:${PORTSDIR}/net/py-eventlet \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=0:${PORTSDIR}/devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}webob>=0.9.8:${PORTSDIR}/www/py-webob \
+ ${PYTHON_PKGNAMEPREFIX}xattr>=0:${PORTSDIR}/devel/py-xattr \
+ rsync>=3.0:${PORTSDIR}/net/rsync
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= easy_install
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${CP} -R ${WRKSRC}/etc/ ${PREFIX}/etc/${PORTNAME}
+
+.include <bsd.port.mk>