aboutsummaryrefslogtreecommitdiff
path: root/databases/pypy-gdbm
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-07-21 06:02:04 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-07-21 06:02:04 +0000
commitbce7563401057b6a13491d185fc43bf7eadf5c9f (patch)
tree02ed5a100b78ad24b4fe33d264212e20dfaa949d /databases/pypy-gdbm
parentdf09d83a48a512d8cf3fb4ab8057f0e1eee6833d (diff)
downloadports-bce7563401057b6a13491d185fc43bf7eadf5c9f.tar.gz
ports-bce7563401057b6a13491d185fc43bf7eadf5c9f.zip
lang/pypy: update to 5.3.1.
- Fix LICENSE for databases/pypy-gdbm (GPLv2+). - Add support for a slave port (i.e. the upcoming pypy3): - Allow select variables to be overridden by slave port. - Allow slave port to have its own distinfo and pkg-plist files. - Depend on lang/pypy if translating with PYPY or PYPY_MINMEM options. - Strip bundled cffi .so files. ChangeLog: - Highlighted changes - Major improvements in the C-API compatibility layer - Complete support for lxml - Passing 95%+ of numpy's test suite - Scipy and matplotlib builds and runs - cffi updated to 1.7 - New features: - Merge a major expansion of the C-API support in cpyext, also expand cpyext tests to allow running them after translation as well as untranslated - Instead of ?GIL not held when a CPython C extension module calls PyXxx?, we now silently acquire/release the GIL. Helps with C extension modules that call some PyXxx() functions without holding the GIL (arguably, they are theoretically buggy). - Support command line -v to trace import statements - Revive traceviewer, a tool to use pygame to view traces - Numpy via our internal _numpypy module: - Implement ufunc.outer - Move PyPy-specific numpypy headers to a subdirectory (also changed the repo accordingly) - Performance improvements: - Use bitstrings to compress lists of descriptors that are attached to an EffectInfo - Remove most of the _ovf, _zer and _val operations from RPython. Kills quite some code internally, and allows the JIT to do better optimizations: for example, app-level code like x / 2 or x % 2 can now be turned into x >> 1 or x & 1, even if x is possibly negative. - Rework the way registers are moved/spilled in before_call() - Internal refactorings: - Refactor code to better support Python3-compatible syntax - Reduce the size of generated C sources during translation by eliminating many many unused struct declarations (Issue #2281) - Reduce the size of generated code by using the same function objects in all generated subclasses - Share cpyext Py* function wrappers according to the signature, shrinking the translated libpypy.so by about 10% (without the JIT)
Notes
Notes: svn path=/head/; revision=418864
Diffstat (limited to 'databases/pypy-gdbm')
-rw-r--r--databases/pypy-gdbm/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/databases/pypy-gdbm/Makefile b/databases/pypy-gdbm/Makefile
index 95e3e13c1664..a38e3b78b8bc 100644
--- a/databases/pypy-gdbm/Makefile
+++ b/databases/pypy-gdbm/Makefile
@@ -8,6 +8,8 @@ CATEGORIES= databases python
MAINTAINER= python@FreeBSD.org
COMMENT= PyPy bindings to the GNU dbm library
+LICENSE= GPLv2+
+
LIB_DEPENDS= libgdbm.so:databases/gdbm
CFFI_NAME= ffi