aboutsummaryrefslogtreecommitdiff
path: root/databases/qdbm-plus
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /databases/qdbm-plus
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=384038
Diffstat (limited to 'databases/qdbm-plus')
-rw-r--r--databases/qdbm-plus/Makefile2
-rw-r--r--databases/qdbm-plus/files/patch-Makefile.in11
2 files changed, 12 insertions, 1 deletions
diff --git a/databases/qdbm-plus/Makefile b/databases/qdbm-plus/Makefile
index 057d5d821ecc..b9bd81b14bee 100644
--- a/databases/qdbm-plus/Makefile
+++ b/databases/qdbm-plus/Makefile
@@ -1,7 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 2
PKGNAMESUFFIX= -plus
COMMENT= C++ API for QDBM
diff --git a/databases/qdbm-plus/files/patch-Makefile.in b/databases/qdbm-plus/files/patch-Makefile.in
new file mode 100644
index 000000000000..17d294b238ff
--- /dev/null
+++ b/databases/qdbm-plus/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2007-03-07 02:44:50 UTC
++++ Makefile.in
+@@ -44,7 +44,7 @@ CPPFLAGS = @CPPFLAGS@ -I$(srcdir) -I$(sr
+ -D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
+ -D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
+ -DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
+-CXXFLAGS = -Wall -ansi -pedantic -fsigned-char -fPIC -O2 -fno-strict-aliasing @MYOPTS@
++CXXFLAGS = @CXXFLAGS@ -Wall -ansi -pedantic -fsigned-char -fPIC -fno-strict-aliasing
+ LD = @LD@
+ LIBS = -lqdbm @LIBS@
+ LIBLDFLAGS = @LDFLAGS@ -L. -L$(srcdir)/.. -L$(MYLIBDIR) \