aboutsummaryrefslogtreecommitdiff
path: root/databases/qt4-pgsql-plugin/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
commit7d5e6b666c579d543fbf4c0996e309e23de8e02e (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /databases/qt4-pgsql-plugin/Makefile
parentb60b2bc8f43a72af43a1f5ff0df9828880c2b7a8 (diff)
downloadports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.tar.gz
ports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.zip
In preparation for Qt 5 ports:
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
Notes
Notes: svn path=/head/; revision=338902
Diffstat (limited to 'databases/qt4-pgsql-plugin/Makefile')
-rw-r--r--databases/qt4-pgsql-plugin/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/qt4-pgsql-plugin/Makefile b/databases/qt4-pgsql-plugin/Makefile
index 978ad0ab7e06..4ef884867d5f 100644
--- a/databases/qt4-pgsql-plugin/Makefile
+++ b/databases/qt4-pgsql-plugin/Makefile
@@ -11,7 +11,6 @@ COMMENT= Qt PostgreSQL database plugin
DB= psql
USE_QT4= moc_build sql
-QT_NONSTANDARD= yes
QT_DIST= yes
USE_PGSQL= yes
@@ -22,12 +21,12 @@ EXTRACT_AFTER_ARGS?= ${DISTNAME}/${DRIVER} \
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" MOC="${MOC}" \
PLUGIN="${PLUGIN}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
QT_INCDIR="${QT_INCDIR}" \
QT_LIBDIR="${QT_LIBDIR}"
PLIST_SUB= DB=${DB}
+EXTRA_PATCHES= # empty
+
SQL_PLUGINDIR= ${PREFIX}/${QT_PLUGINDIR_REL}/sqldrivers
do-install: