aboutsummaryrefslogtreecommitdiff
path: root/databases/qt4-pgsql-plugin/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-07-13 00:04:21 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-07-13 00:04:21 +0000
commitee279d859feb6202deabda725cb8c0a4ec94f21f (patch)
treee2474571fc19a9826f4556e85411a5a38b27ca41 /databases/qt4-pgsql-plugin/Makefile
parent0c0668d340ea6e82704a5585b6095e7d01a19ee8 (diff)
downloadports-ee279d859feb6202deabda725cb8c0a4ec94f21f.tar.gz
ports-ee279d859feb6202deabda725cb8c0a4ec94f21f.zip
During regression testing the WIP Qt 4.3.0 ports, I found that the sql
driver plugins were all broken - even in the current ports! :( I am quite astonished nobody complained about this yet. Is there nobody developing applications with database backends using Qt4 on FreeBSD? The ports let you use the QtSql library and the database plugins without any X11 dependencies! Using Qt for database frontends has never been so attractive! Anyway, this should fix the plugins.
Notes
Notes: svn path=/head/; revision=195506
Diffstat (limited to 'databases/qt4-pgsql-plugin/Makefile')
-rw-r--r--databases/qt4-pgsql-plugin/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/databases/qt4-pgsql-plugin/Makefile b/databases/qt4-pgsql-plugin/Makefile
index 970ac6ed59fb..12b439eec11b 100644
--- a/databases/qt4-pgsql-plugin/Makefile
+++ b/databases/qt4-pgsql-plugin/Makefile
@@ -8,6 +8,7 @@
PORTNAME= qt4-${DB}-plugin
PORTVERSION= 4.2.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_QT}
DISTNAME= qt-x11-opensource-src-${PORTVERSION}
@@ -23,10 +24,12 @@ LIB_DEPENDS+= QtSql:${PORTSDIR}/databases/qt4-sql
USE_PGSQL= yes
#USE_BZIP2= yes
DRIVER= src/sql/drivers/${DB}
+PLUGIN= src/plugins/sqldrivers/${DB}
EXTRACT_AFTER_ARGS?=| ${TAR} -xf - \
- ${DISTNAME}/${DRIVER}
+ ${DISTNAME}/${DRIVER} ${DISTNAME}/${PLUGIN}
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" \
+ PLUGIN="${PLUGIN}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB= DB=${DB}