aboutsummaryrefslogtreecommitdiff
path: root/databases/redis-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2012-10-06 13:54:19 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2012-10-06 13:54:19 +0000
commitdc4070b05d80b7060e4c5703c2cf69fc7a2258ba (patch)
tree0ae92186c0cd2f251bfb984be7b63f6136f854d3 /databases/redis-devel/Makefile
parente86a71cbabd1399650b0aa1ad12cd3074653089b (diff)
downloadports-dc4070b05d80b7060e4c5703c2cf69fc7a2258ba.tar.gz
ports-dc4070b05d80b7060e4c5703c2cf69fc7a2258ba.zip
Update from 2.6.0rc7 to 2.6.0rc8.
Add TEST option for running unit tests. Add test and regression-test targets. Remove needless patch. New Makefile header convention. PR: 172396 <ChangeLog> * [BUGFIX] Fixed compilation on FreeBSD. * [IMPROVED] SRANDMEMBER <count> that returns multiple random elements. * [IMPROVED] Sentinel backported to 2.6. It will be taken in sync with 2.8. * [IMPROVED] Helper function for scripting to return errors and status replies. * [IMPROVED] SORT by nosort [ASC|DESC] uses sorted set elements ordering. * [BUGFIX] Better resistence to system clock skew. * [IMPROVED] Warn the user when the configured maxmemory seems odd. * [BUGFIX] Hashing function is now murmurhash2 for security purposes. * [IMPROVED] Install script no longer uses a template but redis.conf itself. </ChangeLog>
Notes
Notes: svn path=/head/; revision=305364
Diffstat (limited to 'databases/redis-devel/Makefile')
-rw-r--r--databases/redis-devel/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 950a29c469bc..84bc2ce855eb 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: redis
-# Date created: 03 Jul 2009
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= redis
-DISTVERSION= 2.6.0-rc7
+DISTVERSION= 2.6.0-rc8
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -devel
@@ -18,6 +14,15 @@ LICENSE= BSD
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install lang/tcl for redis unit tests
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTESTS}
+USE_TCL_BUILD= yes
+.endif
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lm -lexecinfo
@@ -64,4 +69,9 @@ post-install:
[ -d ${d} ] || ${MKDIR} ${d} && ${CHOWN} ${USERS}:${GROUPS} ${d}
.endfor
+test: build
+ @cd ${WRKSRC} && ${TCLSH} tests/test_helper.tcl
+
+regression-test: test
+
.include <bsd.port.mk>