aboutsummaryrefslogtreecommitdiff
path: root/databases/redis-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2014-10-10 21:18:00 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2014-10-10 21:18:00 +0000
commit0a3e78eb8c4c97a6dbe79a7c71d12ee51326f2e5 (patch)
tree49b7a54865a0d0f016347b5cdfe3bc8fb17de665 /databases/redis-devel
parent70852e384b48ae603e378e4feec98d2b9bdfd210 (diff)
downloadports-0a3e78eb8c4c97a6dbe79a7c71d12ee51326f2e5.tar.gz
ports-0a3e78eb8c4c97a6dbe79a7c71d12ee51326f2e5.zip
Upgrade from 3.0.0-beta8 to 3.0.0-rc1.
<ChangeLog> --[ Redis 3.0.0 RC1 (version 2.9.101) ] Release date: 9 oct 2014 This is the first release candidate of Redis Cluster. >> General changes * [FIX] An very large number of small fixes, old and new, merged in the context of a the issue #1906. Please see the issue page here for exact credits: https://github.com/antirez/redis/pull/1906 of each commit. (Matt Stancliff and many others). * [FIX] SAVE is no longer propagated to AOF / slaves. * [FIX] GETRANGE test no longer fails for 32 bit builds (Matt Stancliff). * [FIX] Limit SCAN latency when the hash table is in an odd state (very few populted buckets because rehashing is in progress). (Xiaost and Salvatore Sanfilippo) * [NEW] Redis is now able to load truncated AOF files without requiring a redis-check-aof utility run. The default now is to load truncated (but apparently not corrupted) AOFs, you can change this in redis.conf. (Salvatore Sanfilippo). * [NEW] DEBUG POPULATE two args form implemented. It is now possible to call it with DEBUG POPULATE <count> <prefix>. Default prefix is "key:" as usually. * [NEW] INCR: Modify incremented object in-place when possible. This results in speed improvements + possibly better memory locality. >> Cluster changes * [FIX] Cluster: claim ping_sent time even if we can't connect. * [FIX] redis-trib should not abort easily on connection issues. * [FIX] Cluster test: less console-spammy resharding test. * [FIX] Fix logic to detect we are among a minority. * [FIX] Process gossip section only for known nodes. * [NEW] Redis Cluster is stable and tested enough, there is a clear MVP, so it was promoted from beta to stable. * [NEW] New unit 09, Pub/Sub across the cluster. * [NEW] New unit 08, update messages. * [NEW] New cluster option to work with partial slots coverage. * [NEW] More chatty cluster slaves when failover is stalled. They log reason with rate limiting, only when reason changes or a given time has elapsed. >> Sentinel changes * [FIX] Sentinel critical bug fixed: the absolute majority was computed in a wrong way because of a programming error. Now the implementation does what the specification says and the majority to authorize a failover (that should not be confused with the ODOWN quorum) is the majority of *all* the Sentinels ever seen for a given master, regardless of their current state. * [FIX] Resolved a memory leak in the hiredis library causing a memory leak in Redis Sentinel when a monitored instance or another Sentinel is unavailable. Every reconnection attempt will leak a small amount of memory, but in the long run the process can reach a considerable size. * [NEW] Sentinel: ability to announce itself with an arbitrary IP/port to work in the context of natted networks. However this is probably still not enough since there is no equivalent mechanism for slaves listed in the master INFO output. (Dara Kong and Salvatore Sanfilippo) </ChangeLog>
Notes
Notes: svn path=/head/; revision=370602
Diffstat (limited to 'databases/redis-devel')
-rw-r--r--databases/redis-devel/Makefile2
-rw-r--r--databases/redis-devel/distinfo4
-rw-r--r--databases/redis-devel/files/patch-deps-Makefile15
-rw-r--r--databases/redis-devel/files/patch-src-Makefile36
4 files changed, 34 insertions, 23 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 0dbf96abe21f..126f41ab5448 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-DISTVERSION= 3.0.0-beta8
+DISTVERSION= 3.0.0-rc1
CATEGORIES= databases
MASTER_SITES= https://github.com/antirez/redis/archive/
PKGNAMESUFFIX= -devel
diff --git a/databases/redis-devel/distinfo b/databases/redis-devel/distinfo
index 326a7968e7c1..503ffd44308a 100644
--- a/databases/redis-devel/distinfo
+++ b/databases/redis-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis/3.0.0-beta8.tar.gz) = b84d1624873c4f20ed7504932233b2b91584b6a0c4383c25034e8710c5ea16cd
-SIZE (redis/3.0.0-beta8.tar.gz) = 1327483
+SHA256 (redis/3.0.0-rc1.tar.gz) = c64c31527d93175e2a83010d69e0b83dc86c8b75b7cf8aa8b497213921418db4
+SIZE (redis/3.0.0-rc1.tar.gz) = 1335857
diff --git a/databases/redis-devel/files/patch-deps-Makefile b/databases/redis-devel/files/patch-deps-Makefile
index 793a03c9bc61..35e9e8aa55b3 100644
--- a/databases/redis-devel/files/patch-deps-Makefile
+++ b/databases/redis-devel/files/patch-deps-Makefile
@@ -1,17 +1,20 @@
---- deps/Makefile.orig 2012-07-02 04:18:07.000000000 +0400
-+++ deps/Makefile 2012-07-02 04:18:56.000000000 +0400
-@@ -58,12 +58,12 @@
- LUA_CFLAGS= -D__C99FEATURES__=1
+--- deps/Makefile.orig 2014-10-11 01:02:23.000000000 +0400
++++ deps/Makefile 2014-10-11 01:03:37.000000000 +0400
+@@ -58,7 +58,7 @@
+ LUA_CFLAGS= -D__C99FEATURES__=1
endif
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
+LUA_CFLAGS+= -Wall -DLUA_ANSI $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
+ # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+ # challenging to cross-compile lua (and redis). These defines make it easier
+@@ -68,7 +68,7 @@
lua: .make-prerequisites
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
-- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
-+ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
+- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
++ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
.PHONY: lua
diff --git a/databases/redis-devel/files/patch-src-Makefile b/databases/redis-devel/files/patch-src-Makefile
index 8846533cdd23..fd370cbcddd5 100644
--- a/databases/redis-devel/files/patch-src-Makefile
+++ b/databases/redis-devel/files/patch-src-Makefile
@@ -1,7 +1,7 @@
---- src/Makefile.orig 2014-01-14 14:17:43.000000000 +0400
-+++ src/Makefile 2014-01-14 14:19:31.000000000 +0400
+--- src/Makefile.orig 2014-10-11 01:09:55.000000000 +0400
++++ src/Makefile 2014-10-11 01:12:53.000000000 +0400
@@ -22,7 +22,7 @@
- WARN=-Wall
+ WARN=-Wall -W
OPT=$(OPTIMIZATION)
-PREFIX?=/usr/local
@@ -9,23 +9,31 @@
INSTALL_BIN=$(PREFIX)/bin
INSTALL=install
-@@ -52,7 +52,7 @@
+@@ -52,7 +52,6 @@
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
-DEBUG=-g -ggdb
-+#DEBUG=-g -ggdb
ifeq ($(uname_S),SunOS)
# SunOS
-@@ -63,6 +63,7 @@
--ifeq ($(uname_S),Darwin)
-- # Darwin (nothing to do)
--else
+@@ -63,6 +62,11 @@
+ ifeq ($(uname_S),Darwin)
+ # Darwin (nothing to do)
+ else
+ifeq ($(uname_S),FreeBSD)
-+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
-+ FINAL_LDFLAGS= $(LDFLAGS)
++ # FreeBSD
++ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
++ FINAL_LDFLAGS= $(LDFLAGS)
+else
- # All the other OSes (notably Linux)
- FINAL_LDFLAGS+= -rdynamic
- FINAL_LIBS+= -pthread
+ ifeq ($(uname_S),AIX)
+ # AIX
+ FINAL_LDFLAGS+= -Wl,-bexpall
+@@ -75,6 +79,7 @@
+ endif
+ endif
+ endif
++endif
+ # Include paths to dependencies
+ FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
+