aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-postgres/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-12 20:09:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-12 20:09:41 +0000
commit596ebf8a494ccec324a561d381d1c60d5f35cf02 (patch)
tree740528554f6f5efe5651a2e1c0f603dcf8fb5474 /databases/ruby-postgres/Makefile
parentfa205cf0127276fbc75367f39be16135d70b5d9e (diff)
downloadports-596ebf8a494ccec324a561d381d1c60d5f35cf02.tar.gz
ports-596ebf8a494ccec324a561d381d1c60d5f35cf02.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Notes
Notes: svn path=/head/; revision=31584
Diffstat (limited to 'databases/ruby-postgres/Makefile')
-rw-r--r--databases/ruby-postgres/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/databases/ruby-postgres/Makefile b/databases/ruby-postgres/Makefile
index 1901405a3808..5c9548e373fb 100644
--- a/databases/ruby-postgres/Makefile
+++ b/databases/ruby-postgres/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: ruby-postgres
-# Date created: 19 April 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+# New ports collection makefile for: ruby-postgres
+# Date created: 19 April 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
@@ -23,9 +23,9 @@ CONFIGURE_ARGS+= --with-pgsql-include-dir="${PGDIR}/include" \
--with-pgsql-lib-dir="${PGDIR}/lib"
PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${PREFIX}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${PREFIX}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
PGDIR?= ${PREFIX}/pgsql
@@ -36,9 +36,9 @@ do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/ruby/postgres
${INSTALL_DATA} ${WRKSRC}/sample/* ${PREFIX}/share/examples/ruby/postgres/
-.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ruby/postgres/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/postgres/