aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-postgres/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-09 19:43:48 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-09 19:43:48 +0000
commit9ab920338903b6eec34abdfb09a081ffe7ca421a (patch)
treea83ff7b459463cf85ac72a047f53991dbbace50c /databases/ruby-postgres/Makefile
parent05a03e7d8c95bae8959cf9037e040afa81b3cc52 (diff)
downloadports-9ab920338903b6eec34abdfb09a081ffe7ca421a.tar.gz
ports-9ab920338903b6eec34abdfb09a081ffe7ca421a.zip
Update to 0.6.1.
Depend on Postgresql7. (Though it works with either 6.4/6.5 or 7.0) Take over the maintainership. At the request of: yasuf@big.or.jp (the previous MAINTAINER)
Notes
Notes: svn path=/head/; revision=31459
Diffstat (limited to 'databases/ruby-postgres/Makefile')
-rw-r--r--databases/ruby-postgres/Makefile33
1 files changed, 18 insertions, 15 deletions
diff --git a/databases/ruby-postgres/Makefile b/databases/ruby-postgres/Makefile
index 85f6ff2ed696..1901405a3808 100644
--- a/databases/ruby-postgres/Makefile
+++ b/databases/ruby-postgres/Makefile
@@ -5,25 +5,20 @@
# $FreeBSD$
#
-PORTNAME= ruby-postgres
-PORTVERSION= 0.5.3
+PORTNAME= postgres
+PORTVERSION= 0.6.1
CATEGORIES= databases
-MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/contrib/ \
- ftp://ftp.TokyoNet.AD.JP/pub/misc/ruby/contrib/ \
- ftp://ftp.iij.ad.jp/pub/lang/ruby/contrib/ \
- ftp://blade.nagaokaut.ac.jp/pub/lang/ruby/contrib/ \
- ftp://ftp.krnet.ne.jp/pub/ruby/contrib/ \
- ftp://mirror.nucba.ac.jp/mirror/ruby/contrib/
-DISTNAME= postgres-${PORTVERSION}
+MASTER_SITES= http://webclub.kcom.ne.jp/mb/noborus/archive/
+PKGNAMEPREFIX= ruby-
DIST_SUBDIR= ruby
-MAINTAINER= yasuf@big.or.jp
+MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-WRKSRC= ${WRKDIR}/postgres
+WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS+= --with-pgsql-include-dir="${PGDIR}/include" \
--with-pgsql-lib-dir="${PGDIR}/lib"
PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
@@ -34,15 +29,23 @@ RUBY_ARCH= ${ARCH}-freebsd${OSREL}
PGDIR?= ${PREFIX}/pgsql
+DOCS_EN= ChangeLog README doc/postgres.html
+DOCS_JA= README.jp doc/postgres.jp.html
+
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
post-install:
${MKDIR} ${PREFIX}/share/examples/ruby/postgres
- ${INSTALL_DATA} ${WRKSRC}/psql*.rb ${PREFIX}/share/examples/ruby/postgres
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${PREFIX}/share/examples/ruby/postgres/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ruby/postgres
- ${INSTALL_DATA} ${WRKSRC}/README* ${WRKSRC}/*.html ${PREFIX}/share/doc/ruby/postgres
+ ${MKDIR} ${PREFIX}/share/doc/ruby/postgres/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/postgres/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/postgres/ja/
+.endfor
.endif
.include <bsd.port.mk>