aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-puppetdb_cli/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2019-05-15 06:29:37 +0000
committerRomain Tartière <romain@FreeBSD.org>2019-05-15 06:29:37 +0000
commit91abad5b313776c9545b9350aac9103c88217205 (patch)
tree7512876de6043e60fa5de0641dd23fdd59ed1050 /databases/rubygem-puppetdb_cli/Makefile
parent12bdf17d39b9b2a41996a76b8d52ffafc368d46f (diff)
downloadports-91abad5b313776c9545b9350aac9103c88217205.tar.gz
ports-91abad5b313776c9545b9350aac9103c88217205.zip
Update to 2.0.0
puppetdb-cli was rewritten in Ruby, so the port was moved from databases/puppetdb-cli to databases/rubygem-puppetdb_cli. With hat: puppet
Notes
Notes: svn path=/head/; revision=501688
Diffstat (limited to 'databases/rubygem-puppetdb_cli/Makefile')
-rw-r--r--databases/rubygem-puppetdb_cli/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/databases/rubygem-puppetdb_cli/Makefile b/databases/rubygem-puppetdb_cli/Makefile
new file mode 100644
index 000000000000..8a4a32ee0a8d
--- /dev/null
+++ b/databases/rubygem-puppetdb_cli/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= puppetdb_cli
+PORTVERSION= 2.0.0
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= puppet@FreeBSD.org
+COMMENT= PuppetDB CLI Tooling
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-cri>0:devel/rubygem-cri \
+ rubygem-pl-puppetdb-ruby>0:databases/rubygem-pl-puppetdb-ruby
+
+USES= gem
+USE_RUBY= yes
+
+PLIST_FILES= bin/puppet-db \
+ bin/puppet-query
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/etc/puppetlabs|/usr/local/etc|' \
+ ${WRKSRC}/man/puppetdb_conf.pod
+
+.include <bsd.port.mk>