aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-redis-namespace/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-07-30 03:10:03 +0000
committerSteve Wills <swills@FreeBSD.org>2013-07-30 03:10:03 +0000
commitfc5988ba4127deebfdc2f7970f6e3991329b50e6 (patch)
tree714ca87e9c9ebc5f09dcce80a972e23a4fbc796c /databases/rubygem-redis-namespace/Makefile
parent908720b49862b3ae9709d7840232f2a9eeebe013 (diff)
downloadports-fc5988ba4127deebfdc2f7970f6e3991329b50e6.tar.gz
ports-fc5988ba4127deebfdc2f7970f6e3991329b50e6.zip
Adds a Redis::Namespace class which can be used to namespace calls to Redis.
This is useful when using a single instance of Redis with multiple, different applications. WWW: http://github.com/resque/redis-namespace
Notes
Notes: svn path=/head/; revision=323936
Diffstat (limited to 'databases/rubygem-redis-namespace/Makefile')
-rw-r--r--databases/rubygem-redis-namespace/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/databases/rubygem-redis-namespace/Makefile b/databases/rubygem-redis-namespace/Makefile
new file mode 100644
index 000000000000..dd9a778326a7
--- /dev/null
+++ b/databases/rubygem-redis-namespace/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= redis-namespace
+PORTVERSION= 1.3.0
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby client class for Redis with namespace support
+
+RUN_DEPENDS= rubygem-redis>=3.0.0:${PORTSDIR}/databases/rubygem-redis
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>