aboutsummaryrefslogtreecommitdiff
path: root/databases/skytools
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
commit67971bd0fb8a440f973d12606b0f496ba216d7df (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /databases/skytools
parentf13c234d6c664c916b5c0d0e6f089d8ef0c93d55 (diff)
downloadports-67971bd0fb8a440f973d12606b0f496ba216d7df.tar.gz
ports-67971bd0fb8a440f973d12606b0f496ba216d7df.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Notes
Notes: svn path=/head/; revision=399684
Diffstat (limited to 'databases/skytools')
-rw-r--r--databases/skytools/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/databases/skytools/Makefile b/databases/skytools/Makefile
index 29b8c08b4e6f..7c16c09f0140 100644
--- a/databases/skytools/Makefile
+++ b/databases/skytools/Makefile
@@ -12,8 +12,6 @@ COMMENT= PostgreSQL tools from Skype: walshipping, queueing, replication
GNU_CONFIGURE= yes
USES= gmake python:2 shebangfix pgsql
-python_OLD_CMD= /usr/bin/env python
-python_CMD= /usr/bin/env python2
SHEBANG_FILES= setup_pkgloader.py setup_skytools.py \
scripts/catsql.py scripts/data_maintainer.py \
scripts/find_sql_functions.py scripts/grantfu.py \