aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitebrowser/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /databases/sqlitebrowser/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'databases/sqlitebrowser/Makefile')
-rw-r--r--databases/sqlitebrowser/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index d6d997d08f54..99ac5cd28f98 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -17,9 +17,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libantlr.a:devel/antlr
LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
-USES= cmake desktop-file-utils sqlite
+USES= cmake desktop-file-utils qt:5 sqlite
CMAKE_ARGS+= -DQT_INCLUDE_DIR=${QT_INCDIR} -DQT_LIBRARY_DIR=${QT_LIBDIR}
-USE_QT5= core gui network printsupport testlib widgets \
+USE_QT= core gui network printsupport testlib widgets \
buildtools_build linguisttools_build qmake_build
USE_GITHUB= yes