aboutsummaryrefslogtreecommitdiff
path: root/databases/timescaledb/Makefile
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-11-23 10:20:30 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-11-23 10:20:30 +0000
commitdcc5b27c9d78bac695e7e6009b32b7815770e44d (patch)
tree9a83b6ecf745cf6017b61717213f79680d29908d /databases/timescaledb/Makefile
parent0de3152ad63cda4daff816770eaa75e4d5962d33 (diff)
downloadports-dcc5b27c9d78bac695e7e6009b32b7815770e44d.tar.gz
ports-dcc5b27c9d78bac695e7e6009b32b7815770e44d.zip
databases/timescaledb: Update to 0.7.0
changelog: https://github.com/timescale/timescaledb/releases/tag/0.7.0 Moreover, switches build to CMake and adds support for pgsql10 PR: 223800 Submitted by: kbowling@freebsd.org (maintainer) Approved by: olivier (mentor) Differential Revision: https://reviews.freebsd.org/D13191
Notes
Notes: svn path=/head/; revision=454751
Diffstat (limited to 'databases/timescaledb/Makefile')
-rw-r--r--databases/timescaledb/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/databases/timescaledb/Makefile b/databases/timescaledb/Makefile
index 8ff95ccf99ca..18a3c1149754 100644
--- a/databases/timescaledb/Makefile
+++ b/databases/timescaledb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= timescaledb
-PORTVERSION= 0.6.0
+PORTVERSION= 0.7.0
CATEGORIES= databases
MAINTAINER= kbowling@FreeBSD.org
@@ -11,17 +11,17 @@ COMMENT= Time-series database built on PostgreSQL
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c11 gmake pgsql:9.6
+USES= compiler:c11 cmake:outsource pgsql:9.6,10
USE_LDCONFIG= yes
USE_GITHUB= YES
GH_ACCOUNT= timescale
-MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 \
- install_bin=/usr/bin/install
-
WANT_PGSQL= server
+SUB_LIST+= PORTVERSION=${PORTVERSION}
+SUB_FILES= pkg-message
+
PLIST_FILES= lib/postgresql/timescaledb.so \
share/postgresql/extension/timescaledb--0.1.0--0.2.0.sql \
share/postgresql/extension/timescaledb--0.2.0--0.3.0.sql \
@@ -30,7 +30,9 @@ PLIST_FILES= lib/postgresql/timescaledb.so \
share/postgresql/extension/timescaledb--0.4.1--0.4.2.sql \
share/postgresql/extension/timescaledb--0.4.2--0.5.0.sql \
share/postgresql/extension/timescaledb--0.5.0--0.6.0.sql \
- share/postgresql/extension/timescaledb--0.6.0.sql \
+ share/postgresql/extension/timescaledb--0.6.0--0.6.1.sql \
+ share/postgresql/extension/timescaledb--0.6.1--0.7.0.sql \
+ share/postgresql/extension/timescaledb--0.7.0.sql \
share/postgresql/extension/timescaledb.control
post-install: