aboutsummaryrefslogtreecommitdiff
path: root/databases/typhoon
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-20 01:30:07 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-20 01:30:07 +0000
commit4cb6da685701d5cf6c7e7a57b125130ce248d6c2 (patch)
treeff1011ef4667d343286c21f3a4a20221a635fadd /databases/typhoon
parente4afaccacb32978e984a0ba8f4d68616e0d9d404 (diff)
downloadports-4cb6da685701d5cf6c7e7a57b125130ce248d6c2.tar.gz
ports-4cb6da685701d5cf6c7e7a57b125130ce248d6c2.zip
Convert to ELF and make reinstall friendly.
Notes
Notes: svn path=/head/; revision=14099
Diffstat (limited to 'databases/typhoon')
-rw-r--r--databases/typhoon/Makefile6
-rw-r--r--databases/typhoon/files/patch-ac8
-rw-r--r--databases/typhoon/pkg-plist8
3 files changed, 14 insertions, 8 deletions
diff --git a/databases/typhoon/Makefile b/databases/typhoon/Makefile
index 9b5f1e5283a5..ae8a6b998eab 100644
--- a/databases/typhoon/Makefile
+++ b/databases/typhoon/Makefile
@@ -3,7 +3,7 @@
# Date created: Wed Dec 11 15:16:19 CST 1996
# Whom: erich@FreeBSD.org
#
-# $Id: Makefile,v 1.2 1996/12/12 05:18:10 asami Exp $
+# $Id: Makefile,v 1.3 1998/01/31 16:59:53 jseger Exp $
#
DISTNAME= typhoon-1.10.3
@@ -26,5 +26,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/typhoon
@${INSTALL_DATA} ${WRKSRC}/man/manual.asc ${PREFIX}/share/typhoon
@${INSTALL_DATA} ${WRKSRC}/include/environ.h ${WRKSRC}/include/typhoon.h ${PREFIX}/include
+ @if [ $PORTOBJFORMAT = "elf" ]; then \
+ @{LN} -sf libtyphoon.so.1.10 ${PREFIX}/lib/libtyphoon.so; \
+ fi
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/databases/typhoon/files/patch-ac b/databases/typhoon/files/patch-ac
index c2d8b3c929fa..cb677b06108c 100644
--- a/databases/typhoon/files/patch-ac
+++ b/databases/typhoon/files/patch-ac
@@ -9,8 +9,8 @@
lint:
lint -u $(DEFINES) $(SRCS)
---- util/Makefile.in~ Wed Dec 11 16:10:14 1996
-+++ util/Makefile.in Wed Dec 11 16:14:42 1996
+--- util/Makefile.in~ Sun May 21 11:47:41 1995
++++ util/Makefile.in Thu Oct 15 17:09:03 1998
@@ -8,11 +8,10 @@
CC = @cc@
CFLAGS = @cflags@
@@ -25,7 +25,7 @@
SHELL = /bin/sh
PROGRAMS = ddlp dbdview tyexport tyimport # tybackup tyrestore
MADESRCS = ddl.c exp.c imp.c
-@@ -74,11 +74,11 @@
+@@ -74,11 +73,11 @@
install: $(PROGRAMS)
cp $(PROGRAMS) $(DESTBIN)
@@ -34,7 +34,7 @@
cd $(DESTBIN) && chmod 755 $(PROGRAMS)
cd $(DESTBIN) && chown $(DESTOWN) $(PROGRAMS)
cd $(DESTBIN) && chgrp $(DESTGRP) $(PROGRAMS)
-+ install -m 644 ../man/ddlp.1 ${PREFIX}/man/man1
++ install -c -m 644 ../man/ddlp.1 ${PREFIX}/man/man1
uninstall:
cd $(DESTBIN) && rm -f $(PROGRAMS)
diff --git a/databases/typhoon/pkg-plist b/databases/typhoon/pkg-plist
index 12eb279e1c41..7fadbfdb269a 100644
--- a/databases/typhoon/pkg-plist
+++ b/databases/typhoon/pkg-plist
@@ -2,10 +2,12 @@ bin/tyexport
bin/tyimport
bin/ddlp
bin/dbdview
-lib/libtyphoon.a
-lib/libtyphoon.so.1.10
-lib/libtyphoon_p.a
include/environ.h
include/typhoon.h
+lib/libtyphoon.a
+lib/libtyphoon.so
+lib/libtyphoon.so.1.10
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/typhoon/manual.asc
@dirrm share/typhoon