aboutsummaryrefslogtreecommitdiff
path: root/databases/virtualpg/Makefile
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-09-11 16:09:59 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-09-11 16:09:59 +0000
commit82ccf1292ff9312e33a47dc6389345cb6b7cacd3 (patch)
tree77c4fd705934c956b5de575dc64487d804c413b0 /databases/virtualpg/Makefile
parentf0571dfeb4f2a75b67f5fb452bbfb493c0709cb7 (diff)
downloadports-82ccf1292ff9312e33a47dc6389345cb6b7cacd3.tar.gz
ports-82ccf1292ff9312e33a47dc6389345cb6b7cacd3.zip
databases/virtualpg: Update to 2.0.0
- Add pkg-plist - Update description Short summary of differences between earlier versions and v2: - Now VirtualPG is available as both a standard C/C++ library (libvirtualpg) and a dynamic extension module to SQLite (mod_virtualpg). - Now the user can freely choose his/her preferred format for DATE / TIME / TIMESTAMP values. - Transactions (BEGIN / COMMIT / ROLLBACK) are now fully honoured also on the PostgreSQL side. - Write operations (INSER / UPDATE / DELETE) are now allowed only if the PostgreSQL user has the corresponding GRANT permissions. - Write operations can be enabled only for PostgreSQL Tables explicitly declaring a PRIMARY KEY.
Notes
Notes: svn path=/head/; revision=548251
Diffstat (limited to 'databases/virtualpg/Makefile')
-rw-r--r--databases/virtualpg/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/databases/virtualpg/Makefile b/databases/virtualpg/Makefile
index 3a1216ab56bc..e52daaee9f00 100644
--- a/databases/virtualpg/Makefile
+++ b/databases/virtualpg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= virtualpg
-PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTVERSION= 2.0.0
CATEGORIES= databases geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
@@ -22,8 +21,8 @@ CFLAGS+= -I${WRKSRC}/src/headers -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-PLIST_FILES= lib/mod_virtualpg.so \
- lib/mod_virtualpg.so.1 \
- lib/mod_virtualpg.so.1.0.0
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvirtualpg.so.0.1.1
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mod_virtualpg.so.0.1.1
.include <bsd.port.mk>