aboutsummaryrefslogtreecommitdiff
path: root/databases/xtrabackup8
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 21:26:32 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 22:16:15 +0000
commit679ae95ffdf009bdcc72e2ba5b4379cf64ccee00 (patch)
treef7bfbad94c2db21a65baf522683ee0e4daaa90f4 /databases/xtrabackup8
parent1cd945e15277f1b441f18187cf5236b60caaa9a6 (diff)
downloadports-679ae95ffdf009bdcc72e2ba5b4379cf64ccee00.tar.gz
ports-679ae95ffdf009bdcc72e2ba5b4379cf64ccee00.zip
databases/xtrabackup8: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'databases/xtrabackup8')
-rw-r--r--databases/xtrabackup8/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/xtrabackup8/Makefile b/databases/xtrabackup8/Makefile
index c1e9cb5810ca..33bf8139cc6e 100644
--- a/databases/xtrabackup8/Makefile
+++ b/databases/xtrabackup8/Makefile
@@ -68,6 +68,12 @@ CXXFLAGS+= -malign-double
KEEP_EXTRA= lz4 robin-hood-hashing zlib
+post-patch:
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+ @${REINPLACE_CMD} -e 's|std::unary_function|std::__unary_function|' \
+ ${WRKSRC}/../boost_1_77_0/boost/container_hash/hash.hpp
+.endif
+
pre-configure:
.for dir in ${KEEP_EXTRA}
@${MV} ${WRKSRC}/extra/${dir} ${WRKDIR}