aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-23 22:19:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-23 22:19:26 +0000
commit00fac2543edcd3e3876e2f26036c8392acccfe3e (patch)
treefd4f1716904d47c64c0f529f6ec568f2a01088a3 /databases
parent116284ba956af8f224199a18960be75aca9fd5d1 (diff)
downloadports-00fac2543edcd3e3876e2f26036c8392acccfe3e.tar.gz
ports-00fac2543edcd3e3876e2f26036c8392acccfe3e.zip
mysqlreport makes a friendly report of important MySQL status values.
mysqlreport transforms the values from SHOW STATUS into an easy-to-read report that provides a much more in-depth understanding of how well MySQL is running. For this and many other reasons, mysqlreport is a better alternative (and practically the only alternative) to manually interpreting SHOW STATUS. WWW: http://hackmysql.com/mysqlreport PR: ports/105787 Submitted by: Alexander Zhuravlev <zaa at zaa.pp.ru>
Notes
Notes: svn path=/head/; revision=177932
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mysqlreport/Makefile37
-rw-r--r--databases/mysqlreport/distinfo3
-rw-r--r--databases/mysqlreport/files/patch-mysqlreport11
-rw-r--r--databases/mysqlreport/pkg-descr8
5 files changed, 60 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e2d2521c004f..53d9a09cb097 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -156,6 +156,7 @@
SUBDIR += mysqlcc
SUBDIR += mysqlcppapi
SUBDIR += mysqlman
+ SUBDIR += mysqlreport
SUBDIR += mysqltcl
SUBDIR += mytop
SUBDIR += namazu2
diff --git a/databases/mysqlreport/Makefile b/databases/mysqlreport/Makefile
new file mode 100644
index 000000000000..0ec00a11e160
--- /dev/null
+++ b/databases/mysqlreport/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mysqlreport
+# Date created: 2006-11-23
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+
+PORTNAME= mysqlreport
+PORTVERSION= 2.7a
+CATEGORIES= databases
+MASTER_SITES= http://hackmysql.com/scripts/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= Mysqlreport makes a friendly report of important MySQL status values
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+
+USE_PERL5= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/mysqlreport
+PORTDOCS= mysqlreportguide.html mysqlreportdoc.html
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/mysqlreport ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/mysqlreport/distinfo b/databases/mysqlreport/distinfo
new file mode 100644
index 000000000000..bdf3e689aa1d
--- /dev/null
+++ b/databases/mysqlreport/distinfo
@@ -0,0 +1,3 @@
+MD5 (mysqlreport-2.7a.tgz) = a1af9e32372cff388b1fe59f595df121
+SHA256 (mysqlreport-2.7a.tgz) = fb77406fa5ce13935e69591c71cda1a539d0959f611796f472e41360586b2cf4
+SIZE (mysqlreport-2.7a.tgz) = 20785
diff --git a/databases/mysqlreport/files/patch-mysqlreport b/databases/mysqlreport/files/patch-mysqlreport
new file mode 100644
index 000000000000..772c57ba72ae
--- /dev/null
+++ b/databases/mysqlreport/files/patch-mysqlreport
@@ -0,0 +1,11 @@
+--- mysqlreport.orig Thu Nov 23 17:56:12 2006
++++ mysqlreport Thu Nov 23 18:03:54 2006
+@@ -76,7 +76,7 @@ $mycnf{'user'} = $op{'user'} if have
+ # Default values if nothing else
+ $mycnf{'host'} ||= 'localhost';
+ $mycnf{'port'} ||= 3306;
+-$mycnf{'socket'} ||= '/var/run/mysqld/mysqld.sock'; # Debian default
++$mycnf{'socket'} ||= '/tmp/mysql.sock';
+ $mycnf{'user'} ||= $ENV{'USER'};
+
+ if(exists $op{'password'})
diff --git a/databases/mysqlreport/pkg-descr b/databases/mysqlreport/pkg-descr
new file mode 100644
index 000000000000..95fe30d921e0
--- /dev/null
+++ b/databases/mysqlreport/pkg-descr
@@ -0,0 +1,8 @@
+mysqlreport makes a friendly report of important MySQL status values.
+mysqlreport transforms the values from SHOW STATUS into an easy-to-read
+report that provides a much more in-depth understanding of how well
+MySQL is running. For this and many other reasons, mysqlreport is
+a better alternative (and practically the only alternative) to
+manually interpreting SHOW STATUS.
+
+WWW: http://hackmysql.com/mysqlreport