aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 13:48:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 13:48:25 +0000
commit1604951b3093e548a7245a9a4de33403f76ba72f (patch)
treec4e49df9c764236863400586b044b0f0825c53ed /databases
parentf9091fd2dae6e339dde03346a01e24036dd344f1 (diff)
downloadports-1604951b3093e548a7245a9a4de33403f76ba72f.tar.gz
ports-1604951b3093e548a7245a9a4de33403f76ba72f.zip
Convert to USES=pgsql
While here: databases/pg_reorg - stagify databases/iplike - convert to USES=libtool - strip binarie databases/ip4r - strip binaries databases/postgresql-libpgeasy - convert to USES=libtool - strip binaries - stagify databases/postgresql-libpqxx - convert to USES=libtool - strip binaries databases/postgresql-libpqxx3 - convert to USES=libtool - strip binaries
Notes
Notes: svn path=/head/; revision=353002
Diffstat (limited to 'databases')
-rw-r--r--databases/ip4r/Makefile15
-rw-r--r--databases/iplike/Makefile8
-rw-r--r--databases/pg_reorg/Makefile36
-rw-r--r--databases/postgresql-libpgeasy/Makefile20
-rw-r--r--databases/postgresql-libpgeasy/pkg-plist2
-rw-r--r--databases/postgresql-libpqxx/Makefile13
-rw-r--r--databases/postgresql-libpqxx/pkg-plist2
-rw-r--r--databases/postgresql-libpqxx3/Makefile5
-rw-r--r--databases/postgresql-libpqxx3/pkg-plist1
9 files changed, 39 insertions, 63 deletions
diff --git a/databases/ip4r/Makefile b/databases/ip4r/Makefile
index 7b0cfba56acb..464cc448b146 100644
--- a/databases/ip4r/Makefile
+++ b/databases/ip4r/Makefile
@@ -9,21 +9,20 @@ MASTER_SITES= http://pgfoundry.org/frs/download.php/3380/
MAINTAINER= tobez@FreeBSD.org
COMMENT= IP address and IP range index types for PostgreSQL
-USE_PGSQL= YES
-USE_GMAKE= YES
+USES= gmake pgsql
MAKE_ARGS= USE_PGXS=1
# In order to make this port PREFIX-safe, we override the install target
# and install the three files manually
-NO_STAGE= yes
do-install:
- @${INSTALL} -m ${BINMODE} ${WRKSRC}/ip4r.so ${PREFIX}/lib/postgresql
- @${MKDIR} ${PREFIX}/share/postgresql/contrib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/postgresql
+ @${INSTALL_LIB} -m ${BINMODE} ${WRKSRC}/ip4r.so ${STAGEDIR}${PREFIX}/lib/postgresql
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/contrib
@${INSTALL_DATA} ${WRKSRC}/ip4r.sql \
- ${PREFIX}/share/postgresql/contrib
- @${MKDIR} ${PREFIX}/share/doc/postgresql/contrib
+ ${STAGEDIR}${PREFIX}/share/postgresql/contrib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/postgresql/contrib
@${INSTALL_DATA} ${WRKSRC}/README.ip4r \
- ${PREFIX}/share/doc/postgresql/contrib
+ ${STAGEDIR}${PREFIX}/share/doc/postgresql/contrib
.include <bsd.port.mk>
diff --git a/databases/iplike/Makefile b/databases/iplike/Makefile
index 5f52401f16f9..580fbe55c343 100644
--- a/databases/iplike/Makefile
+++ b/databases/iplike/Makefile
@@ -9,13 +9,13 @@ MASTER_SITES= SF/opennms/IPLIKE/stable-2.0/
MAINTAINER= venture37@geeklan.co.uk
COMMENT= C implementation of the OpenNMS iplike stored procedure
+USES= libtool pgsql
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_PGSQL= yes
SUB_FILES= pkg-message
+INSTALL_TARGET= install-strip
-PLIST_FILES= lib/postgresql/iplike.la \
- lib/postgresql/iplike.so \
- sbin/install_iplike.sh
+PLIST_FILES= lib/postgresql/iplike.so \
+ sbin/install_iplike.sh
.include <bsd.port.mk>
diff --git a/databases/pg_reorg/Makefile b/databases/pg_reorg/Makefile
index 2aa6093e827f..84fee8b62fa6 100644
--- a/databases/pg_reorg/Makefile
+++ b/databases/pg_reorg/Makefile
@@ -11,33 +11,21 @@ COMMENT= PostgreSQL utility to reorganize tables
LICENSE= BSD
-DESTINY= ${WRKDIR}/destino
-MAKE_ENV= USE_PGXS=0 \
- DESTDIR=${DESTINY}
-USES= gmake
-USE_PGSQL= yes
+MAKE_ENV= USE_PGXS=0
+USES= gmake pgsql
-OPTIONS_DEFINE= DOCS
+PLIST_FILES= bin/pg_reorg \
+ lib/postgresql/pg_reorg.so \
+ share/postgresql/contrib/pg_reorg--1.1.8.sql \
+ share/postgresql/contrib/pg_reorg.sql \
+ share/postgresql/contrib/uninstall_pg_reorg.sql
+PLIST_DIRSTRY= share/postgresql/contrib
+PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DESTINY}${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DESTINY}${DOCSDIR}/)
-.endif
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
- @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${WRKDIR}/PLIST.all
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
- ${SED} -e '/lib\/postgresql$$/d' -e '/share\/doc$$/d' \
- -e '/share\/postgresql$$/d' -e '/share\/postgresql\/extension$$/d' \
- -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/lib/postgresql 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/postgresql/extension 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/postgresql 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/)
.include <bsd.port.mk>
diff --git a/databases/postgresql-libpgeasy/Makefile b/databases/postgresql-libpgeasy/Makefile
index 966125137b91..733753916455 100644
--- a/databases/postgresql-libpgeasy/Makefile
+++ b/databases/postgresql-libpgeasy/Makefile
@@ -11,23 +11,21 @@ MASTER_SITE_SUBDIR= projects/gborg/pgeasy/stable
DIST_SUBDIR= postgresql
MAINTAINER= pgsql@FreeBSD.org
-COMMENT= An easy-to-use C interface to PostgreSQL
+COMMENT= Easy-to-use C interface to PostgreSQL
-USE_AUTOTOOLS= libtool
-USE_PGSQL= YES
-USES= gmake
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USES= gmake libtool pgsql
USE_LDCONFIG= YES
GNU_CONFIGURE= YES
DOCSDIR= ${PREFIX}/share/doc/postgresql/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/postgresql/${PORTNAME}
+INSTALL_TARGET= install-strip
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @- ${MKDIR} -m 755 ${EXAMPLESDIR} ;\
- ${INSTALL} ${WRKSRC}/examples/* ${EXAMPLESDIR} ;\
- ${MKDIR} -m 755 ${DOCSDIR} ;\
- ${INSTALL} ${WRKSRC}/docs/libpgeasy.html ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/libpgeasy.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/databases/postgresql-libpgeasy/pkg-plist b/databases/postgresql-libpgeasy/pkg-plist
index 811df7aa9ce2..36e5d22e6bf0 100644
--- a/databases/postgresql-libpgeasy/pkg-plist
+++ b/databases/postgresql-libpgeasy/pkg-plist
@@ -1,8 +1,8 @@
include/libpgeasy.h
lib/libpgeasy.a
-lib/libpgeasy.la
lib/libpgeasy.so
lib/libpgeasy.so.3
+lib/libpgeasy.so.3.0.0
%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
%%PORTDOCS%%%%EXAMPLESDIR%%/pginsert.c
%%PORTDOCS%%%%EXAMPLESDIR%%/pgmultiresult.c
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 7168d1447ff5..1842fd53e8e3 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libpqxx
PORTVERSION= 4.0.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://pqxx.org/download/software/libpqxx/
PKGNAMEPREFIX= postgresql-
@@ -16,23 +17,15 @@ LICENSE= BSD3CLAUSE
CONFLICTS= postgresql-libpqxx-3.* postgresql-libpqxx3-3.*
PORTSCOUT= limit:^2\.
-USE_PGSQL= yes
USE_PYTHON_BUILD= yes
-USES= gmake shebangfix
+USES= gmake libtool pgsql shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-SOVERSION= 4
-PLIST_SUB= PORTVERSION=${PORTVERSION:R} \
- SOVERSION=${SOVERSION}
+PLIST_SUB= PORTVERSION=${PORTVERSION:R}
SHEBANG_FILES= ${WRKSRC}/tools/splitconfig
python_CMD= ${PYTHON_CMD}
CONFIGURE_ARGS= --enable-shared \
--disable-dependency-tracking
-post-install:
-# This is needed for ldconfig
- ${LN} -sf libpqxx-${PORTVERSION}.so \
- ${STAGEDIR}${PREFIX}/lib/libpqxx.so.${SOVERSION}
-
.include <bsd.port.mk>
diff --git a/databases/postgresql-libpqxx/pkg-plist b/databases/postgresql-libpqxx/pkg-plist
index 0528d2f8572e..c3484fb00948 100644
--- a/databases/postgresql-libpqxx/pkg-plist
+++ b/databases/postgresql-libpqxx/pkg-plist
@@ -93,9 +93,7 @@ include/pqxx/version
include/pqxx/version.hxx
lib/libpqxx-%%PORTVERSION%%.so
lib/libpqxx.a
-lib/libpqxx.la
lib/libpqxx.so
-lib/libpqxx.so.%%SOVERSION%%
libdata/pkgconfig/libpqxx.pc
@dirrm include/pqxx/internal/gates
@dirrm include/pqxx/internal
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
index 610d90c430d6..6f6576d086d2 100644
--- a/databases/postgresql-libpqxx3/Makefile
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libpqxx
PORTVERSION= 3.1.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://pqxx.org/download/software/${PORTNAME}/
PKGNAMEPREFIX= postgresql-
@@ -15,12 +16,12 @@ COMMENT= New C++ interface for PostgreSQL
CONFLICTS= postgresql-libpqxx-[2-4].*
PORTSCOUT= limit:^2\.
-USE_PGSQL= yes
-USES= gmake pkgconfig shebangfix
+USES= gmake libtool pgsql pkgconfig shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
USE_PYTHON_BUILD= yes
+INSTALL_TARGET= install-strip
SHEBANG_FILES= tools/splitconfig
python_CMD= ${PYTHON_CMD}
diff --git a/databases/postgresql-libpqxx3/pkg-plist b/databases/postgresql-libpqxx3/pkg-plist
index 4af66c712953..cf435a598e2c 100644
--- a/databases/postgresql-libpqxx3/pkg-plist
+++ b/databases/postgresql-libpqxx3/pkg-plist
@@ -83,7 +83,6 @@ include/pqxx/version
include/pqxx/version.hxx
lib/libpqxx-3.1.so
lib/libpqxx.a
-lib/libpqxx.la
lib/libpqxx.so
libdata/pkgconfig/libpqxx.pc
@dirrm include/pqxx/internal/gates