aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 11:23:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 11:23:12 +0000
commit1fd451d376c04b6df48cea64574e4b1d7ba21fb0 (patch)
tree3a403691ecd77fedbd9c457b0c7ad9ee1091d996 /databases
parent82bdc6ed1f0cf3469e71c361f443eec10e4ce686 (diff)
downloadports-1fd451d376c04b6df48cea64574e4b1d7ba21fb0.tar.gz
ports-1fd451d376c04b6df48cea64574e4b1d7ba21fb0.zip
Add another couple of Ruby modules.
databases/ruby-mysql: Ruby module for accessing MySQL databases, which has the same functions as C API ports/devel/ruby-optparse: Yet another command line option parser for Ruby
Notes
Notes: svn path=/head/; revision=31372
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-mysql/Makefile40
-rw-r--r--databases/ruby-mysql/distinfo1
-rw-r--r--databases/ruby-mysql/pkg-comment1
-rw-r--r--databases/ruby-mysql/pkg-descr4
-rw-r--r--databases/ruby-mysql/pkg-plist5
6 files changed, 52 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e175c88596a0..5c0b27c4577d 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -43,6 +43,7 @@
SUBDIR += py-MySQLdb
SUBDIR += py-PyGreSQL
SUBDIR += rdb
+ SUBDIR += ruby-mysql
SUBDIR += ruby-postgres
SUBDIR += sqsh
SUBDIR += tcl-Mysql
diff --git a/databases/ruby-mysql/Makefile b/databases/ruby-mysql/Makefile
new file mode 100644
index 000000000000..e76f91d87831
--- /dev/null
+++ b/databases/ruby-mysql/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby-MySQL
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql
+PORTVERSION= 2.3.0
+CATEGORIES= databases # ruby
+MASTER_SITES= http://www.tmtm.org/mysql/ruby/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/mysql/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/mysql/
+ ${INSTALL_DATA} ${WRKSRC}/README.jp ${PREFIX}/share/doc/ruby/mysql/ja
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-mysql/distinfo b/databases/ruby-mysql/distinfo
new file mode 100644
index 000000000000..02dbfdc12734
--- /dev/null
+++ b/databases/ruby-mysql/distinfo
@@ -0,0 +1 @@
+MD5 (mysql-ruby-2.3.0.tar.gz) = e518e06eab4f7a6f2bac186989d04595
diff --git a/databases/ruby-mysql/pkg-comment b/databases/ruby-mysql/pkg-comment
new file mode 100644
index 000000000000..79a6cb2e4f19
--- /dev/null
+++ b/databases/ruby-mysql/pkg-comment
@@ -0,0 +1 @@
+Ruby module for accessing MySQL databases, which has the same functions as C API
diff --git a/databases/ruby-mysql/pkg-descr b/databases/ruby-mysql/pkg-descr
new file mode 100644
index 000000000000..189a24aa6b3a
--- /dev/null
+++ b/databases/ruby-mysql/pkg-descr
@@ -0,0 +1,4 @@
+This is a Ruby module for accessing MySQL databases, which has the
+same functions as C API.
+
+WWW: http://www.tmtm.org/mysql/ruby/README
diff --git a/databases/ruby-mysql/pkg-plist b/databases/ruby-mysql/pkg-plist
new file mode 100644
index 000000000000..63cb1ac4de43
--- /dev/null
+++ b/databases/ruby-mysql/pkg-plist
@@ -0,0 +1,5 @@
+lib/ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/mysql.so
+share/doc/ruby/mysql/ja/README.jp
+share/doc/ruby/mysql/README
+@dirrm share/doc/ruby/mysql/ja
+@dirrm share/doc/ruby/mysql