aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:28 +0000
commit3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5 (patch)
tree5ec4d6c8c02d380cf421717b2ce88beceb851e79 /databases
parent320538c6d599e65e80ad91bd683504f5d7c338f1 (diff)
downloadports-3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5.tar.gz
ports-3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5.zip
Remove USES=execinfo.
PR: 220271 Submitted by: mat (review), Yasuhiro KIMURA (PR) Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D11488
Notes
Notes: svn path=/head/; revision=450351
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi/Makefile2
-rw-r--r--databases/galera/Makefile2
-rw-r--r--databases/libmemcached/Makefile2
-rw-r--r--databases/mariadb100-server/Makefile2
-rw-r--r--databases/mariadb101-server/Makefile2
-rw-r--r--databases/mariadb102-server/Makefile2
-rw-r--r--databases/mariadb55-server/Makefile2
-rw-r--r--databases/mongodb/Makefile2
-rw-r--r--databases/mongodb32/Makefile2
-rw-r--r--databases/mongodb34-rocks/Makefile2
-rw-r--r--databases/mongodb34/Makefile2
-rw-r--r--databases/pgmodeler/Makefile2
-rw-r--r--databases/redis-devel/Makefile3
-rw-r--r--databases/redis/Makefile2
-rw-r--r--databases/rubygem-bdb1/Makefile2
-rw-r--r--databases/twemproxy/Makefile2
-rw-r--r--databases/virtuoso/Makefile2
17 files changed, 17 insertions, 18 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 27bdf65bcafe..f53f289917ec 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs
# Let process generate meaningful backtrace on core dump.
BUILD_DEPENDS= xsltproc:textproc/libxslt
-USES= cmake:outsource execinfo kde:4 shared-mime-info \
+USES= cmake:outsource kde:4 shared-mime-info \
compiler:c++11-lang pathfix tar:bzip2
USE_KDE= automoc4 soprano
USE_QT4= corelib dbus gui network qtestlib_build sql xml \
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index 7d2cabb39c92..60efcc8c22c1 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -28,7 +28,7 @@ NOT_FOR_ARCHS= i386
# https://tracker.crystax.net/issues/1263
NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386
-USES= execinfo python:build scons ssl
+USES= python:build scons ssl
USE_LDCONFIG= yes
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index 2864e37b55ff..45ce603e74e3 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS?= libevent.so:devel/libevent
TEST_DEPENDS= memcached:databases/memcached
-USES= autoreconf execinfo gmake libtool localbase pathfix pkgconfig
+USES= autoreconf gmake libtool localbase pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index fdf7f7e4687f..0b60e3b4bd4d 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -29,7 +29,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb100-client
-USES= bison:build cmake:noninja compiler:c++11-lib cpe execinfo \
+USES= bison:build cmake:noninja compiler:c++11-lib cpe \
ncurses shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql ${PREFIX}/lib/mysql/plugin
SHEBANG_FILES= scripts/*.sh
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 66ca7f89bc96..2354ba4c5d7d 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -28,7 +28,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb101-client
-USES= bison:build cmake compiler:c++11-lib cpe execinfo libedit ncurses \
+USES= bison:build cmake compiler:c++11-lib cpe libedit ncurses \
shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh
diff --git a/databases/mariadb102-server/Makefile b/databases/mariadb102-server/Makefile
index 17511ab59683..b4916af78180 100644
--- a/databases/mariadb102-server/Makefile
+++ b/databases/mariadb102-server/Makefile
@@ -28,7 +28,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb102-client
-USES= bison:build cmake compiler:c++11-lib cpe execinfo iconv:translit libedit ncurses shebangfix ssl
+USES= bison:build cmake compiler:c++11-lib cpe iconv:translit libedit ncurses shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh
SITESDIR= mariadb/mariadb-${PORTVERSION}/source
diff --git a/databases/mariadb55-server/Makefile b/databases/mariadb55-server/Makefile
index 2e41dceb091c..6404076fa5ee 100644
--- a/databases/mariadb55-server/Makefile
+++ b/databases/mariadb55-server/Makefile
@@ -24,7 +24,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb55-client
-USES= cmake:noninja execinfo shebangfix ssl
+USES= cmake:noninja shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh sql-bench/[a-km-z]*
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 820b0917e2b6..2c1d33816417 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -34,7 +34,7 @@ OPTIONS_DEFINE= SSL SASL TEST
OPTIONS_DEFAULT=SSL
TEST_DESC= Add support for running regression test
-USES= cpe execinfo scons
+USES= cpe scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
--use-system-pcre --use-system-snappy --use-system-v8
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
index 754d1288359f..223b0428549a 100644
--- a/databases/mongodb32/Makefile
+++ b/databases/mongodb32/Makefile
@@ -37,7 +37,7 @@ SASL_MAKE_ARGS= --use-sasl-client
SSL_USE= yes
SSL_MAKE_ARGS= --ssl
-USES= compiler cpe execinfo python:build scons
+USES= compiler cpe python:build scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
--use-system-pcre --use-system-snappy \
diff --git a/databases/mongodb34-rocks/Makefile b/databases/mongodb34-rocks/Makefile
index 72b8421b4d3d..bb86cc254419 100644
--- a/databases/mongodb34-rocks/Makefile
+++ b/databases/mongodb34-rocks/Makefile
@@ -30,7 +30,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}pymongo>=3.0:databases/pymongo
-USES= compiler:c++14-lang cpe execinfo python:build scons
+USES= compiler:c++14-lang cpe python:build scons
USE_RC_SUBR= mongod \
mongos
diff --git a/databases/mongodb34/Makefile b/databases/mongodb34/Makefile
index 83146d7f1d12..281659a49b6a 100644
--- a/databases/mongodb34/Makefile
+++ b/databases/mongodb34/Makefile
@@ -31,7 +31,7 @@ CONFLICTS_BUILD= mongo-cxx-driver
CHOSEN_COMPILER_TYPE= clang
-USES= compiler:c++14-lang cpe execinfo python:build scons
+USES= compiler:c++14-lang cpe python:build scons
USE_RC_SUBR= mongod
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
diff --git a/databases/pgmodeler/Makefile b/databases/pgmodeler/Makefile
index 16e7275e5f4a..42c332443d01 100644
--- a/databases/pgmodeler/Makefile
+++ b/databases/pgmodeler/Makefile
@@ -13,7 +13,7 @@ COMMENT= PostgreSQL Database Modeler
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lib execinfo pgsql qmake pkgconfig gmake
+USES= compiler:c++11-lib pgsql qmake pkgconfig gmake
USE_GITHUB= yes
USE_GNOME= libxml2
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 700c43bb2c12..d834628b9d8f 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -14,7 +14,8 @@ LICENSE= BSD3CLAUSE
BROKEN_i386= undefined reference to __atomic_fetch_add_8
-USES= execinfo
+USE_GITHUB= yes
+GH_ACCOUNT= antirez
OPTIONS_DEFINE= TESTS TRIB
OPTIONS_RADIO= EXTLUA
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 02513a6d23d8..a7780d672da7 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -11,8 +11,6 @@ COMMENT= Persistent key-value database with built-in net interface
LICENSE= BSD3CLAUSE
-USES= execinfo
-
OPTIONS_DEFINE= TESTS TRIB
OPTIONS_RADIO= EXTLUA
OPTIONS_RADIO_EXTLUA= LUA LUAJIT
diff --git a/databases/rubygem-bdb1/Makefile b/databases/rubygem-bdb1/Makefile
index cdf020e04874..3ac7cdd95652 100644
--- a/databases/rubygem-bdb1/Makefile
+++ b/databases/rubygem-bdb1/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
USE_RUBY= yes
-USES= execinfo gem shebangfix
+USES= gem shebangfix
SHEBANG_FILES= examples/*.rb
.include <bsd.port.pre.mk>
diff --git a/databases/twemproxy/Makefile b/databases/twemproxy/Makefile
index fe2f35a32ae9..19eb8477db7e 100644
--- a/databases/twemproxy/Makefile
+++ b/databases/twemproxy/Makefile
@@ -14,7 +14,7 @@ LICENSE= APACHE20
USE_GITHUB= yes
GH_ACCOUNT= twitter
-USES= execinfo autoreconf libtool
+USES= autoreconf libtool
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 72352b49bf7c..2d2f41cd246c 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -27,7 +27,7 @@ BROKEN_sparc64= Does not compile: error: DV_INT_TAG_WORD undeclared
NOT_FOR_ARCHS= arm armv6 i386 mips powerpc
NOT_FOR_ARCHS_REASON= can only be built on 64bit platforms
-USES= execinfo gmake libtool readline uidfix ssl
+USES= gmake libtool readline uidfix ssl
USE_AUTOTOOLS= autoheader aclocal
GNU_CONFIGURE= yes