aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-05 19:54:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-05 19:54:12 +0000
commit424d44ae843fe4363079c85dfe2b04861b1b36cb (patch)
tree7c13683c240a199254ffbf5f7c0f373b813c3169 /databases
parenta8fdf914ddd0252f56d8d0bb6c49ccad2b29f13f (diff)
downloadports-424d44ae843fe4363079c85dfe2b04861b1b36cb.tar.gz
ports-424d44ae843fe4363079c85dfe2b04861b1b36cb.zip
Add ANYJSON, ARROW, BABEL, COLOR, ENCRYPTED, ENUM, INTERVALS, IPADDRESS, PASSWORD, PHONE, TIMEZONE and URL options
Notes
Notes: svn path=/head/; revision=530813
Diffstat (limited to 'databases')
-rw-r--r--databases/py-sqlalchemy-utils/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/databases/py-sqlalchemy-utils/Makefile b/databases/py-sqlalchemy-utils/Makefile
index 67adbb5eeb45..8aa368a22f55 100644
--- a/databases/py-sqlalchemy-utils/Makefile
+++ b/databases/py-sqlalchemy-utils/Makefile
@@ -22,4 +22,38 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= ANYJSON ARROW BABEL COLOR ENCRYPTED ENUM INTERVALS IPADDRESS PASSWORD PHONE TIMEZONE URL
+ANYJSON_DESC= JSON support
+ARROW_DESC= Arrow type support
+BABEL_DESC= Babel locale type support
+COLOR_DESC= Color type support
+ENCRYPTED_DESC= Encrypted type support
+ENUM_DESC= Enum type support
+INTERVALS_DESC= Interval operators support
+IPADDRESS_DESC= IP address type support
+PASSWORD_DESC= Password type support
+PHONE_DESC= Phone number type support
+TIMEZONE_DESC= Timezone support
+URL_DESC= URL type support
+
+ANYJSON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}anyjson>=0.3.3:devel/py-anyjson@${PY_FLAVOR}
+ARROW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>=0.3.4:devel/py-arrow@${PY_FLAVOR}
+BABEL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}babel>=1.3:devel/py-babel@${PY_FLAVOR}
+COLOR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colour>=0.0.4:graphics/py-colour@${PY_FLAVOR}
+ENCRYPTED_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.6:security/py-cryptography@${PY_FLAVOR}
+ENUM_RUN_DEPENDS= ${PY_ENUM34}
+INTERVALS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}intervals>=0.7.1:net/py-intervals@${PY_FLAVOR}
+PASSWORD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}passlib>=1.6<2.0:security/py-passlib@${PY_FLAVOR}
+PHONE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}phonenumbers>=5.9.2:devel/py-phonenumbers@${PY_FLAVOR}
+TIMEZONE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR}
+URL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}furl>=0.4.1:devel/py-furl@${PY_FLAVOR}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIPADDRESS}
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipaddr>=0:devel/py-ipaddr@${PY_FLAVOR}
+.endif
+.endif
+
.include <bsd.port.mk>