aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 09:37:29 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 09:37:29 +0000
commit4ac3cd7048c6a4c9005d53f96177aa0e162adf53 (patch)
tree9dd9aac3ddf4654df74c8642f6fc4238e3315c58 /databases
parent2bf9ca57b161dda80ac325ace89ff2fb273a9127 (diff)
downloadports-4ac3cd7048c6a4c9005d53f96177aa0e162adf53.tar.gz
ports-4ac3cd7048c6a4c9005d53f96177aa0e162adf53.zip
databases: Add missing USES={gnome,php}
Notes
Notes: svn path=/head/; revision=517042
Diffstat (limited to 'databases')
-rw-r--r--databases/adodb/Makefile2
-rw-r--r--databases/akonadi/Makefile4
-rw-r--r--databases/dbf/Makefile2
-rw-r--r--databases/emma/Makefile2
-rw-r--r--databases/kexi/Makefile2
-rw-r--r--databases/libmongo-client/Makefile2
-rw-r--r--databases/mariadb101-server/Makefile2
-rw-r--r--databases/mdbtools/Makefile3
-rw-r--r--databases/monetdb/Makefile2
-rw-r--r--databases/pear-Horde_Db/Makefile2
-rw-r--r--databases/pear-Horde_Memcache/Makefile2
-rw-r--r--databases/pear-MDB2_Driver_mysql/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile2
-rw-r--r--databases/pgadmin3/Makefile2
-rw-r--r--databases/pgfouine/Makefile2
-rw-r--r--databases/pgmodeler/Makefile3
-rw-r--r--databases/pgworksheet/Makefile2
-rw-r--r--databases/pxlib/Makefile2
-rw-r--r--databases/py-python-rrdtool/Makefile2
-rw-r--r--databases/qof/Makefile2
-rw-r--r--databases/spatialite/Makefile2
-rw-r--r--databases/sqlitemanager/Makefile2
25 files changed, 30 insertions, 24 deletions
diff --git a/databases/adodb/Makefile b/databases/adodb/Makefile
index 1bf0724e66d1..2f95b9223de2 100644
--- a/databases/adodb/Makefile
+++ b/databases/adodb/Makefile
@@ -13,7 +13,7 @@ COMMENT= Database library for PHP
LICENSE= BSD4CLAUSE LGPL21
LICENSE_COMB= dual
-USES= tar:tgz
+USES= php tar:tgz
USE_PHP= pcre
CONFLICTS= adodb-5.*
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 41ec302ce677..901ea1a8368e 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -15,8 +15,8 @@ BUILD_DEPENDS= xsltproc:textproc/libxslt
CONFLICTS= akonadi-[0-9]* akonadi-kf5-git-[0-9]*
-USES= cmake compiler:c++11-lib gettext kde:5 \
- qt:5 shared-mime-info tar:xz
+USES= cmake compiler:c++11-lib gettext gnome kde:5 qt:5 \
+ shared-mime-info tar:xz
USE_GNOME= libxml2
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes itemmodels itemviews \
diff --git a/databases/dbf/Makefile b/databases/dbf/Makefile
index 2c21de3f4bc1..33ed97d82a5e 100644
--- a/databases/dbf/Makefile
+++ b/databases/dbf/Makefile
@@ -17,7 +17,7 @@ OPTIONS_SUB= yes
WRKSRC= ${WRKDIR}/lib${PORTNAME}
-USES= libtool pathfix zip
+USES= gnome libtool pathfix zip
USE_GNOME= intltool
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_prog_DOC_TO_MAN=""
diff --git a/databases/emma/Makefile b/databases/emma/Makefile
index b40fca059963..bffecaa0a88b 100644
--- a/databases/emma/Makefile
+++ b/databases/emma/Makefile
@@ -12,7 +12,7 @@ COMMENT= Extendable MySQL managing assistant
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb@${PY_FLAVOR}
-USES= python:2.7
+USES= gnome python:2.7
USE_GNOME= pygtk2
USE_PYTHON= distutils
diff --git a/databases/kexi/Makefile b/databases/kexi/Makefile
index fa2868f88390..d1f98dbd139d 100644
--- a/databases/kexi/Makefile
+++ b/databases/kexi/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libKDb3.so:databases/kdb \
libKPropertyCore3.so:x11-toolkits/kproperty \
libKReport3.so:textproc/kreport
-USES= cmake compiler:c++11-lang desktop-file-utils gettext \
+USES= cmake compiler:c++11-lang desktop-file-utils gettext gnome \
iconv kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= glib20
USE_KDE= auth bookmarks codecs completion config \
diff --git a/databases/libmongo-client/Makefile b/databases/libmongo-client/Makefile
index f1a9f2963455..6da1e6dca23e 100644
--- a/databases/libmongo-client/Makefile
+++ b/databases/libmongo-client/Makefile
@@ -16,7 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= algernon
GNU_CONFIGURE= yes
-USES= autoreconf libtool pkgconfig gmake pathfix
+USES= autoreconf gmake gnome libtool pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 1cee9d2ff0c0..5caeee6038ce 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -111,7 +111,7 @@ CMAKE_ON+= WITHOUT_SERVER
GSSAPI_NONE_CMAKE_ON= -DPLUGIN_AUTH_GSSAPI_CLIENT=NO
.else
# MySQL-Server part
-USES+= mysql:101m
+USES+= gnome mysql:101m
USE_GNOME= libxml2
USE_LDCONFIG+= ${PREFIX}/lib/mysql/plugin
USE_RC_SUBR= mysql-server
diff --git a/databases/mdbtools/Makefile b/databases/mdbtools/Makefile
index c7e5a58ddeed..bf9690066a19 100644
--- a/databases/mdbtools/Makefile
+++ b/databases/mdbtools/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= libodbc.so:databases/unixODBC
OPTIONS_DEFINE= GNOME DOCS
OPTIONS_SUB= yes
-USES= autoreconf bison gettext-runtime iconv libtool pathfix pkgconfig readline
+USES= autoreconf bison gettext-runtime gnome iconv libtool pathfix \
+ pkgconfig readline
USE_GITHUB= yes
GH_ACCOUNT= brianb
USE_LDCONFIG= yes
diff --git a/databases/monetdb/Makefile b/databases/monetdb/Makefile
index 732d94f10e08..1bf27186ae58 100644
--- a/databases/monetdb/Makefile
+++ b/databases/monetdb/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre
USE_GNOME= libxml2
-USES= bison iconv gmake libtool pkgconfig tar:xz
+USES= bison gmake gnome iconv libtool pkgconfig tar:xz
USE_LDCONFIG= yes
USE_RC_SUBR= monetdbd
diff --git a/databases/pear-Horde_Db/Makefile b/databases/pear-Horde_Db/Makefile
index 293d9cd6c10c..9e72047adc82 100644
--- a/databases/pear-Horde_Db/Makefile
+++ b/databases/pear-Horde_Db/Makefile
@@ -17,7 +17,9 @@ USE_HORDE_RUN= Horde_Date \
Horde_Exception \
Horde_Support
+MYSQLI_USES= php
MYSQLI_USE= PHP=mysqli
+PDO_USES= php
PDO_USE= PHP=pdo
.include <bsd.port.mk>
diff --git a/databases/pear-Horde_Memcache/Makefile b/databases/pear-Horde_Memcache/Makefile
index f61a834da0e0..17582a9125bc 100644
--- a/databases/pear-Horde_Memcache/Makefile
+++ b/databases/pear-Horde_Memcache/Makefile
@@ -9,7 +9,7 @@ COMMENT= Horde Memcache API
IGNORE_WITH_PHP=71
-USES= horde
+USES= horde php
USE_PHP= memcache hash
USE_HORDE_RUN= Horde_Exception
diff --git a/databases/pear-MDB2_Driver_mysql/Makefile b/databases/pear-MDB2_Driver_mysql/Makefile
index 4e706c465b08..496d328b6264 100644
--- a/databases/pear-MDB2_Driver_mysql/Makefile
+++ b/databases/pear-MDB2_Driver_mysql/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PEAR_PKGNAMEPREFIX}MDB2>=0:databases/pear-MDB2@${PHP_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= pear
+USES= pear php
USE_PHP= mysqli
NO_ARCH= yes
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
index ac64bb025ff2..a7145011c7df 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
-USES= pear
+USES= pear php
USE_PHP= mysqli
NO_ARCH= yes
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
index 3e23342edff6..1f2e3d662fe5 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/DB/Table.php:databases/pear-DB_Table@${PHP_FLAVOR}
-USES= pear
+USES= pear php
USE_PHP= mysqli
NO_ARCH= yes
diff --git a/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile b/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
index 6ab0a5641f96..127051893da7 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/DB/DataObject.php:databases/pear-DB_DataObject@${PHP_FLAVOR}
-USES= pear
+USES= pear php
USE_PHP= mysqli
NO_ARCH= yes
diff --git a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
index 45902db20a65..48f45843f800 100644
--- a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
-USES= pear
+USES= pear php
USE_PHP= mysqli
NO_ARCH= yes
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index fac448fd2c22..e2040948113c 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -15,7 +15,7 @@ LICENSE= PostgreSQL
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
-USES= compiler:c++11-lib gettext gmake pgsql:9.0+ ssl
+USES= compiler:c++11-lib gettext gmake gnome pgsql:9.0+ ssl
USE_GNOME= libxml2 libxslt
USE_WX= 3.0
USE_CXXSTD= c++11
diff --git a/databases/pgfouine/Makefile b/databases/pgfouine/Makefile
index bdeddbed99c6..ee4109123804 100644
--- a/databases/pgfouine/Makefile
+++ b/databases/pgfouine/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://pgfoundry.org/frs/download.php/2575/ \
MAINTAINER= pea@raveland.org
COMMENT= PostgreSQL log analyzer
+USES+= php
+
NO_BUILD= Yes
USE_PHP= gd pcre
diff --git a/databases/pgmodeler/Makefile b/databases/pgmodeler/Makefile
index bd74dfa80e9f..484d580e7e6f 100644
--- a/databases/pgmodeler/Makefile
+++ b/databases/pgmodeler/Makefile
@@ -13,7 +13,8 @@ COMMENT= PostgreSQL Database Modeler
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lib gl pgsql qmake pkgconfig gmake qt:5 xorg
+USES= compiler:c++11-lib gl gmake gnome pgsql pkgconfig qmake qt:5 \
+ xorg
USE_GITHUB= yes
USE_GNOME= libxml2
diff --git a/databases/pgworksheet/Makefile b/databases/pgworksheet/Makefile
index 13a4ee4ea2b3..42f8942aeb69 100644
--- a/databases/pgworksheet/Makefile
+++ b/databases/pgworksheet/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyPgSQL/libpq/__init__.py:databases/py-pyPgSQL@${PY_FLAVOR}
-USES= pgsql python:2.7 tar:bzip2
+USES= gnome pgsql python:2.7 tar:bzip2
USE_GNOME= pygtk2
USE_PYTHON= distutils autoplist
diff --git a/databases/pxlib/Makefile b/databases/pxlib/Makefile
index 587c569b1c77..b4545904a889 100644
--- a/databases/pxlib/Makefile
+++ b/databases/pxlib/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
-USES= gmake iconv libtool pathfix perl5 pkgconfig
+USES= gmake gnome iconv libtool pathfix perl5 pkgconfig
USE_GNOME= intltool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/databases/py-python-rrdtool/Makefile b/databases/py-python-rrdtool/Makefile
index 14108225dda9..6569b0c28b16 100644
--- a/databases/py-python-rrdtool/Makefile
+++ b/databases/py-python-rrdtool/Makefile
@@ -14,7 +14,7 @@ LICENSE= LGPL3
LIB_DEPENDS= librrd.so:databases/rrdtool
-USES= groff pkgconfig python:2.7
+USES= gnome groff pkgconfig python:2.7
USE_GNOME= cairo glib20 libxml2 pango
USE_PYTHON= distutils autoplist
diff --git a/databases/qof/Makefile b/databases/qof/Makefile
index 7338395b53b9..2b8874442c18 100644
--- a/databases/qof/Makefile
+++ b/databases/qof/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ARGS= --disable-doxygen --disable-gdasql --disable-sqlite
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig
+USES= gmake gnome libtool pathfix pkgconfig
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 0838857d0c5c..88c4ed81540b 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libgeos_c.so:graphics/geos \
libfreexl.so:textproc/freexl
GNU_CONFIGURE= yes
-USES= gmake iconv pathfix pkgconfig libtool sqlite
+USES= gmake gnome iconv libtool pathfix pkgconfig sqlite
USE_GNOME= libxml2
CFLAGS+= -I${WRKSRC}/src/headers -I${LOCALBASE}/include
diff --git a/databases/sqlitemanager/Makefile b/databases/sqlitemanager/Makefile
index 48318227d10e..2130dd91d0bd 100644
--- a/databases/sqlitemanager/Makefile
+++ b/databases/sqlitemanager/Makefile
@@ -13,7 +13,7 @@ COMMENT= Multilingual web based tool to manage SQLite database
LICENSE= GPLv2
WRKSRC= ${WRKDIR}/SQLiteManager-${PORTVERSION}
-USES= dos2unix
+USES= dos2unix php
NO_BUILD= yes
PLIST_SUB+= WWWDIR_REL="${WWWDIR_REL}"
USE_PHP= sqlite3