aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /databases
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'databases')
-rw-r--r--databases/cppdb/Makefile2
-rw-r--r--databases/evolution-data-server/Makefile2
-rw-r--r--databases/mariadb100-server/Makefile2
-rw-r--r--databases/mariadb55-server/Makefile2
-rw-r--r--databases/mysql55-server/Makefile2
-rw-r--r--databases/mysql56-server/Makefile2
-rw-r--r--databases/mysql57-server/Makefile2
-rw-r--r--databases/mysql80-server/Makefile2
-rw-r--r--databases/mysqlwsrep56-server/Makefile2
-rw-r--r--databases/percona55-server/Makefile2
-rw-r--r--databases/percona56-server/Makefile2
-rw-r--r--databases/percona57-server/Makefile2
-rw-r--r--databases/tarantool/Makefile2
-rw-r--r--databases/xtrabackup/Makefile2
14 files changed, 14 insertions, 14 deletions
diff --git a/databases/cppdb/Makefile b/databases/cppdb/Makefile
index e94e27c3bc20..0a6abbf4a660 100644
--- a/databases/cppdb/Makefile
+++ b/databases/cppdb/Makefile
@@ -41,7 +41,7 @@ SQLITE3_INTERNAL_DESC= Link SQLite 3 backend into CppDB
SQLITE3_MODULE_DESC= Build SQLite 3 backend as a CppDB module
USE_LDCONFIG= yes
-USES= cmake:outsource ninja tar:bzip2
+USES= cmake:outsource tar:bzip2
.include <bsd.port.options.mk>
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 0270146787d6..328676545037 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -30,7 +30,7 @@ LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
PORTSCOUT= limitw:1,even
USES= bdb:5 cmake compiler:c++11-lib gettext gnome gperf \
- iconv localbase ninja pathfix pkgconfig python:3.3+,build\
+ iconv localbase pathfix pkgconfig python:3.3+,build\
sqlite tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool introspection:build libxml2
USE_LDCONFIG= yes
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index 1a6734be87fa..6f72d893fc78 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -29,7 +29,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb100-client
-USES= bison:build cmake compiler:c++11-lib cpe execinfo \
+USES= bison:build cmake:noninja compiler:c++11-lib cpe execinfo \
ncurses shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql ${PREFIX}/lib/mysql/plugin
SHEBANG_FILES= scripts/*.sh
diff --git a/databases/mariadb55-server/Makefile b/databases/mariadb55-server/Makefile
index 78c7e5a9fe3c..e4a20c849031 100644
--- a/databases/mariadb55-server/Makefile
+++ b/databases/mariadb55-server/Makefile
@@ -24,7 +24,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb55-client
-USES= cmake execinfo shebangfix ssl
+USES= cmake:noninja execinfo shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh sql-bench/[a-km-z]*
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index f8ced7135c45..ff396d5b00ec 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -14,7 +14,7 @@ COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
SLAVEDIRS= databases/mysql55-client
-USES= cmake readline shebangfix
+USES= cmake:noninja readline shebangfix
CXXFLAGS+= ${CPPFLAGS}
NO_OPTIONS_SORT=yes
diff --git a/databases/mysql56-server/Makefile b/databases/mysql56-server/Makefile
index c0f814289e0c..875aca26eb42 100644
--- a/databases/mysql56-server/Makefile
+++ b/databases/mysql56-server/Makefile
@@ -13,7 +13,7 @@ COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
SLAVEDIRS= databases/mysql56-client
-USES= bison:build cmake:outsource compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:outsource,noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix ssl
USE_PERL5= run
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index f7b58be324f3..3f2466a5d0d5 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SLAVEDIRS= databases/mysql57-client
-USES= bison:build cmake:outsource compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:outsource,noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix ssl
USE_PERL5= run
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index d31550cd03b3..8a131b3ab81d 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${DISTVERSIONSUFFIX}
SLAVEDIRS= databases/mysql80-client
-USES= bison:build cmake:outsource compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:outsource,noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix ssl
USE_PERL5= run
diff --git a/databases/mysqlwsrep56-server/Makefile b/databases/mysqlwsrep56-server/Makefile
index 4909d5aafd92..6fc7cdf36cd7 100644
--- a/databases/mysqlwsrep56-server/Makefile
+++ b/databases/mysqlwsrep56-server/Makefile
@@ -22,7 +22,7 @@ DATADIR= ${PREFIX}/share/mysql
NOT_FOR_ARCHS= aarch64 armv6 powerpc64
NOT_FOR_ARCHS_REASON= error: Unsupported platform
-USES= cmake:outsource libedit shebangfix perl5
+USES= cmake:outsource,noninja libedit shebangfix perl5
USE_PERL5= run
USE_LDCONFIG= yes
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index f0d0861b58da..50c28e8c1545 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= flo@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/percona55-client
-USES= bison cmake readline shebangfix
+USES= bison cmake:noninja readline shebangfix
CXXFLAGS+= ${CPPFLAGS}
diff --git a/databases/percona56-server/Makefile b/databases/percona56-server/Makefile
index a0df827b0a4d..0e532f9fc872 100644
--- a/databases/percona56-server/Makefile
+++ b/databases/percona56-server/Makefile
@@ -17,7 +17,7 @@ NOT_FOR_ARCHS_REASON= unsupported platform
SLAVEDIRS= databases/percona56-client \
databases/percona-pam-for-mysql
-USES= bison cmake perl5 shebangfix
+USES= bison cmake:noninja perl5 shebangfix
OPTIONS_DEFINE= OPENSSL FASTMTX INNODBMEMCACHED TOKUDB
OPTIONS_DEFAULT= OPENSSL INNODBMEMCACHED
diff --git a/databases/percona57-server/Makefile b/databases/percona57-server/Makefile
index c4ab19025fd4..31ab44835982 100644
--- a/databases/percona57-server/Makefile
+++ b/databases/percona57-server/Makefile
@@ -24,7 +24,7 @@ BROKEN_powerpc64= Does not build
SLAVEDIRS= databases/percona57-client \
databases/percona57-pam-for-mysql
-USES= bison:build cmake compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix
MY_DBDIR= /var/db/mysql
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index f09ad003a7c3..37e5e422abeb 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -15,7 +15,7 @@ NOT_FOR_ARCHS= armv6 powerpc64 sparc64
NOT_FOR_ARCHS_REASON= fails to build: Unsupported architecture
MAKE_JOBS_UNSAFE=yes
-USES= cmake compiler:c++11-lang gettext gmake perl5 readline
+USES= cmake:noninja compiler:c++11-lang gettext gmake perl5 readline
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 4f0278477e07..e74790b1fdcf 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -29,7 +29,7 @@ BROKEN_mips64= fails to compile: 'fpsetmask' was not declared in this scope
BROKEN_powerpc64= fails to link: ld: final link failed: Bad value
# autotool is in use for 5.1 builds
-USES= alias autoreconf:build cpe gettext cmake libtool perl5 shebangfix
+USES= alias autoreconf:build cpe gettext cmake:noninja libtool perl5 shebangfix
CPE_VENDOR= percona
SHEBANG_FILES= storage/innobase/xtrabackup/xbcloud_osenv.sh