aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-06 17:33:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-06 17:33:20 +0000
commit627ded965eea35b78e7f33a9748450235b6e6fb4 (patch)
tree6406dfebe420e4ce1ea33cd4f627f500253ca328 /databases
parent421e7c22fc69a225baf73e804ba8a8d6a1c8b744 (diff)
downloadports-627ded965eea35b78e7f33a9748450235b6e6fb4.tar.gz
ports-627ded965eea35b78e7f33a9748450235b6e6fb4.zip
Add AIOREDIS and LUA options
Notes
Notes: svn path=/head/; revision=530901
Diffstat (limited to 'databases')
-rw-r--r--databases/py-fakeredis/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/databases/py-fakeredis/Makefile b/databases/py-fakeredis/Makefile
index 01692131d883..68176be8c93b 100644
--- a/databases/py-fakeredis/Makefile
+++ b/databases/py-fakeredis/Makefile
@@ -23,6 +23,13 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= AIOREDIS LUA
+AIOREDIS_DESC= Asyncio redis support
+LUA_DESC= Lua support
+
+AIOREDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aioredis>=0:databases/py-aioredis@${PY_FLAVOR}
+LUA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lupa>=0:lang/py-lupa@${PY_FLAVOR}
+
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} test_fakeredis.py