aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2024-06-13 16:42:21 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2024-06-13 16:46:03 +0000
commit68436150c0bbed44dec6393a310a9695cb869b89 (patch)
treeab562d2aa40a48e32e90e66e09d386a8f922ee05 /databases
parent59c450d2273aa66e00df37bfe17b5048468ccb13 (diff)
downloadports-68436150c0bbed44dec6393a310a9695cb869b89.tar.gz
ports-68436150c0bbed44dec6393a310a9695cb869b89.zip
databases/pguri: Unbreak for PostgreSQL 16
The changes for the patch were taken from here: https://github.com/petere/pguri/issues/16#issuecomment-1816077925 PR: 279190
Diffstat (limited to 'databases')
-rw-r--r--databases/pguri/Makefile2
-rw-r--r--databases/pguri/files/patch-uri.c29
2 files changed, 30 insertions, 1 deletions
diff --git a/databases/pguri/Makefile b/databases/pguri/Makefile
index 7ea44d541924..555425b8f11e 100644
--- a/databases/pguri/Makefile
+++ b/databases/pguri/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pguri
PORTVERSION= 1.20151224
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MAINTAINER= tz@FreeBSD.org
diff --git a/databases/pguri/files/patch-uri.c b/databases/pguri/files/patch-uri.c
new file mode 100644
index 000000000000..10a95328056d
--- /dev/null
+++ b/databases/pguri/files/patch-uri.c
@@ -0,0 +1,29 @@
+--- uri.c.orig 2024-06-13 16:34:21 UTC
++++ uri.c
+@@ -149,7 +149,7 @@ uri_host_inet(PG_FUNCTION_ARGS)
+ char *tmp = palloc(16);
+ snprintf(tmp, 16, "%u.%u.%u.%u", data[0], data[1], data[2], data[3]);
+ uriFreeUriMembersA(&uri);
+- PG_RETURN_INET_P(DirectFunctionCall1(inet_in, CStringGetDatum(tmp)));
++ PG_RETURN_INET_P((inet *) (DirectFunctionCall1(inet_in, CStringGetDatum(tmp))));
+ }
+ else if (uri.hostData.ip6)
+ {
+@@ -161,7 +161,7 @@ uri_host_inet(PG_FUNCTION_ARGS)
+ data[8], data[9], data[10], data[11],
+ data[12], data[13], data[14], data[15]);
+ uriFreeUriMembersA(&uri);
+- PG_RETURN_INET_P(DirectFunctionCall1(inet_in, CStringGetDatum(tmp)));
++ PG_RETURN_INET_P((inet *) (DirectFunctionCall1(inet_in, CStringGetDatum(tmp))));
+ }
+ else
+ {
+@@ -299,7 +299,7 @@ uri_path_array(PG_FUNCTION_ARGS)
+ uriFreeUriMembersA(&uri);
+
+ if (astate)
+- PG_RETURN_ARRAYTYPE_P(makeArrayResult(astate, CurrentMemoryContext));
++ PG_RETURN_ARRAYTYPE_P((Pointer)(makeArrayResult(astate, CurrentMemoryContext)));
+ else
+ PG_RETURN_ARRAYTYPE_P(construct_empty_array(TEXTOID));
+ }