aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-11-20 16:51:15 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-11-20 16:51:15 +0000
commit6d0c8c64ee5d3e0e8f752ccfaa3b3a203c7609f8 (patch)
tree268b7bfd0f5143443a9d0dbbb33b6175b3049677 /databases
parentef18a0f2784825a3c37348632a6e9a61a20d2a57 (diff)
downloadports-6d0c8c64ee5d3e0e8f752ccfaa3b3a203c7609f8.tar.gz
ports-6d0c8c64ee5d3e0e8f752ccfaa3b3a203c7609f8.zip
Change permissions for formerly suid-ed binaries:
-r-xr-xr-x root wheel fb_inet_server -r-sr-x--- root firebird fb_lock_mgr -r-x------ root wheel gds_drop 1. fb_inet_server is installed as normal binary but still must be started under "firebird" user (it must be specified in x?inetd.conf) 2. fb_lock_mgr is still suid-ed binary but can be started only by users in "firebird" group - it affects usage of "gsec" and similar utilities while using "embedded" (direct) database access mode. 3. gds_drop is installed as normal binary but can be started by "root" only to prevent any improper/malicious usage.
Notes
Notes: svn path=/head/; revision=177670
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird2-client/Makefile1
-rw-r--r--databases/firebird2-server/Makefile12
-rw-r--r--databases/firebird20-client/Makefile1
-rw-r--r--databases/firebird20-server/Makefile12
4 files changed, 14 insertions, 12 deletions
diff --git a/databases/firebird2-client/Makefile b/databases/firebird2-client/Makefile
index 5e1b77d92b85..84efb7b9bf4e 100644
--- a/databases/firebird2-client/Makefile
+++ b/databases/firebird2-client/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= firebird
+PORTREVISION= 3
PKGNAMESUFFIX= -client
COMMENT= Firebird-2 database client
diff --git a/databases/firebird2-server/Makefile b/databases/firebird2-server/Makefile
index 509df22b931f..c6a7e42cd796 100644
--- a/databases/firebird2-server/Makefile
+++ b/databases/firebird2-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= firebird
PORTVERSION= 2.0.0
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=firebird
@@ -59,8 +59,7 @@ ALL_TARGET= firebird_boot ref_databases msgs libfbembed intl otherfiles \
SUB_FILES= pkg-install pkg-message aliases.conf
-SUID_BIN= fb_inet_server fb_lock_mgr gds_drop
-UTIL_BIN= fb_lock_print gbak gdef gfix gsec gstat nbackup
+UTIL_BIN= fb_inet_server fb_lock_print gbak gdef gfix gsec gstat nbackup
UDF_SO= ib_udf.so fbudf.so
UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
.else
@@ -156,9 +155,10 @@ do-install:
.if !defined(CLIENT_ONLY)
${INSTALL_PROGRAM} ${UTIL_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} ${PREFIX}/bin
-
- ${INSTALL_PROGRAM} -o firebird -g firebird -m 6550 \
- ${SUID_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -o root -g firebird -m 4550 \
+ ${WRKSRC}/gen/firebird/bin/fb_lock_mgr ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -m 500 \
+ ${WRKSRC}/gen/firebird/bin/gds_drop ${PREFIX}/bin
@${MKDIR} ${CONFDIR}
${INSTALL_DATA} ${WRKDIR}/aliases.conf ${CONFDIR}/aliases.conf.sample
diff --git a/databases/firebird20-client/Makefile b/databases/firebird20-client/Makefile
index 5e1b77d92b85..84efb7b9bf4e 100644
--- a/databases/firebird20-client/Makefile
+++ b/databases/firebird20-client/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= firebird
+PORTREVISION= 3
PKGNAMESUFFIX= -client
COMMENT= Firebird-2 database client
diff --git a/databases/firebird20-server/Makefile b/databases/firebird20-server/Makefile
index 509df22b931f..c6a7e42cd796 100644
--- a/databases/firebird20-server/Makefile
+++ b/databases/firebird20-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= firebird
PORTVERSION= 2.0.0
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=firebird
@@ -59,8 +59,7 @@ ALL_TARGET= firebird_boot ref_databases msgs libfbembed intl otherfiles \
SUB_FILES= pkg-install pkg-message aliases.conf
-SUID_BIN= fb_inet_server fb_lock_mgr gds_drop
-UTIL_BIN= fb_lock_print gbak gdef gfix gsec gstat nbackup
+UTIL_BIN= fb_inet_server fb_lock_print gbak gdef gfix gsec gstat nbackup
UDF_SO= ib_udf.so fbudf.so
UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
.else
@@ -156,9 +155,10 @@ do-install:
.if !defined(CLIENT_ONLY)
${INSTALL_PROGRAM} ${UTIL_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} ${PREFIX}/bin
-
- ${INSTALL_PROGRAM} -o firebird -g firebird -m 6550 \
- ${SUID_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -o root -g firebird -m 4550 \
+ ${WRKSRC}/gen/firebird/bin/fb_lock_mgr ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -m 500 \
+ ${WRKSRC}/gen/firebird/bin/gds_drop ${PREFIX}/bin
@${MKDIR} ${CONFDIR}
${INSTALL_DATA} ${WRKDIR}/aliases.conf ${CONFDIR}/aliases.conf.sample