aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-17 06:49:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-17 06:49:29 +0000
commit6fb6597c896b7c2d85ae3cf5c992dff59a7205ac (patch)
treeaa66d7bd719f61ac29aba195639af7c69749e352 /databases
parent97fc19df31dd1dfe1159320656deabf02d509846 (diff)
downloadports-6fb6597c896b7c2d85ae3cf5c992dff59a7205ac.tar.gz
ports-6fb6597c896b7c2d85ae3cf5c992dff59a7205ac.zip
- Change PERL_CONFIGURE to "yes" for all values less than or equal to 5.8.0+
With hat: perl
Notes
Notes: svn path=/head/; revision=281878
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBD-FrontBase/Makefile2
-rw-r--r--databases/p5-DBD-Multi/Makefile2
-rw-r--r--databases/p5-DBIx-Class-Loader/Makefile2
-rw-r--r--databases/p5-DBIx-Class-ResultSet-HashRef/Makefile2
-rw-r--r--databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile2
-rw-r--r--databases/p5-DBIx-Class-Schema-Loader/Makefile2
-rw-r--r--databases/p5-DBIx-Class-UUIDColumns/Makefile2
-rw-r--r--databases/p5-DBIx-Class-Validation/Makefile2
-rw-r--r--databases/p5-DBIx-Log4perl/Makefile2
-rw-r--r--databases/p5-DBIx-SearchBuilder/Makefile2
-rw-r--r--databases/p5-Genezzo/Makefile2
-rw-r--r--databases/p5-Iterator-DBI/Makefile2
-rw-r--r--databases/p5-Rose-DB-Object/Makefile2
-rw-r--r--databases/p5-Rose-DB/Makefile2
-rw-r--r--databases/p5-SQL-ReservedWords/Makefile2
-rw-r--r--databases/p5-Template-DBI/Makefile2
16 files changed, 16 insertions, 16 deletions
diff --git a/databases/p5-DBD-FrontBase/Makefile b/databases/p5-DBD-FrontBase/Makefile
index ad9a89196aa9..9a384722774c 100644
--- a/databases/p5-DBD-FrontBase/Makefile
+++ b/databases/p5-DBD-FrontBase/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/lib/libFBCAccess.a:${PORTSDIR}/databases/frontbase
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.6.0+
+PERL_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
MAN3= DBD::FB.3
diff --git a/databases/p5-DBD-Multi/Makefile b/databases/p5-DBD-Multi/Makefile
index 75e795300c3e..6f332242296a 100644
--- a/databases/p5-DBD-Multi/Makefile
+++ b/databases/p5-DBD-Multi/Makefile
@@ -32,7 +32,7 @@ RUN_DEPENDS+= ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Co
${SITE_PERL}/Sys/SigAction.pm:${PORTSDIR}/devel/p5-Sys-SigAction \
${SITE_PERL}/${PERL_ARCH}/Bundle/DBI.pm:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBD::Multi.3
diff --git a/databases/p5-DBIx-Class-Loader/Makefile b/databases/p5-DBIx-Class-Loader/Makefile
index 1451b974d511..cded90291680 100644
--- a/databases/p5-DBIx-Class-Loader/Makefile
+++ b/databases/p5-DBIx-Class-Loader/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= p5-DBI>=1.3:${PORTSDIR}/databases/p5-DBI \
p5-UNIVERSAL-require>=0.10:${PORTSDIR}/devel/p5-UNIVERSAL-require
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBIx::Class::Loader.3 \
DBIx::Class::Loader::DB2.3 \
diff --git a/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile b/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile
index dab01cb5cb71..e3592effba5b 100644
--- a/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile
+++ b/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile
@@ -17,7 +17,7 @@ COMMENT= Adds syntactic sugar to skip the fancy objects
BUILD_DEPENDS= p5-DBIx-Class>=0.04001:${PORTSDIR}/databases/p5-DBIx-Class
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBIx::Class::ResultSet::HashRef.3
diff --git a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
index f24a9993e9a7..19a308cb2fec 100644
--- a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
+++ b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
@@ -26,7 +26,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
LICENSE_COMB= dual
LICENSE= ART20 GPLv2
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBIx::Class::ResultSet::RecursiveUpdate.3
diff --git a/databases/p5-DBIx-Class-Schema-Loader/Makefile b/databases/p5-DBIx-Class-Schema-Loader/Makefile
index 662b7b9c0346..9a122bbb83db 100644
--- a/databases/p5-DBIx-Class-Schema-Loader/Makefile
+++ b/databases/p5-DBIx-Class-Schema-Loader/Makefile
@@ -62,7 +62,7 @@ USE_PGSQL= yes
RUN_DEPENDS+= p5-DBD-Oracle>=0.19:${PORTSDIR}/databases/p5-DBD-Oracle
.endif
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN1= dbicdump.1
MAN3= DBIx::Class::Schema::Loader.3 \
diff --git a/databases/p5-DBIx-Class-UUIDColumns/Makefile b/databases/p5-DBIx-Class-UUIDColumns/Makefile
index c18c7c719da4..44fd69455f0a 100644
--- a/databases/p5-DBIx-Class-UUIDColumns/Makefile
+++ b/databases/p5-DBIx-Class-UUIDColumns/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-
${SITE_PERL}/DBIx/Class.pm:${PORTSDIR}/databases/p5-DBIx-Class
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBIx::Class::UUIDColumns.3 \
DBIx::Class::UUIDColumns::UUIDMaker.3 \
diff --git a/databases/p5-DBIx-Class-Validation/Makefile b/databases/p5-DBIx-Class-Validation/Makefile
index 96f0d1302eab..fe6e433b2d94 100644
--- a/databases/p5-DBIx-Class-Validation/Makefile
+++ b/databases/p5-DBIx-Class-Validation/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Instal
p5-DBIx-Class>=0.07005:${PORTSDIR}/databases/p5-DBIx-Class
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBIx::Class::Validation.3
diff --git a/databases/p5-DBIx-Log4perl/Makefile b/databases/p5-DBIx-Log4perl/Makefile
index 665665a20140..b344acd26f91 100644
--- a/databases/p5-DBIx-Log4perl/Makefile
+++ b/databases/p5-DBIx-Log4perl/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= p5-DBI>=1.50:${PORTSDIR}/databases/p5-DBI \
p5-Log-Log4perl>=1.04:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= DBIx::Log4perl.3
diff --git a/databases/p5-DBIx-SearchBuilder/Makefile b/databases/p5-DBIx-SearchBuilder/Makefile
index 5702ce8e1f6f..03aed9fdc44b 100644
--- a/databases/p5-DBIx-SearchBuilder/Makefile
+++ b/databases/p5-DBIx-SearchBuilder/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/ReturnValue.pm:${PORTSDIR}/devel/p5-Class-Retu
${SITE_PERL}/${PERL_ARCH}/Encode.pm:${PORTSDIR}/converters/p5-Encode
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.7.3+
+PERL_CONFIGURE= yes
MAN3= DBIx::SearchBuilder.3 DBIx::SearchBuilder::Handle.3 \
DBIx::SearchBuilder::Handle::Informix.3 \
diff --git a/databases/p5-Genezzo/Makefile b/databases/p5-Genezzo/Makefile
index 0f9283625223..91d0dab2bc30 100644
--- a/databases/p5-Genezzo/Makefile
+++ b/databases/p5-Genezzo/Makefile
@@ -17,7 +17,7 @@ COMMENT= An extensible database with SQL and DBI
RUN_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= 5.7.3+
+PERL_CONFIGURE= yes
MAN1= gendba.pl.1 genexp.pl.1
MAN3= Genezzo.3 Genezzo::Block::RDBArray.3 \
diff --git a/databases/p5-Iterator-DBI/Makefile b/databases/p5-Iterator-DBI/Makefile
index f268413bc554..fb815c1a7855 100644
--- a/databases/p5-Iterator-DBI/Makefile
+++ b/databases/p5-Iterator-DBI/Makefile
@@ -19,6 +19,6 @@ RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= Iterator::DBI.3
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/databases/p5-Rose-DB-Object/Makefile b/databases/p5-Rose-DB-Object/Makefile
index ea86dda3e849..a57ef7f944cb 100644
--- a/databases/p5-Rose-DB-Object/Makefile
+++ b/databases/p5-Rose-DB-Object/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= p5-Rose-DB>=0.753,1:${PORTSDIR}/databases/p5-Rose-DB \
${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
OPTIONS= FAST_CLONE "use Scalar::Util::Clone (requires perl5.8+)" off
diff --git a/databases/p5-Rose-DB/Makefile b/databases/p5-Rose-DB/Makefile
index e9179ff888cd..3d8f2730ebe5 100644
--- a/databases/p5-Rose-DB/Makefile
+++ b/databases/p5-Rose-DB/Makefile
@@ -27,7 +27,7 @@ BUILD_DEPENDS= p5-Rose-DateTime>=0.532:${PORTSDIR}/devel/p5-Rose-DateTime \
${SITE_PERL}/${PERL_ARCH}/YAML/Syck.pm:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= Rose::DB.3 \
Rose::DB::Cache.3 \
diff --git a/databases/p5-SQL-ReservedWords/Makefile b/databases/p5-SQL-ReservedWords/Makefile
index e8770c2e4f49..d3ec6e23eaaa 100644
--- a/databases/p5-SQL-ReservedWords/Makefile
+++ b/databases/p5-SQL-ReservedWords/Makefile
@@ -17,7 +17,7 @@ COMMENT= Reserved SQL words by ANSI/ISO
BUILD_DEPENDS= ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN1= sqlrw.1
MAN3= SQL::ReservedWords.3 \
diff --git a/databases/p5-Template-DBI/Makefile b/databases/p5-Template-DBI/Makefile
index 79508183c00a..0eede5d6e4dd 100644
--- a/databases/p5-Template-DBI/Makefile
+++ b/databases/p5-Template-DBI/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template
p5-MLDBM>=0:${PORTSDIR}/databases/p5-MLDBM
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+
+PERL_CONFIGURE= yes
MAN3= Template::DBI.3 \
Template::Plugin::DBI.3